summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustus Ranvier <justusranvier@tormail.org>2013-01-24 06:01:01 -0600
committerJustus Ranvier <justusranvier@tormail.org>2013-01-24 06:01:01 -0600
commit7bc5459a6c24846acf322a99ee956d5eea8f9e41 (patch)
tree0ade3fda6a65f5cc907bb145b0d65f9425feb023
parentadd ebuild for v0.87-beta (diff)
downloadjranvier-master.tar.gz
jranvier-master.tar.bz2
jranvier-master.zip
Add ebuild for armory-0.87.2HEADmaster
-rw-r--r--net-misc/armory/armory-0.87.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/armory/armory-0.87.2.ebuild b/net-misc/armory/armory-0.87.2.ebuild
new file mode 100644
index 0000000..0884560
--- /dev/null
+++ b/net-misc/armory/armory-0.87.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit git-2
+
+DESCRIPTION="Armory is an advanced Bitcoin client"
+HOMEPAGE="http://bitcoinarmory.com/"
+
+EGIT_REPO_URI="git://github.com/etotheipi/BitcoinArmory.git"
+EGIT_COMMIT="v0.87.2-beta"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="net-p2p/bitcoin-qt"
+
+DEPEND="dev-python/PyQt4
+ dev-lang/swig
+ dev-python/twisted
+ x11-misc/xdg-utils"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+}
+
+pkg_postinst() {
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_64x64.png armoryicon
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_64x64.png armoryofflineicon
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_green_64x64.png armorytestneticon
+}