summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/bup/bup-0.25-r2.ebuild (renamed from app-backup/bup/bup-0.25-r1.ebuild)11
-rw-r--r--app-backup/bup/bup-9999.ebuild10
2 files changed, 17 insertions, 4 deletions
diff --git a/app-backup/bup/bup-0.25-r1.ebuild b/app-backup/bup/bup-0.25-r2.ebuild
index 1cb2cdc..39cf21b 100644
--- a/app-backup/bup/bup-0.25-r1.ebuild
+++ b/app-backup/bup/bup-0.25-r2.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
-inherit eutils
+EAPI=5
+
+inherit eutils python
DOC_COMMIT="bc21345a527cc446084369861655126f6b0ecd8a"
@@ -30,8 +31,14 @@ DEPEND="|| (
dev-python/pylibacl"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
mv "../bup-${DOC_COMMIT}" bup-man || die
+ python_convert_shebangs -r 2 .
}
src_configure() {
diff --git a/app-backup/bup/bup-9999.ebuild b/app-backup/bup/bup-9999.ebuild
index f3b7fa6..ac8e3f1 100644
--- a/app-backup/bup/bup-9999.ebuild
+++ b/app-backup/bup/bup-9999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
EGIT_REPO_URI="git://github.com/bup/${PN}.git
http://github.com/bup/${PN}.git"
-inherit git-2 eutils
+inherit git-2 eutils python
DESCRIPTION="It backs things up based on the git packfile format"
HOMEPAGE="http://github.com/bup/bup"
@@ -30,8 +30,14 @@ DEPEND="|| (
doc? ( app-text/pandoc )"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
epatch_user
+ python_convert_shebangs -r 2 .
}
src_configure() {