summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/libfm/libfm-9999.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/x11-libs/libfm/libfm-9999.ebuild b/x11-libs/libfm/libfm-9999.ebuild
index 0c49504..5bcd647 100644
--- a/x11-libs/libfm/libfm-9999.ebuild
+++ b/x11-libs/libfm/libfm-9999.ebuild
@@ -5,7 +5,8 @@
EAPI=5
#EGIT_REPO_URI="https://github.com/lxde/${PN}"
-EGIT_REPO_URI="git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/${PN}"
+#EGIT_REPO_URI="git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/${PN}"
+EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
# master seems way too unstable for us to use
#EGIT_BRANCH="1.1"
inherit autotools git-2 fdo-mime vala
@@ -15,7 +16,7 @@ HOMEPAGE="http://pcmanfm.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0/4.0.0" #copy ABI_VERSION because it seems upstream change it randomly
-IUSE="+automount debug doc examples udisks vala"
+IUSE="+automount debug examples udisks vala"
KEYWORDS=""
COMMON_DEPEND=">=dev-libs/glib-2.18:2
@@ -32,9 +33,7 @@ RDEPEND="${COMMON_DEPEND}
)"
DEPEND="${COMMON_DEPEND}
vala? ( $(vala_depend) )
- doc? (
- dev-util/gtk-doc
- )
+ dev-util/gtk-doc
>=dev-util/intltool-0.40
virtual/pkgconfig
sys-devel/gettext"
@@ -44,12 +43,7 @@ DOCS=( AUTHORS TODO )
REQUIRED_USE="udisks? ( automount )"
src_prepare() {
- if ! use doc; then
- sed -ie '/SUBDIRS=/s#docs##' "${S}"/Makefile.am || die "sed failed"
- sed -ie '/^[[:space:]]*docs/d' configure.ac || die "sed failed"
- else
- gtkdocize --copy || die
- fi
+ gtkdocize --copy || die
sed -i -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" \
configure.ac || die "sed failed"
@@ -88,7 +82,7 @@ src_configure() {
$(use_enable debug) \
$(use_enable udisks) \
$(use_enable vala actions) \
- $(use_enable doc gtk-doc) \
+ --enable-gtk-doc \
--with-html-dir=/usr/share/doc/${PF}/html
}