aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-02-21 21:21:08 +0000
committerPaul Healy <lmiphay@gmail.com>2019-02-21 21:21:08 +0000
commit83fc5fe7369dc6ae04b17308fdbfbc78188ffb55 (patch)
tree7e0cebe7328c006eaff1dfa2a739ab66100ba411
parentrevbump grok (diff)
downloadlmiphay-83fc5fe7369dc6ae04b17308fdbfbc78188ffb55.tar.gz
lmiphay-83fc5fe7369dc6ae04b17308fdbfbc78188ffb55.tar.bz2
lmiphay-83fc5fe7369dc6ae04b17308fdbfbc78188ffb55.zip
revbump homeassistant
Signed-off-by: Paul Healy <lmiphay@gmail.com>
-rw-r--r--app-misc/homeassistant-bin/Manifest1
-rw-r--r--app-misc/homeassistant-bin/homeassistant-bin-0.88.0.ebuild131
-rw-r--r--homeassistant.keywords4
3 files changed, 134 insertions, 2 deletions
diff --git a/app-misc/homeassistant-bin/Manifest b/app-misc/homeassistant-bin/Manifest
index 387473d..f6aaff3 100644
--- a/app-misc/homeassistant-bin/Manifest
+++ b/app-misc/homeassistant-bin/Manifest
@@ -8,4 +8,5 @@ EBUILD homeassistant-bin-0.86.3.ebuild 3561 BLAKE2B 4495ab1ce8f8f45b9a497fb58f92
EBUILD homeassistant-bin-0.86.4.ebuild 3561 BLAKE2B 4495ab1ce8f8f45b9a497fb58f9282c6f0d1ed6f74bd941d0ca10fca8c3b0fb88b3ad599de09359746ce06f2944695226873a77b28bd88612aa350dbee147c50 SHA512 6a21fda18fed1efd506f20a176ba81c490fad20dd9ed63165a960e3d55892d6fc6e061a1d92c1ab5f96135a7e2addd672173c7b970e469dd7b6e6222f7d2f540
EBUILD homeassistant-bin-0.87.0.ebuild 3561 BLAKE2B 4495ab1ce8f8f45b9a497fb58f9282c6f0d1ed6f74bd941d0ca10fca8c3b0fb88b3ad599de09359746ce06f2944695226873a77b28bd88612aa350dbee147c50 SHA512 6a21fda18fed1efd506f20a176ba81c490fad20dd9ed63165a960e3d55892d6fc6e061a1d92c1ab5f96135a7e2addd672173c7b970e469dd7b6e6222f7d2f540
EBUILD homeassistant-bin-0.87.1.ebuild 3561 BLAKE2B 4495ab1ce8f8f45b9a497fb58f9282c6f0d1ed6f74bd941d0ca10fca8c3b0fb88b3ad599de09359746ce06f2944695226873a77b28bd88612aa350dbee147c50 SHA512 6a21fda18fed1efd506f20a176ba81c490fad20dd9ed63165a960e3d55892d6fc6e061a1d92c1ab5f96135a7e2addd672173c7b970e469dd7b6e6222f7d2f540
+EBUILD homeassistant-bin-0.88.0.ebuild 3561 BLAKE2B 4495ab1ce8f8f45b9a497fb58f9282c6f0d1ed6f74bd941d0ca10fca8c3b0fb88b3ad599de09359746ce06f2944695226873a77b28bd88612aa350dbee147c50 SHA512 6a21fda18fed1efd506f20a176ba81c490fad20dd9ed63165a960e3d55892d6fc6e061a1d92c1ab5f96135a7e2addd672173c7b970e469dd7b6e6222f7d2f540
EBUILD homeassistant-bin-9999.ebuild 2566 BLAKE2B 8bc81f53fb3cb8744ac59aa48c14e01d442a48fde8ed408b72922f6c921f81b6cacf4ce759a256f720c14416eaf3a62d92bf1f26c1f28919b90743d088908df2 SHA512 cd28376bdc8f7cc988a1ed01e84a03ac4de8bf843a1169ca87ab4e1d9c116a30abec36dc049e34058455e27c7ae96ae6587ac4b13a122565bae7cc718ed990c4
diff --git a/app-misc/homeassistant-bin/homeassistant-bin-0.88.0.ebuild b/app-misc/homeassistant-bin/homeassistant-bin-0.88.0.ebuild
new file mode 100644
index 0000000..cecd39b
--- /dev/null
+++ b/app-misc/homeassistant-bin/homeassistant-bin-0.88.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit user readme.gentoo-r1 eutils distutils-r1 systemd
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="Home automation platform (Python 3 required)"
+HOMEPAGE="https://home-assistant.io"
+SRC_URI="" # pip installs HA version $PV from PyPI
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="maint mysql"
+
+PY_HA="3.6"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ !app-misc/homeassistant
+ dev-lang/python:${PY_HA}
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ mysql? ( dev-python/mysqlclient )
+"
+RDEPEND="
+ ${DEPEND}
+ app-admin/logrotate
+ maint? (
+ app-crypt/certbot
+ app-crypt/ssl-cert-check
+ net-misc/dropbox-uploader
+ virtual/logger
+ )
+"
+
+INSTALL_DIR="/opt/${MY_PN}"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+ The HA interface listens on port 8123 - this _will_ take a minute or two to appear
+
+ hass configuration is in: /etc/${MY_PN}
+ For openrc daemon command line arguments are configured in: /etc/conf.d/${MY_PN}
+
+ logging is to: /var/log/${MY_PN}/{server,errors,stdout}.log
+ For HA logging configuration see: https://www.home-assistant.io/components/logger/
+
+ The sqlite db is by default in: /etc/${MY_PN}
+ To move it after ${MY_PN} has run once and while ${MY_PN} is stopped:
+ - add /etc/${MY_PN}/recorder.yaml to /etc/${MY_PN}/configuration.yaml
+ - mv /etc/${MY_PN}/home-assistant_v2.db /var/db/${MY_PN}
+
+ support thread at:
+ https://community.home-assistant.io/t/gentoo-homeassistant-0-59-2-ebuild/35577
+
+ The script /usr/bin/update-homeassistant can be used to update homeassistant-bin (it keeps
+ a backup of the previous virtualenv under /opt). The script is for openrc only at the moment.
+"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ enewgroup "${MY_PN}"
+ enewuser "${MY_PN}" -1 -1 "$INSTALL_DIR" "${MY_PN}"
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin "${FILESDIR}/update-homeassistant"
+
+ keepdir "$INSTALL_DIR"
+
+ keepdir "/etc/${MY_PN}"
+ insinto "/etc/${MY_PN}"
+ doins "${FILESDIR}/recorder.yaml"
+ fowners -R "${MY_PN}:${MY_PN}" "/etc/${MY_PN}"
+
+ "python${PY_HA}" -m venv "${D}/$INSTALL_DIR"
+ # for no output from pip add: --quiet
+ # note the venv has a python3, but no python3.x
+ VIRTUAL_ENV="$INSTALL_DIR" "${D}/$INSTALL_DIR/bin/python3" -m pip --no-cache-dir install "${MY_PN}==${PV}" || die
+ sed -i "1c#!$INSTALL_DIR/bin/python3" "${D}/$INSTALL_DIR/bin/hass"
+ fowners -R "${MY_PN}:${MY_PN}" "$INSTALL_DIR"
+
+ if use mysql ; then
+ VIRTUAL_ENV="$INSTALL_DIR" "${D}/$INSTALL_DIR/bin/python3" -m pip --no-cache-dir install "mysqlclient" || die
+ fi
+
+ newconfd "${FILESDIR}/${MY_PN}.conf.d" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.init.d" "${MY_PN}"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${MY_PN}.logrotate" "${MY_PN}"
+
+ keepdir "/var/log/${MY_PN}/old"
+ fowners -R "${MY_PN}:${MY_PN}" "/var/log/${MY_PN}"
+
+ keepdir "/var/db/${MY_PN}"
+ fowners -R "${MY_PN}:${MY_PN}" "/var/db/${MY_PN}"
+
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ elog "homeassistant requires python 3.5 (or later)"
+ elog ""
+ elog "This ebuild installs homeassistant into a virtualenv built for:"
+ elog ""
+ elog " python ${PY_HA} (the current python 3.x in gentoo PYTHON_TARGETS)"
+ elog ""
+ elog "If you have previously run homeassistant with an older version of "
+ elog "python, then it is recommended that you do a clean install on moving to"
+ elog "python ${PY_HA}."
+
+ readme.gentoo_print_elog
+}
+
+pkg_config() {
+ "${INSTALL_DIR}/bin/hass" --script ensure_config
+}
diff --git a/homeassistant.keywords b/homeassistant.keywords
index 7a80e26..1651485 100644
--- a/homeassistant.keywords
+++ b/homeassistant.keywords
@@ -1,5 +1,5 @@
-#=app-misc/homeassistant-bin-0.87.0 ~amd64
-=app-misc/homeassistant-bin-0.87.1 ~amd64
+#=app-misc/homeassistant-bin-0.87.1 ~amd64
+=app-misc/homeassistant-bin-0.88.0 ~amd64
# from portage
=dev-python/certifi-2017.11.5 ~amd64