summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukas Elsner <open@mindrunner.de>2015-10-26 20:00:58 +0100
committerLukas Elsner <open@mindrunner.de>2015-10-26 20:00:58 +0100
commit7c30ad677da8c86b3ee833318656d997a90e6d29 (patch)
treed8c0d18b9ad1c06020e0549e6b63b3c9de7b8bab
parentforce insyncs libevent version (diff)
downloadluman-7c30ad677da8c86b3ee833318656d997a90e6d29.tar.gz
luman-7c30ad677da8c86b3ee833318656d997a90e6d29.tar.bz2
luman-7c30ad677da8c86b3ee833318656d997a90e6d29.zip
added missing file
-rw-r--r--app-backup/insync-bin/insync-bin-1.3.2-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-backup/insync-bin/insync-bin-1.3.2-r2.ebuild b/app-backup/insync-bin/insync-bin-1.3.2-r2.ebuild
new file mode 100644
index 0000000..64fccbf
--- /dev/null
+++ b/app-backup/insync-bin/insync-bin-1.3.2-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit rpm
+
+DESCRIPTION="Advanced cross-platform Google Drive client"
+HOMEPAGE="https://www.insynchq.com/"
+MAGIC="36049"
+MAIN_INSTALLER_STRING="http://s.insynchq.com/builds/insync-${PV}.${MAGIC}-fc21"
+SRC_URI="
+ x86? ( ${MAIN_INSTALLER_STRING}.i686.rpm )
+ amd64? ( ${MAIN_INSTALLER_STRING}.x86_64.rpm )"
+
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+DEPEND="<dev-libs/libevent-2.1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ rpm_src_unpack ${A}
+ mkdir -p "${S}" # Without this src_prepare fails
+}
+
+src_install() {
+ cp -pPR "${WORKDIR}"/{usr,etc} "${D}"/ || die "Installation failed"
+
+ echo "SEARCH_DIRS_MASK=\"/usr/lib*/insync\"" > "${T}/70${PN}" || die
+ insinto "/etc/revdep-rebuild" && doins "${T}/70${PN}" || die
+}
+
+pkg_postinst() {
+ elog "To automatically start insync add 'insync start' to your session"
+ elog "startup scripts. GNOME users can also choose to enable"
+ elog "the insync extension via gnome-tweak-tool."
+}