aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel de Oliveira <menelkir@itroll.org>2010-05-31 10:04:38 -0300
committerDaniel de Oliveira <menelkir@itroll.org>2010-05-31 10:04:38 -0300
commitf729af2e33dc6c4abdd5ea4ff69b4917748be5be (patch)
treec0c15630ea07dff6a6c98f7e80a9c2692834cfd3
parentfirst commit (diff)
downloadmenelkir-f729af2e33dc6c4abdd5ea4ff69b4917748be5be.tar.gz
menelkir-f729af2e33dc6c4abdd5ea4ff69b4917748be5be.tar.bz2
menelkir-f729af2e33dc6c4abdd5ea4ff69b4917748be5be.zip
new file: app-admin/webmin/ChangeLog
new file: app-admin/webmin/Manifest new file: app-admin/webmin/files/init.d.webmin new file: app-admin/webmin/files/webmin-1.170-setup-nocheck.patch new file: app-admin/webmin/files/webmin-pam new file: app-admin/webmin/webmin-1.510.ebuild
-rw-r--r--app-admin/webmin/ChangeLog9
-rw-r--r--app-admin/webmin/Manifest7
-rw-r--r--app-admin/webmin/files/init.d.webmin40
-rw-r--r--app-admin/webmin/files/webmin-1.170-setup-nocheck.patch21
-rw-r--r--app-admin/webmin/files/webmin-pam5
-rw-r--r--app-admin/webmin/webmin-1.510.ebuild118
-rw-r--r--test0
7 files changed, 200 insertions, 0 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
new file mode 100644
index 0000000..57e708e
--- /dev/null
+++ b/app-admin/webmin/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-admin/webmin
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.188 2010/01/08 17:50:14 a3li Exp $
+
+*webmin-1.510 (31 May 2010)
+
+ 31 May 2010; Daniel Oliveira <menelkir@itroll.org> +webmin-1.510.ebuild:
+ Bump (unmaintained by official tree)
+
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
new file mode 100644
index 0000000..0289021
--- /dev/null
+++ b/app-admin/webmin/Manifest
@@ -0,0 +1,7 @@
+AUX init.d.webmin 880 RMD160 9aab2eb11c28dfde803f5e5913ed7003fb2e8e0e SHA1 02d0708fc712b3f1c6702a0b4a26472b2878d8ca SHA256 aa09a0e8810611146f35f7c954f5c72449c7ea14b9d4b19d0591560a7a2d95de
+AUX webmin-1.170-setup-nocheck.patch 943 RMD160 a6fdb34184261c63ed738f9435c4a31f4d988cff SHA1 216b214a5d4042af7fe293a6ee4191d5de70bf73 SHA256 5bb71c9a5eb76d98757b2892cd3a0b656593f5136d5109f49bc7191b9a7f3aa1
+AUX webmin-pam 128 RMD160 ee4f2cd70ed2bcaa7e4865fae26ac5c14c36c620 SHA1 91b34c1424bf69a1f8e292193e1a5e2add814a97 SHA256 fcb5cc28ad0db83e96652241621b27782fa71aeea5576cb67f2c7f5ccfaed4af
+DIST webmin-1.510-minimal.tar.gz 1703326 RMD160 23986b606094c616c8cc1ddf1bf303c4237d3840 SHA1 b75c0c7e3d1742f0a3195e950641eb4151b2c3aa SHA256 31775b943bddd7ec924b6d1e332a58cdd6291a396e763e17894b9db620688cde
+DIST webmin-1.510.tar.gz 14841163 RMD160 abb75b21849473cd0f8287fcfadd2ed4f0789893 SHA1 53587ec6555e448c5aa3719bd50a855204a4c38c SHA256 92c6ebff7c6bd5d12031f799146e4a919c0fccdd117eef6c5a7447f313703900
+EBUILD webmin-1.510.ebuild 3617 RMD160 5fc37789d34667bb4b4b238390fa4ac0015dcdbb SHA1 6b1fb1bd0f17fec7c829a0401a910763f9695592 SHA256 c0dd89c06a3140979b8b75562d59511ec5534241950d2d67f0c922d985bb3b5f
+MISC ChangeLog 349 RMD160 1e28a7d2bc9733262652ef2e3332ba76084b44ec SHA1 a54d491a21a7cb17a40112391f9ff6ea5d23dedf SHA256 897e29c0666d47bfdb6562c75703cd06b88cb98812db3d9f78312fe56c39e3c0
diff --git a/app-admin/webmin/files/init.d.webmin b/app-admin/webmin/files/init.d.webmin
new file mode 100644
index 0000000..7649891
--- /dev/null
+++ b/app-admin/webmin/files/init.d.webmin
@@ -0,0 +1,40 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/files/init.d.webmin,v 1.6 2007/10/30 10:36:07 uberlord Exp $
+
+depend() {
+ use net logger
+}
+
+
+checkconfig() {
+ if [ ! -f /etc/webmin/config ]; then
+ eerror "Error starting webmin. /etc/webmin/config is not present."
+ eerror "Please report this on http://bugs.gentoo.org."
+ return 1
+ fi
+
+ return 0
+}
+
+start() { # copied from /etc/usermin/start
+ checkconfig || return 1
+ ebegin "Starting Webmin"
+
+ LANG=
+ export LANG
+
+ unset PERLIO
+ export PERLIO
+ start-stop-daemon --start --exec /usr/libexec/webmin/miniserv.pl \
+ --pidfile /var/run/webmin.pid \
+ -- /etc/webmin/miniserv.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Webmin"
+ start-stop-daemon --stop --quiet --pidfile /var/run/webmin.pid
+ eend $?
+}
diff --git a/app-admin/webmin/files/webmin-1.170-setup-nocheck.patch b/app-admin/webmin/files/webmin-1.170-setup-nocheck.patch
new file mode 100644
index 0000000..6bc3c4d
--- /dev/null
+++ b/app-admin/webmin/files/webmin-1.170-setup-nocheck.patch
@@ -0,0 +1,21 @@
+--- webmin-1.170/setup.sh.orig 2004-12-31 14:40:55.956541085 -0800
++++ webmin-1.170/setup.sh 2004-12-31 14:41:23.431018153 -0800
+@@ -356,12 +356,12 @@
+ echo ""
+ exit 12
+ fi
+- $perl -e 'use Socket; socket(FOO, PF_INET, SOCK_STREAM, getprotobyname("tcp")); setsockopt(FOO, SOL_SOCKET, SO_REUSEADDR, pack("l", 1)); bind(FOO, pack_sockaddr_in($ARGV[0], INADDR_ANY)) || exit(1); exit(0);' $port
+- if [ $? != "0" ]; then
+- echo "ERROR: TCP port $port is already in use by another program"
+- echo ""
+- exit 13
+- fi
++ #$perl -e 'use Socket; socket(FOO, PF_INET, SOCK_STREAM, getprotobyname("tcp")); setsockopt(FOO, SOL_SOCKET, SO_REUSEADDR, pack("l", 1)); bind(FOO, pack_sockaddr_in($ARGV[0], INADDR_ANY)) || exit(1); exit(0);' $port
++ #if [ $? != "0" ]; then
++ # echo "ERROR: TCP port $port is already in use by another program"
++ # echo ""
++ # exit 13
++ #fi
+ printf "Login name (default admin): "
+ if [ "$login" = "" ]; then
+ read login
diff --git a/app-admin/webmin/files/webmin-pam b/app-admin/webmin/files/webmin-pam
new file mode 100644
index 0000000..c9a20b0
--- /dev/null
+++ b/app-admin/webmin/files/webmin-pam
@@ -0,0 +1,5 @@
+#%PAM-1.0
+auth include system-auth
+auth required pam_unix.so nullok
+account required pam_unix.so
+session required pam_unix.so
diff --git a/app-admin/webmin/webmin-1.510.ebuild b/app-admin/webmin/webmin-1.510.ebuild
new file mode 100644
index 0000000..360b10a
--- /dev/null
+++ b/app-admin/webmin/webmin-1.510.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.500.ebuild,v 1.1 2009/12/09 14:51:49 patrick Exp $
+
+inherit eutils pam
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+HOMEPAGE="http://www.webmin.com/"
+SRC_URI="minimal? ( mirror://sourceforge/webadmin/${P}-minimal.tar.gz )
+ !minimal? ( mirror://sourceforge/webadmin/${P}.tar.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+# ~mips removed because of broken deps. Bug #86085
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="apache2 mysql pam postgres ssl minimal"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ ssl? ( dev-perl/Net-SSLeay )
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ pam? ( dev-perl/Authen-PAM )
+ dev-perl/XML-Generator
+ virtual/logger"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.170-setup-nocheck.patch
+}
+
+src_install() {
+ # Bug #97212
+ addpredict /var/lib/rpm
+ # Bug #249904
+ addpredict /dev/mapper/control
+ addpredict /etc/lvm/cache
+ # Bug #194305
+ addpredict /var/spool/cron/crontabs
+ # Bug 267996
+ addpredict /lib/modules/$(uname -r)/kernel/net
+
+ rm -f mount/freebsd-mounts*
+ rm -f mount/netbsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /var
+
+ cp -rp * "${D}"/usr/libexec/webmin
+
+ # in webmin-minimal openslp is not present
+ if [ ! -f "${D}/usr/libexec/webmin/openslp/config-gentoo-linux" ] ; then
+ cp "${D}"/usr/libexec/webmin/openslp/config \
+ "${D}"/usr/libexec/webmin/openslp/config-gentoo-linux
+ fi
+
+ newinitd "${FILESDIR}"/init.d.webmin webmin
+
+ newpamd "${FILESDIR}"/webmin-pam webmin
+ echo gentoo > "${D}"/usr/libexec/webmin/install-type
+
+ # Fix ownership
+ chown -R root:0 "${D}"
+
+ dodir /etc/webmin
+ dodir /var/log/webmin
+
+ config_dir="${D}"/etc/webmin
+ var_dir="${D}"/var/log/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ "${D}"/usr/libexec/webmin/setup.sh > "${T}"/webmin-setup.out 2>&1 || die "Failed to create initial webmin configuration."
+
+ # Fixup the config files to use their real locations
+ sed -i -e "s:^pidfile=.*$:pidfile=/var/run/webmin.pid:" "${D}"/etc/webmin/miniserv.conf
+ find "${D}"/etc/webmin -type f | xargs sed -i -e "s:${D}:/:g"
+
+ # Cleanup from the config script
+ rm -rf "${D}"/var/log/webmin
+ keepdir /var/log/webmin/
+
+ # Get rid of this crap...
+ rm -rf "${D}"/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1
+ rm -f "${D}"/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1.tar.gz
+}
+
+pkg_postinst() {
+ local crypt=$(grep "^root:" "${ROOT}"/etc/shadow | cut -f 2 -d :)
+ crypt=${crypt//\\/\\\\}
+ crypt=${crypt//\//\\\/}
+ sed -i -e "s/root:XXX/root:${crypt}/" "${ROOT}/etc/webmin/miniserv.users"
+
+ einfo "To make webmin start at boot time, run: 'rc-update add webmin default'."
+ use ssl && einfo "Point your web browser to https://localhost:10000 to use webmin."
+ use ssl || einfo "Point your web browser to http://localhost:10000 to use webmin."
+
+ einfo "NOTE: virtual-server has been removed from this ebuild."
+ elog "To create a login account for webmin named \"admin\", execute the "
+ elog "following command:"
+ elog "/usr/libexec/webmin/changepass.pl /etc/webmin admin <new_password>"
+}
diff --git a/test b/test
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test