summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-02-15 09:21:46 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:21 +0200
commit5ac74c93839e0f8a12c287fc41f7a2940e7eef50 (patch)
treef80cade2352ec4b3cca3771552f566a8d861caab
parentavoid use_if_iuse. Bump epubreader, classic-theme-restorer, noscript (diff)
downloadmv-5ac74c93839e0f8a12c287fc41f7a2940e7eef50.tar.gz
mv-5ac74c93839e0f8a12c287fc41f7a2940e7eef50.tar.bz2
mv-5ac74c93839e0f8a12c287fc41f7a2940e7eef50.zip
Fix python-single-r1 usage. Introduce etc-crontab-systemd and block dcron
-rw-r--r--dev-cpp/cpplint/ChangeLog3
-rw-r--r--dev-cpp/cpplint/cpplint-141-r1.ebuild5
-rw-r--r--dev-util/pyrep/ChangeLog3
-rw-r--r--dev-util/pyrep/pyrep-1.4-r1.ebuild5
-rw-r--r--profiles/use.local.desc2
-rw-r--r--sys-process/systemd-cron/ChangeLog4
-rw-r--r--sys-process/systemd-cron/metadata.xml2
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.2.ebuild28
8 files changed, 30 insertions, 22 deletions
diff --git a/dev-cpp/cpplint/ChangeLog b/dev-cpp/cpplint/ChangeLog
index 025756f0..4b754f64 100644
--- a/dev-cpp/cpplint/ChangeLog
+++ b/dev-cpp/cpplint/ChangeLog
@@ -4,6 +4,9 @@
*cpplint-141-r1 (18 Jan 2015)
+ 15 Feb 2015; Martin Väth <martin@mvath.de>:
+ Fix python-single-r1 usage. Remove non-working python versions
+
18 Jan 2014; Martin Väth <martin@mvath.de>:
Use new-style python dependency. Fix shebang
diff --git a/dev-cpp/cpplint/cpplint-141-r1.ebuild b/dev-cpp/cpplint/cpplint-141-r1.ebuild
index 195c19a2..3af580ed 100644
--- a/dev-cpp/cpplint/cpplint-141-r1.ebuild
+++ b/dev-cpp/cpplint/cpplint-141-r1.ebuild
@@ -3,8 +3,8 @@
# $Header: $
EAPI=5
-PYTHON_COMPAT=( jython2_{5,7} pypy{,3} python{2_7,3_{3,4}} )
-inherit elisp-common eutils python-r1
+PYTHON_COMPAT=( jython2_7 pypy python2_7 )
+inherit elisp-common eutils python-single-r1
RESTRICT="mirror"
SUBVERSION_REVISION="r=${PV}"
@@ -59,6 +59,7 @@ src_prepare() {
use prefix || sed -i \
-e '1s"^#!/usr/bin/env python$"#!'"${EPREFIX}/usr/bin/python"'"' \
-- "${PN}.py" || die
+ python_fix_shebang "${S}"
epatch_user
}
diff --git a/dev-util/pyrep/ChangeLog b/dev-util/pyrep/ChangeLog
index 03d515b6..597acaa2 100644
--- a/dev-util/pyrep/ChangeLog
+++ b/dev-util/pyrep/ChangeLog
@@ -4,6 +4,9 @@
*pyrep-1.4-r1 (18 Jan 2015)
+ 15 Feb 2015; Martin Väth <martin@mvath.de>:
+ Fix python-single-r1 usage
+
18 Jan 2015; Martin Väth <martin@mvath.de>:
Use new-style python dependency
diff --git a/dev-util/pyrep/pyrep-1.4-r1.ebuild b/dev-util/pyrep/pyrep-1.4-r1.ebuild
index 71807f45..343a60ad 100644
--- a/dev-util/pyrep/pyrep-1.4-r1.ebuild
+++ b/dev-util/pyrep/pyrep-1.4-r1.ebuild
@@ -4,8 +4,8 @@
EAPI=5
RESTRICT="mirror"
-PYTHON_COMPAT=( jython2_{5,7} pypy{,3} python{2_7,3_{3,4}} )
-inherit eutils python-r1
+PYTHON_COMPAT=( jython2_7 pypy{,3} python{2_7,3_{3,4}} )
+inherit eutils python-single-r1
DESCRIPTION="Search and/or replace regular expressions within many files interactively"
HOMEPAGE="https://github.com/vaeth/pyrep/"
@@ -20,6 +20,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}"
src_prepare() {
+ python_fix_shebang "${S}"
use prefix || sed -i \
-e '1s"^#!/usr/bin/env python$"#!'"${EPREFIX}/usr/bin/python"'"' \
-- "${PN}" || die
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index decadeb3..3c59d6f1 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -115,7 +115,7 @@ sys-fs/squash_dir:unionfs-fuse - Prefer unionfs-fuse
sys-fs/squashfs-tools:lz4 - Enable support for LZ4 compression using app-arch/lz4
sys-fs/squashfs-tools:xz - Enable support for XZ ("LZMA2") compression using app-arch/xz-utils
sys-process/systemd-cron:cron-boot - Enable systemd boot cron target
-sys-process/systemd-cron:etc-crontab - Use /etc/crontab; disable this when you have the sys-process/dcron default file here
+sys-process/systemd-cron:etc-crontab-systemd - Use /etc/crontab-systemd instead of /etc/crontab to avoid format conflict with sys-process/dcron
sys-process/systemd-cron:minutely - Enable systemd minutely cron target
sys-process/systemd-cron:setgid - Install a cron setgid helper to allow users editing crontabs
sys-process/systemd-cron:yearly - Enable systemd yearly/semi-annually/quarterly cron target
diff --git a/sys-process/systemd-cron/ChangeLog b/sys-process/systemd-cron/ChangeLog
index c4b730df..2c19acdc 100644
--- a/sys-process/systemd-cron/ChangeLog
+++ b/sys-process/systemd-cron/ChangeLog
@@ -4,6 +4,10 @@
*systemd-cron-1.5.2 (22 Dec 2014)
+ 15 Feb 2015; Martin Väth <martin@mvath.de>:
+ Remove etc-crontab; instead, introduce etc-crontab-systemd and a dcron block.
+ Fix python-single-r1 usage
+
12 Dec 2014; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild
diff --git a/sys-process/systemd-cron/metadata.xml b/sys-process/systemd-cron/metadata.xml
index fcc68f9e..d9f7269a 100644
--- a/sys-process/systemd-cron/metadata.xml
+++ b/sys-process/systemd-cron/metadata.xml
@@ -15,7 +15,7 @@
</upstream>
<use>
<flag name="cron-boot">Enable systemd boot cron target</flag>
- <flag name="etc-crontab">Use /etc/crontab; disable this when you have the sys-process/dcron default file here</flag>
+ <flag name="etc-crontab-systemd">Use /etc/crontab-systemd instead of /etc/crontab to avoid format conflict with sys-process/dcron</flag>
<flag name="setgid">Install a cron setgid helper to allow users editing crontabs</flag>
<flag name="minutely">Enable systemd minutely cron target</flag>
<flag name="yearly">Enable systemd yearly/semi-annually/quarterly cron target</flag>
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.2.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.2.ebuild
index a2407edb..ebf0be09 100644
--- a/sys-process/systemd-cron/systemd-cron-1.5.2.ebuild
+++ b/sys-process/systemd-cron/systemd-cron-1.5.2.ebuild
@@ -14,28 +14,33 @@ SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="cron-boot +etc-crontab minutely setgid yearly"
+IUSE="cron-boot etc-crontab-systemd minutely setgid yearly"
COMMON_DEPEND="sys-process/cronbase"
RDEPEND=">=sys-apps/systemd-217
sys-apps/debianutils
+ !etc-crontab-systemd? ( !sys-process/dcron )
+ ${PYTHON_DEPS}
${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_prepare() {
- python_setup
python_fix_shebang --force "${S}/src/bin"
sed -i \
-e 's/^crontab/crontab-systemd/' \
-e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
- "${S}/src/man/crontab."{1,5}".in" || die
+ -- "${S}/src/man/crontab."{1,5}".in" || die
sed -i \
-e 's!/crontab$!/crontab-systemd!' \
-e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
- "${S}/Makefile.in" || die
- use etc-crontab || sed -i \
- -e "s!/etc/crontab!/dev/null!" \
- "${S}/src/bin/systemd-crontab-generator.py" || die
+ -- "${S}/Makefile.in" || die
+ if use etc-crontab-systemd
+ then sed -i \
+ -e "s!/etc/crontab!/etc/crontab-systemd!" \
+ -- "${S}/src/man/crontab."{1,5}".in" \
+ "${S}/src/bin/systemd-crontab-generator.py" || die
+ fi
epatch_user
}
@@ -61,12 +66,3 @@ src_configure() {
$(my_use_enable setgid) \
--enable-persistent=yes
}
-
-pkg_postinst() {
- if use etc-crontab && {
- has_version sys-process/dcron || ! has_version virtual/cron
- }
- then ewarn "sys-process/systemd-cron[etc-crontab] does not work with the /etc/crontab"
- ewarn "installed by sys-process/dcron"
- fi
-}