summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-08-13 16:17:04 +0200
committerMartin Väth <martin@mvath.de>2018-08-13 16:17:04 +0200
commit75d039db75b9e9752073310938ec559c8fc06d3e (patch)
tree2cdd7f3f1b8fa51b4219271ce8c55c0b21e6e11b
parenteclass: add @SUPPORTED_EAPIS (diff)
downloadmv-75d039db75b9e9752073310938ec559c8fc06d3e.tar.gz
mv-75d039db75b9e9752073310938ec559c8fc06d3e.tar.bz2
mv-75d039db75b9e9752073310938ec559c8fc06d3e.zip
sys-block/zram-init: Version bump to 8.0
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--sys-block/zram-init/Manifest1
-rw-r--r--sys-block/zram-init/zram-init-8.0.ebuild48
3 files changed, 50 insertions, 1 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 79131013..a18884c7 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -104,7 +104,7 @@ sys-apps/paxopen 1.2: A wrapper script to set PAX kernel variables to an insecur
sys-apps/schedule 8.0-r1: script to schedule jobs in a multiuser multitasking environment
sys-apps/starter 3.0: POSIX shell script and function to schedule commands
sys-block/parted 2.4-r2: Create, destroy, resize, check, copy partitions and file systems
-sys-block/zram-init 7.1-r2: Scripts to support compressed swap devices or ramdisks with zram
+sys-block/zram-init 7.1-r2 8.0: Scripts to support compressed swap devices or ramdisks with zram
sys-boot/grub-cfg-mv 1.5: A grub.cfg library/example for GRUB2
sys-fs/emount 3.0.4: mount/unmount create/remove dm-crypt filesystems according to your /etc/fstab
sys-fs/squash_dir 13.14: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
diff --git a/sys-block/zram-init/Manifest b/sys-block/zram-init/Manifest
index 59fb2bc5..33b76b2d 100644
--- a/sys-block/zram-init/Manifest
+++ b/sys-block/zram-init/Manifest
@@ -1 +1,2 @@
DIST zram-init-7.1.tar.gz 9054 SHA512 6a9a6568d1c439f941401cb5638645a034a3cb29aaafa0d7595ad19fe7c50296e72c6751393eaa5cd8877b0d2bd0376339fb0f596c9517f9b17d425cc9c5ed53
+DIST zram-init-8.0.tar.gz 9125 SHA512 d8efb796f14482b389db940fda1cc2d3869fa139bb3d60d282fb4bfa9ee6f7adb93801c6e22860bf1eb1a2b1c4715681418f916ae7a96c1fe58ef003365eed34
diff --git a/sys-block/zram-init/zram-init-8.0.ebuild b/sys-block/zram-init/zram-init-8.0.ebuild
new file mode 100644
index 00000000..78f9a045
--- /dev/null
+++ b/sys-block/zram-init/zram-init-8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1 systemd
+
+DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
+HOMEPAGE="https://github.com/vaeth/zram-init/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/push-2.0-r2
+ !<sys-apps/openrc-0.13"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
+ rc-config add zram default
+If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
+You might need to modify /etc/modprobe.d/zram.conf"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- sbin/* || die
+ default
+}
+
+src_install() {
+ doinitd openrc/init.d/*
+ doconfd openrc/conf.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc/modprobe.d
+ doins modprobe.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc AUTHORS ChangeLog README.md
+ readme.gentoo_create_doc
+ into /
+ dosbin sbin/*
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}