summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-01-18 12:50:47 +0100
committerMartin Väth <martin@mvath.de>2018-01-18 12:50:47 +0100
commitd01259ef2edae613c4e43907493cae37d25439fc (patch)
treeb62e272bb74d218b6207bf4f8ff9d6fe6600e7cb
parentapp-text/stardict: use slotted enchant dependency (diff)
downloadmv-d01259ef2edae613c4e43907493cae37d25439fc.tar.gz
mv-d01259ef2edae613c4e43907493cae37d25439fc.tar.bz2
mv-d01259ef2edae613c4e43907493cae37d25439fc.zip
x11-libs/gtk+: Version bump
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--x11-libs/gtk+/Manifest2
-rw-r--r--x11-libs/gtk+/files/gtk+-3.22.20-libcloudproviders-automagic.patch57
-rw-r--r--x11-libs/gtk+/gtk+-2.24.31-r1.ebuild11
-rw-r--r--x11-libs/gtk+/gtk+-3.22.19.ebuild15
-rw-r--r--x11-libs/gtk+/gtk+-3.22.26.ebuild (renamed from x11-libs/gtk+/gtk+-3.22.16.ebuild)24
6 files changed, 85 insertions, 26 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index acf4d437..587ff167 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -137,7 +137,7 @@ www-plugins/translate-to-me 1.1: Firefox webextension: translate the selected te
www-plugins/ublock-origin 1.14.24: Firefox webextension: An efficient list-based blocker
www-plugins/xclear 1.8.2-r1: Firefox legacy add-on: button to clear URL
x11-drivers/nvidia-drivers 173.14.39-r2: NVIDIA Accelerated Graphics Driver
-x11-libs/gtk+ 2.24.31-r1 3.22.16 3.22.19: Gimp ToolKit +
+x11-libs/gtk+ 2.24.31-r1 3.22.19 3.22.26: Gimp ToolKit +
x11-libs/motif 2.3.7: The Motif user interface component toolkit
x11-misc/redshift 1.8: A screen color temperature adjusting software
x11-wm/fvwm 2.6.7-r1: An extremely powerful ICCCM-compliant multiple virtual desktop window manager
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index 45a64127..f79298fa 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,3 +1,3 @@
DIST gtk+-2.24.31.tar.xz 12805344 SHA512 75b846661308d94b5236e7e1c367deabf57753792ca87e92f9769822dd5ec90e00cd8d5574adcc12162e3702e1ae6dc152278a1d218f9bd9e4d1c8dc1dd520c1
-DIST gtk+-3.22.16.tar.xz 18655144 SHA256 3e0c3ad01f3c8c5c9b1cc1ae00852bd55164c8e5a9c1f90ba5e07f14f175fe2c SHA512 a981ba3c420db649645787916d603a22f1da9d839aba39f3786bab47f9a247867d94d342ce4c3aa47de4876072ed9cf3615304a73de7e613063cef08b8c0d612
DIST gtk+-3.22.19.tar.xz 18841024 SHA512 c83198794433ee6eb29f8740d59bd7056cd36808b4bff1a99563ab1a1742e6635dab4f2a8be33317f74d3b336f0d1adc28dd91410da056b50a08c215f184dce2
+DIST gtk+-3.22.26.tar.xz 18922136 SHA512 2fd3a4175168d37f243359bac5df84722a2830fe5b62f86b914ce39ff500f0361e412843922343dffef8bee8f1205799ff86dd3ae8ac419928f4fe977e0e946f
diff --git a/x11-libs/gtk+/files/gtk+-3.22.20-libcloudproviders-automagic.patch b/x11-libs/gtk+/files/gtk+-3.22.20-libcloudproviders-automagic.patch
new file mode 100644
index 00000000..8913bc88
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-3.22.20-libcloudproviders-automagic.patch
@@ -0,0 +1,57 @@
+From 4588c9c6463d8958d8305caafa58ea5c263fd352 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 16 Jan 2018 09:07:38 +0100
+Subject: [PATCH] Fix libcloudproviders check
+
+Use autotools managed variables and make use of pkgconfig macros.
+---
+ configure.ac | 26 +++++++++++++-------------
+ 1 file changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 24110386b4..cebe66c2e5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -349,8 +349,10 @@ AC_ARG_ENABLE(mir-backend,
+
+ AC_ARG_ENABLE(cloudproviders,
+ [AS_HELP_STRING([--enable-cloudproviders],
+- [enable libcloudproviders integration])],
+- [cloudproviders_set=yes])
++ [enable libcloudproviders integration])
++ ],
++ [],
++ [enable_cloudproviders=yes])
+
+ if test -z "$backend_set"; then
+ if test "$platform_win32" = yes; then
+@@ -1350,17 +1352,15 @@ fi
+ # Check for libcloudproviders
+
+ CLOUDPROVIDER_PACKAGES=""
+-if test "x$cloudproviders_set" = "xyes"; then
+- CLOUDPROVIDER_PACKAGES="cloudproviders >= cloudproviders_required_version"
+- if $PKG_CONFIG --exists $CLOUDPROVIDER_PACKAGES ; then
+- AC_DEFINE(HAVE_CLOUDPROVIDERS, [1],
+- [Define if libcloudproviders is available]
+- )
+- else
+- AC_MSG_ERROR([
+-*** libcloudproviders not found.])
+- fi
+-fi
++AS_IF([test "$enable_cloudproviders" = "yes"],
++ [
++ CLOUDPROVIDER_PACKAGES="cloudproviders >= cloudproviders_required_version"
++ PKG_CHECK_EXISTS(
++ [$CLOUDPROVIDER_PACKAGES],
++ [AC_DEFINE(HAVE_CLOUDPROVIDERS, [1], [Define if libcloudproviders is available])],
++ [AC_MSG_ERROR([*** libcloudproviders not found])]
++ )
++ ])
+
+ CFLAGS="$saved_cflags"
+ LDFLAGS="$saved_ldflags"
+--
+2.15.1
+
diff --git a/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild b/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild
index 857f5440..32cad32d 100644
--- a/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017 Gentoo Foundation
+# Copyright 2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,7 +7,7 @@ GNOME2_LA_PUNT="yes"
inherit autotools eutils flag-o-matic gnome2 multilib multilib-minimal readme.gentoo-r1 virtualx
DESCRIPTION="Gimp ToolKit +"
-HOMEPAGE="http://www.gtk.org/"
+HOMEPAGE="https://www.gtk.org/"
LICENSE="LGPL-2+"
SLOT="2"
@@ -16,7 +16,7 @@ REQUIRED_USE="
xinerama? ( !aqua )
"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# Upstream wants us to do their job:
# https://bugzilla.gnome.org/show_bug.cgi?id=768663#c1
@@ -222,8 +222,7 @@ multilib_src_install_all() {
# Also set more default variables in sync with gtk3 and other distributions
echo 'gtk-fallback-icon-theme = "gnome"' > "${T}/gtkrc"
echo 'gtk-theme-name = "Adwaita"' >> "${T}/gtkrc"
- if use adwaita-icon-theme
- then
+ if use adwaita-icon-theme ; then
echo 'gtk-icon-theme-name = "Adwaita"' >> "${T}/gtkrc"
else
echo 'gtk-icon-theme-name = "gnome"' >> "${T}/gtkrc"
@@ -237,7 +236,7 @@ multilib_src_install_all() {
# dev-util/gtk-builder-convert split off into a separate package, #402905
rm "${ED}"usr/bin/gtk-builder-convert || die
- rm -f "${ED}"usr/share/man/man1/gtk-builder-convert.* || die
+ rm "${ED}"usr/share/man/man1/gtk-builder-convert.* || die
readme.gentoo_create_doc
}
diff --git a/x11-libs/gtk+/gtk+-3.22.19.ebuild b/x11-libs/gtk+/gtk+-3.22.19.ebuild
index 3cb0e655..01b30ee1 100644
--- a/x11-libs/gtk+/gtk+-3.22.19.ebuild
+++ b/x11-libs/gtk+/gtk+-3.22.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017 Gentoo Foundation
+# Copyright 2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,17 +7,17 @@ GNOME2_LA_PUNT="yes"
inherit autotools flag-o-matic gnome2 multilib virtualx multilib-minimal
DESCRIPTION="Gimp ToolKit +"
-HOMEPAGE="http://www.gtk.org/"
+HOMEPAGE="https://www.gtk.org/"
LICENSE="LGPL-2+"
SLOT="3"
-IUSE="adwaita-icon-theme aqua atk-bridge broadway cloudprint colord cups debug examples +introspection test vim-syntax wayland +X xinerama"
+IUSE="adwaita-icon-theme aqua atk-bridge broadway cloudprint colord cups examples +introspection test vim-syntax wayland +X xinerama"
REQUIRED_USE="
|| ( aqua wayland X )
xinerama? ( X )
"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# Upstream wants us to do their job:
# https://bugzilla.gnome.org/show_bug.cgi?id=768662#c1
@@ -86,12 +86,12 @@ RDEPEND="${COMMON_DEPEND}
>=dev-util/gtk-update-icon-cache-3
!<gnome-base/gail-1000
!<x11-libs/vte-0.31.0:2.90
- adwaita-icon-theme? ( >=x11-themes/adwaita-icon-theme-3.14 )
- !adwaita-icon-theme? ( x11-themes/hicolor-icon-theme virtual/freedesktop-icon-theme )
"
# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
PDEPEND="
- adwaita-icon-theme? ( gnome-base/librsvg[${MULTILIB_USEDEP}] )
+ adwaita-icon-theme? ( gnome-base/librsvg[${MULTILIB_USEDEP}]
+ >=x11-themes/adwaita-icon-theme-3.14 )
+ !adwaita-icon-theme? ( x11-themes/hicolor-icon-theme virtual/freedesktop-icon-theme )
vim-syntax? ( app-vim/gtk-syntax )
"
@@ -158,7 +158,6 @@ multilib_src_configure() {
$(use_enable X xrandr) \
$(use_enable xinerama) \
$(use_with atk-bridge) \
- $(usex debug --enable-debug --enable-debug=minimum) \
--disable-papi \
--disable-mir-backend \
--enable-man \
diff --git a/x11-libs/gtk+/gtk+-3.22.16.ebuild b/x11-libs/gtk+/gtk+-3.22.26.ebuild
index 32d35231..66dd2b70 100644
--- a/x11-libs/gtk+/gtk+-3.22.16.ebuild
+++ b/x11-libs/gtk+/gtk+-3.22.26.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017 Gentoo Foundation
+# Copyright 2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,17 +7,17 @@ GNOME2_LA_PUNT="yes"
inherit autotools flag-o-matic gnome2 multilib virtualx multilib-minimal
DESCRIPTION="Gimp ToolKit +"
-HOMEPAGE="http://www.gtk.org/"
+HOMEPAGE="https://www.gtk.org/"
LICENSE="LGPL-2+"
SLOT="3"
-IUSE="adwaita-icon-theme aqua atk-bridge broadway cloudprint colord cups debug examples +introspection test vim-syntax wayland +X xinerama"
+IUSE="adwaita-icon-theme aqua atk-bridge broadway cloudprint colord cups examples +introspection test vim-syntax wayland +X xinerama"
REQUIRED_USE="
|| ( aqua wayland X )
xinerama? ( X )
"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# Upstream wants us to do their job:
# https://bugzilla.gnome.org/show_bug.cgi?id=768662#c1
@@ -43,7 +43,7 @@ COMMON_DEPEND="
introspection? ( >=dev-libs/gobject-introspection-1.39:= )
wayland? (
>=dev-libs/wayland-1.9.91[${MULTILIB_USEDEP}]
- >=dev-libs/wayland-protocols-1.7
+ >=dev-libs/wayland-protocols-1.9
media-libs/mesa[wayland,${MULTILIB_USEDEP}]
>=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
)
@@ -86,12 +86,12 @@ RDEPEND="${COMMON_DEPEND}
>=dev-util/gtk-update-icon-cache-3
!<gnome-base/gail-1000
!<x11-libs/vte-0.31.0:2.90
- adwaita-icon-theme? ( >=x11-themes/adwaita-icon-theme-3.14 )
- !adwaita-icon-theme? ( x11-themes/hicolor-icon-theme virtual/freedesktop-icon-theme )
"
# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
PDEPEND="
- adwaita-icon-theme? ( gnome-base/librsvg[${MULTILIB_USEDEP}] )
+ adwaita-icon-theme? ( gnome-base/librsvg[${MULTILIB_USEDEP}]
+ >=x11-themes/adwaita-icon-theme-3.14 )
+ !adwaita-icon-theme? ( x11-themes/hicolor-icon-theme virtual/freedesktop-icon-theme )
vim-syntax? ( app-vim/gtk-syntax )
"
@@ -127,6 +127,9 @@ src_prepare() {
# gtk-update-icon-cache is installed by dev-util/gtk-update-icon-cache
eapply "${FILESDIR}"/${PN}-3.22.2-update-icon-cache.patch
+ # Fix broken autotools logic
+ eapply "${FILESDIR}"/${PN}-3.22.20-libcloudproviders-automagic.patch
+
# Use patches from BSD to make gtk3-atk-bridge a true option -
# This was intentionally removed by upstream, see
# https://mail.gnome.org/archives/commits-list/2012-June/msg03813.html
@@ -141,6 +144,7 @@ src_prepare() {
multilib_src_configure() {
# need libdir here to avoid a double slash in a path that libtool doesn't
# grok so well during install (// between $EPREFIX and usr ...)
+ # cloudprovider is not packaged in Gentoo
ECONF_SOURCE=${S} \
gnome2_src_configure \
$(use_enable aqua quartz-backend) \
@@ -158,9 +162,9 @@ multilib_src_configure() {
$(use_enable X xrandr) \
$(use_enable xinerama) \
$(use_with atk-bridge) \
- $(usex debug --enable-debug --enable-debug=minimum) \
- --disable-papi \
+ --disable-cloudproviders \
--disable-mir-backend \
+ --disable-papi \
--enable-man \
--with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
--libdir="${EPREFIX}"/usr/$(get_libdir) \