summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-06-12 20:45:40 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:22 +0200
commit1c82b10d8fce8a7f8dffdc84839c385c651565f2 (patch)
treedb54bab7b0cf29b1cb7c1447099159320fc8875a /app-portage/portage-bashrc-mv/portage-bashrc-mv-13.4.ebuild
parentBump portage-bashrc-mv (diff)
downloadmv-1c82b10d8fce8a7f8dffdc84839c385c651565f2.tar.gz
mv-1c82b10d8fce8a7f8dffdc84839c385c651565f2.tar.bz2
mv-1c82b10d8fce8a7f8dffdc84839c385c651565f2.zip
Bump portage-bashrc-mv, classic-theme-restorer
Diffstat (limited to 'app-portage/portage-bashrc-mv/portage-bashrc-mv-13.4.ebuild')
-rw-r--r--app-portage/portage-bashrc-mv/portage-bashrc-mv-13.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-portage/portage-bashrc-mv/portage-bashrc-mv-13.4.ebuild b/app-portage/portage-bashrc-mv/portage-bashrc-mv-13.4.ebuild
new file mode 100644
index 00000000..51dd2d81
--- /dev/null
+++ b/app-portage/portage-bashrc-mv/portage-bashrc-mv-13.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="Provide support for /etc/portage/bashrc.d and /etc/portage/package.cflags"
+HOMEPAGE="https://github.com/vaeth/portage-bashrc-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="!<dev-util/ccache-3.2"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dodoc NEWS README
+ exeinto "/usr/share/doc/${PF}"
+ doexe fix-portage-2.2.15
+ docompress -x "/usr/share/doc/${PF}/fix-portage-2.2.15"
+ insinto /etc/portage
+ doins -r bashrc bashrc.d
+ docompress /etc/portage/bashrc.d/README
+}
+
+pkg_postinst() {
+ case ${REPLACING_VERSIONS} in
+ [0-9].*|1[0-2].*)
+ ewarn "Remember to run /usr/share/doc/${PF}/fix-portage-2.2.15"
+ ewarn "as the first command after upgrading to >=portage-2.2.15"
+ ewarn "See NEWS for details";;
+ esac
+ optfeature "improved mask handling" app-portage/eix
+ optfeature "output of expected emerge time" app-portage/portage-utils
+ optfeature "detailed information output in title bar" app-shells/runtitle
+ ! test -d /var/cache/gpo || \
+ ewarn "Obsolete /var/cache/gpo found. Please remove"
+}