summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2023-10-16 21:41:14 +0200
committerMartin Väth <martin@mvath.de>2023-10-16 21:41:14 +0200
commitd9ffe9b7ccf80451bfe7a3187ecbb625af724fd6 (patch)
tree68571da69653ed36328b40c5eb54d8e9077e2e7b /gui-apps/wcm/wcm-0.8.0.ebuild
parentgui-wm/wayfire, gui-libs/wf-config, gui-apps/wf-shell: Version bump (diff)
downloadmv-d9ffe9b7ccf80451bfe7a3187ecbb625af724fd6.tar.gz
mv-d9ffe9b7ccf80451bfe7a3187ecbb625af724fd6.tar.bz2
mv-d9ffe9b7ccf80451bfe7a3187ecbb625af724fd6.zip
gui-wm/wayfire: fix manpage, debugging. gui-apps/wcm: add for version bump
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'gui-apps/wcm/wcm-0.8.0.ebuild')
-rw-r--r--gui-apps/wcm/wcm-0.8.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gui-apps/wcm/wcm-0.8.0.ebuild b/gui-apps/wcm/wcm-0.8.0.ebuild
new file mode 100644
index 00000000..d9c12a2d
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+RESTRICT="mirror"
+
+inherit meson xdg
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wcm/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ >=gui-wm/wayfire-${PV%.*}
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"