summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2023-10-16 21:41:14 +0200
committerMartin Väth <martin@mvath.de>2023-10-16 21:41:14 +0200
commitd9ffe9b7ccf80451bfe7a3187ecbb625af724fd6 (patch)
tree68571da69653ed36328b40c5eb54d8e9077e2e7b /gui-apps/wcm
parentgui-wm/wayfire, gui-libs/wf-config, gui-apps/wf-shell: Version bump (diff)
downloadmv-d9ffe9b7ccf80451bfe7a3187ecbb625af724fd6.tar.gz
mv-d9ffe9b7ccf80451bfe7a3187ecbb625af724fd6.tar.bz2
mv-d9ffe9b7ccf80451bfe7a3187ecbb625af724fd6.zip
gui-wm/wayfire: fix manpage, debugging. gui-apps/wcm: add for version bump
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'gui-apps/wcm')
-rw-r--r--gui-apps/wcm/Manifest1
-rw-r--r--gui-apps/wcm/metadata.xml13
-rw-r--r--gui-apps/wcm/wcm-0.8.0.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/gui-apps/wcm/Manifest b/gui-apps/wcm/Manifest
new file mode 100644
index 00000000..d76c7232
--- /dev/null
+++ b/gui-apps/wcm/Manifest
@@ -0,0 +1 @@
+DIST wcm-0.8.0.tar.xz 430960 BLAKE2B 4d845edc631bda6b3fbee181d64897b366f4e73af7fef0e912f0a5dc9c7db4dc731319b6c25ce3e2206cc05c908ee402e01ed914cba4ccc63b0d52b9980b7414 SHA512 43d863cfd44dc10874f6ac0c511cd07d84721c53955315fb6eed54ba5f6ac9ebcdcf19e515639deafb333d8e45d95ce8e5222ce1d3344fc7d72f09b018bf517e
diff --git a/gui-apps/wcm/metadata.xml b/gui-apps/wcm/metadata.xml
new file mode 100644
index 00000000..4aa1e1a3
--- /dev/null
+++ b/gui-apps/wcm/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ GUI front end to the wayfire config manager.
+ Allows to reload changes on the fly without
+ needing to restart wayfire.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">WayfireWM/wcm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/wcm/wcm-0.8.0.ebuild b/gui-apps/wcm/wcm-0.8.0.ebuild
new file mode 100644
index 00000000..d9c12a2d
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+RESTRICT="mirror"
+
+inherit meson xdg
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wcm/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ >=gui-wm/wayfire-${PV%.*}
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"