summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-07-08 15:15:16 +0200
committerMartin Väth <martin@mvath.de>2017-07-08 15:15:16 +0200
commit48cc1b8ec080d2fd5e15b2a84036b0dba85a19eb (patch)
treee62392c458fad86e7cbe802a83d09fce59a38d0e /media-libs
parentmedia-libs/avidemux-plugins: Fix USE in metdata.xml (diff)
downloadmv-48cc1b8ec080d2fd5e15b2a84036b0dba85a19eb.tar.gz
mv-48cc1b8ec080d2fd5e15b2a84036b0dba85a19eb.tar.bz2
mv-48cc1b8ec080d2fd5e15b2a84036b0dba85a19eb.zip
avidemux: Add -std=c++14 (or 11), see gentoo bug 623178
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.6.20-r1.ebuild8
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-2.6.20.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/media-libs/avidemux-core/avidemux-core-2.6.20-r1.ebuild b/media-libs/avidemux-core/avidemux-core-2.6.20-r1.ebuild
index 22f3d2f2..93fafa5c 100644
--- a/media-libs/avidemux-core/avidemux-core-2.6.20-r1.ebuild
+++ b/media-libs/avidemux-core/avidemux-core-2.6.20-r1.ebuild
@@ -76,6 +76,14 @@ src_prepare() {
}
src_configure() {
+ if test-flags-CXX -std=c++14 ; then
+ append-cxxflags -std=c++14
+ elif test-flags-CXX -std=c++11 ; then
+ append-cxxflags -std=c++11
+ elif use qt4 || use qt5 ; then
+ die "For qt support a compiler with c++11 support is needed"
+ fi
+
# Add lax vector typing for PowerPC.
if use ppc || use ppc64 ; then
append-cflags -flax-vector-conversions
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-2.6.20.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-2.6.20.ebuild
index ab0fac56..7dcbe8ec 100644
--- a/media-libs/avidemux-plugins/avidemux-plugins-2.6.20.ebuild
+++ b/media-libs/avidemux-plugins/avidemux-plugins-2.6.20.ebuild
@@ -90,6 +90,14 @@ src_prepare() {
}
src_configure() {
+ if test-flags-CXX -std=c++14 ; then
+ append-cxxflags -std=c++14
+ elif test-flags-CXX -std=c++11 ; then
+ append-cxxflags -std=c++11
+ elif use qt4 || use qt5 ; then
+ die "For qt support a compiler with c++11 support is needed"
+ fi
+
# Add lax vector typing for PowerPC.
if use ppc || use ppc64 ; then
append-cflags -flax-vector-conversions