summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-10-05 00:00:37 +0200
committerMartin Väth <martin@mvath.de>2017-10-05 00:00:37 +0200
commitff6d89e34e2610b2abff07b6fadb7a77eb0393e9 (patch)
tree6ea05ab5ea8cb3972001c0a4a2a6bff2b0ea02e2 /media-tv
parentapp-shells/termcolors-mv: Version bump. Add USE=poor (diff)
downloadmv-ff6d89e34e2610b2abff07b6fadb7a77eb0393e9.tar.gz
mv-ff6d89e34e2610b2abff07b6fadb7a77eb0393e9.tar.bz2
mv-ff6d89e34e2610b2abff07b6fadb7a77eb0393e9.zip
media-tv/w_scan: Add patch to force plp_id=0
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/w_scan/files/plp_id.patch14
-rw-r--r--media-tv/w_scan/metadata.xml6
-rw-r--r--media-tv/w_scan/w_scan-20170107-r1.ebuild (renamed from media-tv/w_scan/w_scan-20170107.ebuild)7
3 files changed, 25 insertions, 2 deletions
diff --git a/media-tv/w_scan/files/plp_id.patch b/media-tv/w_scan/files/plp_id.patch
new file mode 100644
index 00000000..3f6f9ec5
--- /dev/null
+++ b/media-tv/w_scan/files/plp_id.patch
@@ -0,0 +1,14 @@
+Martin Väth <martin@mvath.de>:
+It seems that for DVB-T2 the plp_id always has to be 0.
+At least, this value seems to be correct for a Sundtek TV card in Rostock.
+--- 1/descriptors.c
++++ 1/descriptors.c
+@@ -1013,7 +1013,7 @@
+ // descriptor_tag 8 uimsbf
+ descriptor_length = buf[1]; // descriptor_length 8 uimsbf
+ //descriptor_tag_extension = buf[2]; // descriptor_tag_extension 8 uimsbf
+- t->plp_id = buf[3]; // plp_id 8 uimsbf; uniquely identifies the PLP carrying this TS within the T2 system.
++ t->plp_id = 0;//buf[3]; // plp_id 8 uimsbf; uniquely identifies the PLP carrying this TS within the T2 system.
+ t->system_id = get_u16(buf + 4); // T2_system_id 16 uimsbf; uniquely identifies the T2 system within the network, two T2 systems with same T2_system_id && network_id ire identical, except that cell_id may differ..
+ if ((t->extended_info = (descriptor_length > 4))) { // has extension
+ switch (buf[6] >> 6) { // SISO/MISO 2 bslbf (Multiple-Input Single-Output)
diff --git a/media-tv/w_scan/metadata.xml b/media-tv/w_scan/metadata.xml
index 49fd40c5..b1707910 100644
--- a/media-tv/w_scan/metadata.xml
+++ b/media-tv/w_scan/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>hd_brummy@gentoo.org</email>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
</maintainer>
+ <use>
+ <flag name="plp-id-zero">Apply experimental patch to force plp_id to 0 for DVB-T2. Seems to be necessary at least with some tuners in some regions</flag>
+ </use>
</pkgmetadata>
diff --git a/media-tv/w_scan/w_scan-20170107.ebuild b/media-tv/w_scan/w_scan-20170107-r1.ebuild
index f453db0d..e9c96443 100644
--- a/media-tv/w_scan/w_scan-20170107.ebuild
+++ b/media-tv/w_scan/w_scan-20170107-r1.ebuild
@@ -10,11 +10,16 @@ SRC_URI="http://wirbel.htpc-forum.de/w_scan/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
+IUSE="doc examples +plp-id-zero"
DEPEND=">=virtual/linuxtv-dvb-headers-5.8"
RDEPEND=""
+src_prepare() {
+ use plp-id-zero && eapply "${FILESDIR}"/plp_id.patch
+ default
+}
+
src_install() {
emake DESTDIR="${ED}" install