summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /media-video/video-mv
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'media-video/video-mv')
-rw-r--r--media-video/video-mv/Manifest1
-rw-r--r--media-video/video-mv/metadata.xml16
-rw-r--r--media-video/video-mv/video-mv-8.6.ebuild63
3 files changed, 80 insertions, 0 deletions
diff --git a/media-video/video-mv/Manifest b/media-video/video-mv/Manifest
new file mode 100644
index 00000000..b4727af9
--- /dev/null
+++ b/media-video/video-mv/Manifest
@@ -0,0 +1 @@
+DIST video-mv-8.6.tar.gz 17738 SHA256 0b171761cbf7b7ee8bd44aaecca1c51d72e1b0bd45cfa47a8f20aaa0d6d4b07d SHA512 57f376401b2019d18b86c86a70a717fed90ba1d22047c34b04c27dc523cb0f6856fe16d8993899fadfe81dd9b945fd62397f81830719917f439cc4553b6ec885 WHIRLPOOL bd0153a0ed47dec2853e80303d9bcc27e8b13ba957a029cd7d7de15ed595198a3889956b568625c36568766f3d1d51e08031fd0e4e717f39bbb7451f0ba6c8cd
diff --git a/media-video/video-mv/metadata.xml b/media-video/video-mv/metadata.xml
new file mode 100644
index 00000000..e85a5d21
--- /dev/null
+++ b/media-video/video-mv/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/video-mv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/video-mv/video-mv-8.6.ebuild b/media-video/video-mv/video-mv-8.6.ebuild
new file mode 100644
index 00000000..21383ea3
--- /dev/null
+++ b/media-video/video-mv/video-mv-8.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils readme.gentoo
+
+DESCRIPTION="Frontends for using mplayer/mencoder, ffmpeg/libav, or tzap as video recorder"
+HOMEPAGE="https://github.com/vaeth/video-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-shells/push
+ >=app-shells/runtitle-2.3
+ || ( ( media-sound/alsa-utils
+ || ( media-video/mplayer[encode] virtual/ffmpeg ) )
+ media-tv/linuxtv-dvb-apps )"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="If you use dvb-t with zsh completion, you might want to put
+zstyle ':completion:*' matcher-list '' 'm:{a-zA-Z}={A-Za-z}'
+into your ~/.zshrc or /etc/zshrc for case-insensitive matching."
+
+src_prepare() {
+ local i
+ use prefix || for i in bin/*
+ do test -h "${i}" || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -e 's"^\. _videoscript\.sh$". '"${EPREFIX}/usr/share/video-mv/_videoscript.sh"'"' \
+ -- "${i}" || die
+ done
+ epatch_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}"
+ then doins "${i}"
+ elif [ "${i#*/}" != '_videoscript.sh' ]
+ then dobin "${i}"
+ fi
+ done
+ insinto /usr/share/video-mv
+ doins bin/_videoscript.sh
+ insinto /etc
+ doins etc/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc README
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ optfeature "status bar support" app-shells/runtitle
+ readme.gentoo_pkg_postinst
+}