summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-12-26 18:59:03 +0100
committerMartin Väth <martin@mvath.de>2016-12-26 18:59:03 +0100
commit0e40666fe890a09a4981723d6f92da66017917e1 (patch)
tree4d8507d445440fa52e0a95bbe1391b1b4af50193 /media-video
parentapp-eselect/eselect-net: New ebuild from scratch (diff)
downloadmv-0e40666fe890a09a4981723d6f92da66017917e1.tar.gz
mv-0e40666fe890a09a4981723d6f92da66017917e1.tar.bz2
mv-0e40666fe890a09a4981723d6f92da66017917e1.zip
avidemux: Filter problematic flags. Remove old
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avidemux/avidemux-2.6.12-r1.ebuild138
-rw-r--r--media-video/avidemux/avidemux-2.6.15-r1.ebuild4
2 files changed, 4 insertions, 138 deletions
diff --git a/media-video/avidemux/avidemux-2.6.12-r1.ebuild b/media-video/avidemux/avidemux-2.6.12-r1.ebuild
deleted file mode 100644
index 6e0ed63a..00000000
--- a/media-video/avidemux/avidemux-2.6.12-r1.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-RESTRICT="mirror"
-
-PLOCALES="ca cs de el es fr it ja pt_BR ru sr sr@latin tr"
-
-inherit cmake-utils eutils flag-o-matic l10n
-
-SLOT="2.6"
-
-DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-IUSE="debug opengl nls qt4 sdl vaapi vdpau video_cards_fglrx xv"
-KEYWORDS="~amd64 ~x86"
-
-if [[ ${PV} == *9999* ]] ; then
- MY_P=$P
- KEYWORDS=""
- PROPERTIES="live"
- EGIT_REPO_URI="https://github.com/mean00/avidemux2"
- inherit git-r3
-else
- MY_P="${PN}_${PV}"
- SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tar.gz"
-fi
-
-DEPEND="
- ~media-libs/avidemux-core-${PV}:${SLOT}[nls?,sdl?,vaapi?,vdpau?,video_cards_fglrx?,xv?]
- opengl? ( virtual/opengl:0 )
- qt4? ( >=dev-qt/qtgui-4.8.3:4 )
- vaapi? ( x11-libs/libva:0 )
- video_cards_fglrx? (
- || ( >=x11-drivers/ati-drivers-14.12-r3
- x11-libs/xvba-video:0 )
- )"
-RDEPEND="$DEPEND"
-PDEPEND="~media-libs/avidemux-plugins-${PV}:${SLOT}[opengl?,qt4?]"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- #cmake-utils_src_prepare
-
- # Fix icon name -> avidemux-2.6.png
- sed -i -e "/^Icon/ s:${PN}:${PN}-2.6:" ${PN}2.desktop || die "Icon name fix failed."
-
- # The desktop file is broken. It uses avidemux2 instead of avidemux3
- # so it will actually launch avidemux-2.5 if it is installed.
- sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || die "Desktop file fix failed."
- sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt4:' ${PN}2.desktop || die "Desktop file fix failed."
-
- # Fix QA warnings that complain a trailing ; is missing and Application is deprecated.
- sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}2.desktop || die "Desktop file fix failed."
-
- # Now rename the desktop file to not collide with 2.5.
- mv ${PN}2.desktop ${PN}-2.6.desktop || die "Collision rename failed."
-
- # Fix underlinking to work with gold linker
- sed -i -e 's/\( ADM_core6\)/ Xext\1/' avidemux/common/ADM_render/CMakeLists.txt || die "Couldn't fix underlinking"
-
- # Remove "Build Option" dialog because it doesn't reflect what the GUI can or has been built with. (Bug #463628)
- sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || die "Couldn't remove \"Build Option\" dialog."
- eapply_user
-}
-
-src_configure() {
- local mycmakeargs
- mycmakeargs=(
- -DAVIDEMUX_SOURCE_DIR="'${S}'"
- -DGETTEXT="$(usex nls)"
- -DSDL="$(usex sdl)"
- -DLIBVA="$(usex vaapi)"
- -DVDPAU="$(usex vdpau)"
- -DXVBA="$(usex video_cards_fglrx)"
- -DXVIDEO="$(usex xv)"
- )
-
- if use debug ; then
- mycmakeargs+=( -DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug -DADM_DEBUG=1 )
- fi
-
- processes="buildCli:avidemux/cli"
- use qt4 && processes+=" buildQt4:avidemux/qt4"
-
- # Needed for gcc-6
- append-cxxflags $(test-flags-CXX -std=gnu++98)
-
- # Add lax vector typing for PowerPC.
- if use ppc || use ppc64 ; then
- append-cflags -flax-vector-conversions
- fi
-
- # See bug 432322.
- use x86 && replace-flags -O0 -O1
-
- for process in ${processes} ; do
- local build="${process%%:*}"
-
- mkdir "${S}"/${build} || die "Can't create build folder."
- cd "${S}"/${build} || die "Can't enter build folder."
- CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${S}"/${build} cmake-utils_src_configure
- done
-}
-
-src_compile() {
- for process in ${processes} ; do
- BUILD_DIR="${S}/${process%%:*}" cmake-utils_src_compile
- done
-}
-
-DOCS=( AUTHORS README )
-
-src_install() {
- for process in ${processes} ; do
- BUILD_DIR="${S}/${process%%:*}" cmake-utils_src_install
- done
-
- if [[ -f "${ED}"/usr/bin/avidemux3_cli ]] ; then
- fperms +x /usr/bin/avidemux3_cli
- fi
-
- if [[ -f "${ED}"/usr/bin/avidemux3_jobs ]] ; then
- fperms +x /usr/bin/avidemux3_jobs
- fi
-
- cd "${S}" || die "Can't enter source folder."
- newicon ${PN}_icon.png ${PN}-2.6.png
-
- if use qt4 ; then
- fperms +x /usr/bin/avidemux3_qt4
- domenu ${PN}-2.6.desktop
- fi
-}
diff --git a/media-video/avidemux/avidemux-2.6.15-r1.ebuild b/media-video/avidemux/avidemux-2.6.15-r1.ebuild
index 3226c752..91bb3074 100644
--- a/media-video/avidemux/avidemux-2.6.15-r1.ebuild
+++ b/media-video/avidemux/avidemux-2.6.15-r1.ebuild
@@ -70,6 +70,7 @@ src_prepare() {
# Fix underlinking to work with gold linker
sed -i -e 's/\( ADM_core6\)/ Xext\1/' avidemux/common/ADM_render/CMakeLists.txt || die "Couldn't fix underlinking"
+
eapply_user
}
@@ -103,6 +104,9 @@ src_configure() {
# Needed for gcc-6
append-cxxflags $(test-flags-CXX -std=gnu++98)
+ # Filter problematic flags
+ filter-flags -fwhole-program -flto -ftracer
+
# Add lax vector typing for PowerPC.
if use ppc || use ppc64 ; then
append-cflags -flax-vector-conversions