summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <mvath@google.com>2019-03-10 12:46:22 +0100
committerMartin Väth <mvath@google.com>2019-03-10 12:46:22 +0100
commitc946924d110d229791825c67b9fa1f050490e88b (patch)
treef3c78839b72608805076687ef5813da96475f602 /media-video
parentmedia-libs/avidemux-plugins: revert EAPI bump (diff)
downloadmv-c946924d110d229791825c67b9fa1f050490e88b.tar.gz
mv-c946924d110d229791825c67b9fa1f050490e88b.tar.bz2
mv-c946924d110d229791825c67b9fa1f050490e88b.zip
app-shells/schily-tools media-video/avidemux: Version bump
Signed-off-by: Martin Väth <mvath@google.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avidemux/Manifest2
-rw-r--r--media-video/avidemux/avidemux-2.7.2.ebuild (renamed from media-video/avidemux/avidemux-2.7.1-r1.ebuild)41
2 files changed, 2 insertions, 41 deletions
diff --git a/media-video/avidemux/Manifest b/media-video/avidemux/Manifest
index 39dec42b..60929277 100644
--- a/media-video/avidemux/Manifest
+++ b/media-video/avidemux/Manifest
@@ -1 +1 @@
-DIST avidemux_2.7.1.tar.gz 22263775 SHA512 85a690a36cad827f176818d6f566d897b4e46b2a272c8fb18bd64672d92f106d2706ac214b3e3ac3a836c5c98f81f7d5feca1229c3f3f2152ab715a3565008be
+DIST avidemux_2.7.2.tar.gz 23903618 SHA512 40d023a1dadfadd9dc8ecfd3368f0e1ad27edd45fe33f7cf8245ab2c7b6038e12c2c05b975b515fc4686e7b8043e75016a5b617a827f8d23a5e40b870c718d1b
diff --git a/media-video/avidemux/avidemux-2.7.1-r1.ebuild b/media-video/avidemux/avidemux-2.7.2.ebuild
index 6b39448e..5dc1faa3 100644
--- a/media-video/avidemux/avidemux-2.7.1-r1.ebuild
+++ b/media-video/avidemux/avidemux-2.7.2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+RESTRICT="mirror"
if [[ ${PV} == *9999* ]] ; then
MY_P="${P}"
@@ -56,35 +57,6 @@ src_prepare() {
for process in ${processes} ; do
CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
done
-
- # Fix icon name -> avidemux-2.7.png
- sed -i -e "/^Icon/ s:${PN}:${PN}-${SLOT}:" ${PN}2.desktop || \
- die "Icon name fix failed."
-
- # The desktop file is broken. It uses avidemux2 instead of avidemux3
- # so it will actually launch avidemux-2.7 if it is installed.
- sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || \
- die "Desktop file fix failed."
- if use qt5; then
- sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt5:' ${PN}2.desktop || \
- die "Desktop file fix failed."
- fi
-
- # QA warnings: missing trailing ';' and 'Application' is deprecated.
- sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}2.desktop || \
- die "Desktop file fix failed."
-
- # Now rename the desktop file to not collide with 2.6.
- mv ${PN}2.desktop ${PN}-${SLOT}.desktop || die "Collision rename failed."
-
- # Remove "Build Option" dialog because it doesn't reflect
- # what the GUI can or has been built with. (Bug #463628)
- sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || \
- die "Couldn't remove \"Build Option\" dialog."
-
- # Fix underlinking with gold
- sed -i -e 's/{QT_QTGUI_LIBRARY}/{QT_QTGUI_LIBRARY} -lXext/' \
- avidemux/common/ADM_render/CMakeLists.txt || die
}
src_configure() {
@@ -96,10 +68,6 @@ src_configure() {
# See bug 432322.
use x86 && replace-flags -O0 -O1
- # The build relies on an avidemux-core header that uses 'nullptr'
- # which is from >=C++11. Let's use the GCC-6 default C++ dialect.
- append-cxxflags -std=c++14
-
local mycmakeargs=(
-DGETTEXT="$(usex nls)"
-DSDL="$(usex sdl)"
@@ -153,9 +121,6 @@ src_install() {
fperms +x /usr/bin/avidemux3_jobs
fi
- cd "${S}" || die "Can't enter source folder."
- newicon ${PN}_icon.png ${PN}-${SLOT}.png
-
if [[ -f "${ED}"/usr/bin/avidemux3_qt5 ]] ; then
fperms +x /usr/bin/avidemux3_qt5
fi
@@ -163,10 +128,6 @@ src_install() {
if [[ -f "${ED}"/usr/bin/avidemux3_jobs_qt5 ]] ; then
fperms +x /usr/bin/avidemux3_jobs_qt5
fi
-
- if use qt5 ; then
- domenu ${PN}-${SLOT}.desktop
- fi
}
pkg_postinst() {