summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-11-15 10:23:39 +0100
committerMartin Väth <martin@mvath.de>2017-11-15 10:23:39 +0100
commit199678fa69ca0d0cbcb4f3a35f1c584482e8b7eb (patch)
tree626b15965bd3fa255c7c5ca34fe3776343b71132 /sys-fs/squashmount
parentsys-fs/squashfuse: Copy and bump from gentoo repository to support zstd (diff)
downloadmv-199678fa69ca0d0cbcb4f3a35f1c584482e8b7eb.tar.gz
mv-199678fa69ca0d0cbcb4f3a35f1c584482e8b7eb.tar.bz2
mv-199678fa69ca0d0cbcb4f3a35f1c584482e8b7eb.zip
sys-fs/squashmount: Version bumps. squashmount-17.0.0 defaults to zstd
Diffstat (limited to 'sys-fs/squashmount')
-rw-r--r--sys-fs/squashmount/Manifest3
-rw-r--r--sys-fs/squashmount/squashmount-16.1.0.ebuild (renamed from sys-fs/squashmount/squashmount-16.0.0_p2.ebuild)0
-rw-r--r--sys-fs/squashmount/squashmount-17.0.0.ebuild88
3 files changed, 90 insertions, 1 deletions
diff --git a/sys-fs/squashmount/Manifest b/sys-fs/squashmount/Manifest
index c4e0a02c..e32873da 100644
--- a/sys-fs/squashmount/Manifest
+++ b/sys-fs/squashmount/Manifest
@@ -1 +1,2 @@
-DIST squashmount-16.0.0_p2.tar.gz 67978 SHA512 874c89ae4bdada7c555699b543d313a35454d132f6356af27d8d2275873de1ab601da4bb375a3ba5424f6b2754007544275551c4d82b49b2cb9ec7953a0b2462
+DIST squashmount-16.1.0.tar.gz 68224 SHA512 d0530367a8edbaa01dd14a224d808259975630e77763a56fe3c1a3a15a0497e2bea341bd68ed07983f2ffd6bf539dbbabb278f03e5fa48d09043d4bb1c3c50bc
+DIST squashmount-17.0.0.tar.gz 68295 SHA512 4a370f04c76ca28cc65e281ffa16ad8d360afc506db7199a41d849ea1d1115af529ea1e3c8eb79ef72fc40b1d4422fef487591a6449c10c6a306493b38797f73
diff --git a/sys-fs/squashmount/squashmount-16.0.0_p2.ebuild b/sys-fs/squashmount/squashmount-16.1.0.ebuild
index 2e495b03..2e495b03 100644
--- a/sys-fs/squashmount/squashmount-16.0.0_p2.ebuild
+++ b/sys-fs/squashmount/squashmount-16.1.0.ebuild
diff --git a/sys-fs/squashmount/squashmount-17.0.0.ebuild b/sys-fs/squashmount/squashmount-17.0.0.ebuild
new file mode 100644
index 00000000..2e495b03
--- /dev/null
+++ b/sys-fs/squashmount/squashmount-17.0.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
+HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html
+https://github.com/vaeth/squashmount/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# These should really depend on USE-flags but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND="app-shells/runtitle
+dev-perl/File-Which
+!arm? ( !ia64? ( !sparc? ( dev-perl/String-ShellQuote ) ) )"
+
+RDEPEND="!<sys-apps/openrc-0.13
+ >=dev-lang/perl-5.22
+ || ( dev-perl/File-Which sys-apps/which )
+ sys-fs/squashfs-tools
+ !<sys-fs/unionfs-fuse-0.25
+ !<app-portage/find_cruft-4.0.0
+ ${OPTIONAL_RDEPEND}"
+# >=dev-lang/perl-5.12
+# || ( >=dev-lang/perl-5.10.1 >=virtual/perl-File-Path-2.6.5 )
+# || ( >=dev-lang/perl-5.4.5 virtual/perl-File-Spec )
+# || ( >=dev-lang/perl-5.10.1 >=virtual/perl-File-Temp-0.19 )
+# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
+# || ( >=dev-lang/perl-5.9.3 virtual/perl-IO-Compress )
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="Please adapt /etc/squashmount.pl as well as
+/etc/systemd/system/squashmount.service.d/timeout.conf to your needs.
+
+Configure the mount point 'gentoo' only if you use sync-type = squashdelta.
+
+For improved output use sys-fs/squashfs-tools from the mv overlay.
+
+It is recommended to put into your zshrc the line:
+alias squashmount='noglob squashmount'"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- bin/* || die
+ eapply_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README ChangeLog compress.txt
+ doinitd openrc/init.d/*
+ systemd_dounit systemd/system/*
+ dotmpfiles tmpfiles.d/*
+ insinto /etc
+ doins -r etc/revdep-rebuild etc/systemd
+ exeinto /etc/portage/repo.postsync.d
+ doexe etc/portage/repo.postsync.d/*
+ insinto /usr/lib
+ doins lib/*
+ doins -r lib/find_cruft
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ if use arm || use ia64 || use sparc
+ then optfeature "improved output" 'dev-perl/String-ShellQuote'
+ fi
+ optfeature "user mounting" \
+ '>=sys-fs/squashfuse-0.1.100 >=sys-fs/unionfs-fuse-0.25' \
+ '>=sys-fs/squashfuse-0.1.100 sys-fs/funionfs'
+ case " ${REPLACING_VERSIONS}" in
+ *' '[0-9].*|*' '1[0-4].*|*' '15.[0-2].*|*' '15.3.0*)
+ FORCE_PRINT_ELOG="true";;
+ esac
+ readme.gentoo_print_elog
+ tmpfiles_process squashmount.conf
+}