summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-10-31 23:20:20 +0100
committerMartin Väth <martin@mvath.de>2016-10-31 23:20:20 +0100
commit146905f61de5b686e3bcced6ef5601bda0fa998b (patch)
tree15e2f135fe9206c7748b7e29a8735f9e8076e7e9 /sys-kernel/kernel/kernel-2.03.ebuild
parentFix deps (diff)
downloadmv-146905f61de5b686e3bcced6ef5601bda0fa998b.tar.gz
mv-146905f61de5b686e3bcced6ef5601bda0fa998b.tar.bz2
mv-146905f61de5b686e3bcced6ef5601bda0fa998b.zip
sys-kernel/kernel: Version bump
Diffstat (limited to 'sys-kernel/kernel/kernel-2.03.ebuild')
-rw-r--r--sys-kernel/kernel/kernel-2.03.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/kernel/kernel-2.03.ebuild b/sys-kernel/kernel/kernel-2.03.ebuild
new file mode 100644
index 00000000..3514d7f1
--- /dev/null
+++ b/sys-kernel/kernel/kernel-2.03.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A POSIX shell script to compile the kernel with user permissions"
+HOMEPAGE="https://github.com/vaeth/kernel/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-admin/sudo
+ app-admin/sudox
+ >=app-shells/push-2.0
+ >=app-shells/runtitle-2.3
+ !<dev-util/ccache-3.2"
+DEPEND=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- bin/* || die
+ eapply_user
+}
+
+src_install() {
+ dobin bin/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}
+
+pkg_postinst() {
+ optfeature "faster execution" 'app-portage/eix'
+ optfeature "status bar support" 'app-shells/runtitle'
+}