summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-01-21 01:36:39 +0100
committerMartin Väth <martin@mvath.de>2017-01-21 01:36:39 +0100
commit9a4ebf3af84ec34a61b92ad0c19ee9e009d1ab68 (patch)
tree5acd3496e444df20a1e04a6ed755b64e9dbaf1fb /x11-drivers
parentdev-vcs/git-wrappers-mv: Version bump (diff)
downloadmv-9a4ebf3af84ec34a61b92ad0c19ee9e009d1ab68.tar.gz
mv-9a4ebf3af84ec34a61b92ad0c19ee9e009d1ab68.tar.bz2
mv-9a4ebf3af84ec34a61b92ad0c19ee9e009d1ab68.zip
x11-drivers/nvidia-drivers: Dependency changes from gentoo repository
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-173.14.39-r2.ebuild (renamed from x11-drivers/nvidia-drivers/nvidia-drivers-173.14.39-r1.ebuild)31
1 files changed, 15 insertions, 16 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-173.14.39-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-173.14.39-r2.ebuild
index d5ac2688..6acec3e4 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-173.14.39-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-173.14.39-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils flag-o-matic linux-mod multilib portability \
+inherit eutils flag-o-matic linux-mod multilib-minimal nvidia-driver portability \
unpacker user versionator readme.gentoo-r1
X86_NV_PACKAGE="NVIDIA-Linux-x86-${PV}"
@@ -11,13 +11,13 @@ AMD64_NV_PACKAGE="NVIDIA-Linux-x86_64-${PV}"
X86_FBSD_NV_PACKAGE="NVIDIA-FreeBSD-x86-${PV}"
DESCRIPTION="NVIDIA Accelerated Graphics Driver"
-HOMEPAGE="http://www.nvidia.com/"
+HOMEPAGE="http://www.nvidia.com/ http://www.nvidia.com/Download/Find.aspx"
SRC_URI="x86? ( http://us.download.nvidia.com/XFree86/Linux-x86/${PV}/${X86_NV_PACKAGE}-pkg0.run )
amd64? ( http://us.download.nvidia.com/XFree86/Linux-x86_64/${PV}/${AMD64_NV_PACKAGE}-pkg2.run )
x86-fbsd? ( http://us.download.nvidia.com/freebsd/${PV}/${X86_FBSD_NV_PACKAGE}.tar.gz )"
LICENSE="GPL-2 NVIDIA-r1"
-SLOT="0"
+SLOT="0/173"
KEYWORDS="-* amd64 x86 ~x86-fbsd"
IUSE="acpi multilib kernel3-13 kernel3-14 +kernel3-17 kernel_linux pax_kernel tools"
RESTRICT="bindist mirror strip"
@@ -34,20 +34,19 @@ DEPEND="
"
RDEPEND="
${COMMON}
- <x11-base/xorg-server-1.15.99
+ <x11-base/xorg-server-1.15.99:=
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
acpi? ( sys-power/acpid )
- multilib? (
- >=x11-libs/libX11-1.6.2[abi_x86_32]
- >=x11-libs/libXext-1.3.2[abi_x86_32]
- )
tools? (
- dev-libs/atk
- dev-libs/glib
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/pango[X]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/pango[X,${MULTILIB_USEDEP}]
)
"