summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/googleearth/googleearth-7.1.8.3036.ebuild5
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.0.3832.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/sci-geosciences/googleearth/googleearth-7.1.8.3036.ebuild b/sci-geosciences/googleearth/googleearth-7.1.8.3036.ebuild
index 009383dc..5d2524a8 100644
--- a/sci-geosciences/googleearth/googleearth-7.1.8.3036.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.1.8.3036.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -105,7 +105,7 @@ src_prepare() {
die "patchelf failed on ${x}"
done
- epatch "${FILESDIR}"/${PN}-${PV%%.*}-pro-desktopfile.patch
+ eapply -p0 "${FILESDIR}"/${PN}-${PV%%.*}-pro-desktopfile.patch
default
}
@@ -117,6 +117,7 @@ src_install() {
domenu google-earth-pro.desktop
+ local size
for size in 16 22 24 32 48 64 128 256 ; do
newicon -s ${size} product_logo_${size}.png google-earth-pro.png
done
diff --git a/sci-geosciences/googleearth/googleearth-7.3.0.3832.ebuild b/sci-geosciences/googleearth/googleearth-7.3.0.3832.ebuild
index 25324715..d8fc656c 100644
--- a/sci-geosciences/googleearth/googleearth-7.3.0.3832.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.3.0.3832.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -112,7 +112,7 @@ src_prepare() {
die "patchelf failed on ${x}"
done
- epatch "${FILESDIR}"/${PN}-${PV%%.*}-pro-desktopfile.patch
+ eapply -p0 "${FILESDIR}"/${PN}-${PV%%.*}-pro-desktopfile.patch
default
}
@@ -124,6 +124,7 @@ src_install() {
domenu google-earth-pro.desktop
+ local size
for size in 16 22 24 32 48 64 128 256 ; do
newicon -s ${size} product_logo_${size}.png google-earth-pro.png
done