summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/sdlmame/files/sdlmame-0.174-string.patch10
-rw-r--r--games-emulation/sdlmame/files/sdlmame-0.174-tostring.patch11
-rw-r--r--games-emulation/sdlmame/sdlmame-0.174-r2.ebuild2
3 files changed, 23 insertions, 0 deletions
diff --git a/games-emulation/sdlmame/files/sdlmame-0.174-string.patch b/games-emulation/sdlmame/files/sdlmame-0.174-string.patch
new file mode 100644
index 00000000..85077265
--- /dev/null
+++ b/games-emulation/sdlmame/files/sdlmame-0.174-string.patch
@@ -0,0 +1,10 @@
+--- 1/src/osd/modules/render/bgfx/effect.h
++++ 1/src/osd/modules/render/bgfx/effect.h
+@@ -15,6 +15,7 @@
+
+ #include <vector>
+ #include <map>
++#include <string>
+
+ class bgfx_uniform;
+
diff --git a/games-emulation/sdlmame/files/sdlmame-0.174-tostring.patch b/games-emulation/sdlmame/files/sdlmame-0.174-tostring.patch
new file mode 100644
index 00000000..431856ac
--- /dev/null
+++ b/games-emulation/sdlmame/files/sdlmame-0.174-tostring.patch
@@ -0,0 +1,11 @@
+--- 1/scripts/build/msgfmt.py
++++ 1/scripts/build/msgfmt.py
+@@ -112,7 +112,7 @@
+ 7*4, # start of key index
+ 7*4+len(keys)*8, # start of value index
+ 0, 0) # size and offset of hash table
+- output += array.array("i", offsets).tostring()
++ output += array.array("i", offsets).tobytes()
+ output += ids
+ output += strs
+ return output
diff --git a/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild b/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild
index c06ca402..8a3809d1 100644
--- a/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild
+++ b/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild
@@ -77,6 +77,8 @@ src_prepare() {
eapply \
"${FILESDIR}"/${P}-qt.patch \
"${FILESDIR}"/${P}-cxx14.patch \
+ "${FILESDIR}"/${P}-string.patch \
+ "${FILESDIR}"/${P}-tostring.patch \
"${FILESDIR}"/${P}-sdlSetWindow.patch
# Disable using bundled libraries
enable_feature USE_SYSTEM_LIB_EXPAT