summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-mobilephone/adb-sync/Manifest1
-rw-r--r--app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild32
-rw-r--r--app-mobilephone/adb-sync/metadata.xml12
-rw-r--r--app-portage/etcat/etcat-1.0.2.ebuild2
-rw-r--r--app-portage/etcat/etcat-99999999.ebuild2
-rw-r--r--app-text/stardict/stardict-3.0.6-r4.ebuild2
-rw-r--r--app-text/stardict/stardict-4.0.0_pre20170304.ebuild2
-rw-r--r--dev-cpp/cpplint/cpplint-99999999.ebuild2
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.26.0.ebuild2
-rw-r--r--dev-util/flawfinder/Manifest1
-rw-r--r--dev-util/flawfinder/flawfinder-2.0.15.ebuild36
-rw-r--r--dev-util/flawfinder/metadata.xml13
-rw-r--r--games-emulation/sdlmame/sdlmame-0.174-r2.ebuild2
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild4
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-2.7.8.ebuild2
-rw-r--r--metadata/pkg_desc_index5
-rw-r--r--profiles/use.local.desc2
-rw-r--r--sys-kernel/kconfig-hardened-check/kconfig-hardened-check-0.5.9.ebuild4
-rw-r--r--sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild4
-rw-r--r--x11-misc/redshift/Manifest1
-rw-r--r--x11-misc/redshift/metadata.xml17
-rw-r--r--x11-misc/redshift/redshift-1.12-r4.ebuild88
-rw-r--r--x11-terms/kitty/Manifest1
-rw-r--r--x11-terms/kitty/files/kitty-0.14.4-svg-icon.patch16
-rw-r--r--x11-terms/kitty/files/kitty-0.16.0-remove-terminfo.patch14
-rw-r--r--x11-terms/kitty/files/kitty-0.17.2-flags.patch50
-rw-r--r--x11-terms/kitty/files/kitty-0.19.1-tests.patch11
-rw-r--r--x11-terms/kitty/kitty-0.19.3.ebuild107
-rw-r--r--x11-terms/kitty/metadata.xml15
-rw-r--r--x11-themes/fvwm-crystal/Manifest1
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.6.5.ebuild82
-rw-r--r--x11-themes/fvwm-crystal/metadata.xml27
32 files changed, 438 insertions, 122 deletions
diff --git a/app-mobilephone/adb-sync/Manifest b/app-mobilephone/adb-sync/Manifest
new file mode 100644
index 00000000..3616b559
--- /dev/null
+++ b/app-mobilephone/adb-sync/Manifest
@@ -0,0 +1 @@
+DIST adb-sync-0_p20190101.tar.gz 13956 BLAKE2B 380109fa302fc5376de8124aa31c3fa03a27ece22d7f2d74638a5387820ad7c2b294daa6e8185f6eef49524e987d7a7f1222a1ee3b6550247993ebcc7c1ac98d SHA512 8bd5eb514c63327860017402f509231a0882cd3624ed3350039b2383f38e503abc6cd319ff41a47d70031958b0b38b973c36272fc4af6e69cce54e15e6bb6990
diff --git a/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
new file mode 100644
index 00000000..01ee4b7d
--- /dev/null
+++ b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit python-single-r1
+
+COMMIT=fb7c549753de7a5579ed3400dd9f8ac71f7bf1b1
+
+DESCRIPTION="Synchronize files between a PC and an Android device using ADB"
+HOMEPAGE="https://github.com/google/adb-sync"
+SRC_URI="https://github.com/google/adb-sync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+channel"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-util/android-tools
+ channel? ( net-misc/socat )"
+DEPEND=""
+
+S="${WORKDIR}/adb-sync-${COMMIT}"
+
+src_install() {
+ dodoc README.md
+ python_doscript adb-sync
+ use channel && dobin adb-channel
+}
diff --git a/app-mobilephone/adb-sync/metadata.xml b/app-mobilephone/adb-sync/metadata.xml
new file mode 100644
index 00000000..d076f30c
--- /dev/null
+++ b/app-mobilephone/adb-sync/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <bugs-to>https://github.com/google/adb-sync/issues</bugs-to>
+ <remote-id type="github">google/adb-sync</remote-id>
+ </upstream>
+ <use>
+ <flag name="channel">Install the adb-channel script</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-portage/etcat/etcat-1.0.2.ebuild b/app-portage/etcat/etcat-1.0.2.ebuild
index 1eced863..36229c17 100644
--- a/app-portage/etcat/etcat-1.0.2.ebuild
+++ b/app-portage/etcat/etcat-1.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
case ${PV} in
99999999*)
diff --git a/app-portage/etcat/etcat-99999999.ebuild b/app-portage/etcat/etcat-99999999.ebuild
index 1eced863..36229c17 100644
--- a/app-portage/etcat/etcat-99999999.ebuild
+++ b/app-portage/etcat/etcat-99999999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
case ${PV} in
99999999*)
diff --git a/app-text/stardict/stardict-3.0.6-r4.ebuild b/app-text/stardict/stardict-3.0.6-r4.ebuild
index a35f54d6..dad3b6bc 100644
--- a/app-text/stardict/stardict-3.0.6-r4.ebuild
+++ b/app-text/stardict/stardict-3.0.6-r4.ebuild
@@ -8,7 +8,7 @@ EAPI=7
# seperate for now.
GNOME2_LA_PUNT=yes
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit autotools flag-o-matic gnome2 python-single-r1
diff --git a/app-text/stardict/stardict-4.0.0_pre20170304.ebuild b/app-text/stardict/stardict-4.0.0_pre20170304.ebuild
index cc9264a4..ccebab56 100644
--- a/app-text/stardict/stardict-4.0.0_pre20170304.ebuild
+++ b/app-text/stardict/stardict-4.0.0_pre20170304.ebuild
@@ -8,7 +8,7 @@ EAPI=7
# seperate for now.
GNOME2_LA_PUNT=yes
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit autotools flag-o-matic gnome2 python-single-r1
diff --git a/dev-cpp/cpplint/cpplint-99999999.ebuild b/dev-cpp/cpplint/cpplint-99999999.ebuild
index 9a8b89a8..6752cda9 100644
--- a/dev-cpp/cpplint/cpplint-99999999.ebuild
+++ b/dev-cpp/cpplint/cpplint-99999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{7,8,9,10} )
EGIT_REPO_URI="https://github.com/google/styleguide.git"
inherit elisp-common git-r3 python-single-r1
RESTRICT="mirror"
diff --git a/dev-python/PyPDF2/PyPDF2-1.26.0.ebuild b/dev-python/PyPDF2/PyPDF2-1.26.0.ebuild
index 2498a421..491d56c8 100644
--- a/dev-python/PyPDF2/PyPDF2-1.26.0.ebuild
+++ b/dev-python/PyPDF2/PyPDF2-1.26.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit distutils-r1
diff --git a/dev-util/flawfinder/Manifest b/dev-util/flawfinder/Manifest
new file mode 100644
index 00000000..5b443b7b
--- /dev/null
+++ b/dev-util/flawfinder/Manifest
@@ -0,0 +1 @@
+DIST flawfinder-2.0.15.tar.gz 253677 BLAKE2B 5c4a0e21e0a7f144382c6ca25f713aef9bdb413d4bb5a73f66632ef365f55c75e755ab59cf92fb54dc2d043c8b88be8c28d5f5fca36df6795dabc00313b839f2 SHA512 12b637bae789ee86710c7d6ee203b811e78414ad5d173730bfffe3ea783a76ce999878c57ddaa8019744cac6bf94967663fd9fd80769d7a24b0a79d23c0b0d9d
diff --git a/dev-util/flawfinder/flawfinder-2.0.15.ebuild b/dev-util/flawfinder/flawfinder-2.0.15.ebuild
new file mode 100644
index 00000000..ae622da6
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-2.0.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s/${PN}.1.gz/${PN}.1/g" setup.py || die 'sed failed.'
+ default
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+ distutils-r1_python_install_all
+}
diff --git a/dev-util/flawfinder/metadata.xml b/dev-util/flawfinder/metadata.xml
new file mode 100644
index 00000000..885fb2b1
--- /dev/null
+++ b/dev-util/flawfinder/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://sourceforge.net/p/flawfinder/code/ci/master/tree/ChangeLog</changelog>
+ <bugs-to>https://sourceforge.net/p/flawfinder/bugs/</bugs-to>
+ <remote-id type="sourceforge">flawfinder</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild b/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild
index 8a3809d1..8c3ae6a8 100644
--- a/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild
+++ b/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit python-any-r1 toolchain-funcs qmake-utils
MY_PV="${PV/.}"
diff --git a/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild
index e96311d5..0e0895bf 100644
--- a/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild
+++ b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit autotools flag-o-matic desktop python-any-r1 xdg
MY_PV=$(ver_rs 2 '')
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-2.7.8.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-2.7.8.ebuild
index e8abc5a3..38318d25 100644
--- a/media-libs/avidemux-plugins/avidemux-plugins-2.7.8.ebuild
+++ b/media-libs/avidemux-plugins/avidemux-plugins-2.7.8.ebuild
@@ -4,7 +4,7 @@
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit cmake flag-o-matic python-single-r1
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 4eef25d5..3b919960 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -20,6 +20,7 @@ app-emacs/mv_emacs 1.4-r1: (X)Emacs extensions: block support, macrorecorder, ve
app-eselect/eselect-net 0.2-r1: eselect module for managing network open-rc service configurations
app-misc/knapsack 7.3: A fast solver for the 0/1-knapsack problem with multiple knapsacks
app-misc/machine-learning-mv 1.3: Some machine learning experiments
+app-mobilephone/adb-sync 0_p20190101: Synchronize files between a PC and an Android device using ADB
app-portage/changelog-gitrepo 1.1: Create ChangeLog data for gentoo repositories from git
app-portage/eix 0.34.12 99999999: Search and query ebuilds
app-portage/etcat 1.0.2 99999999: Updated version of an old Portage information extractor
@@ -57,6 +58,7 @@ dev-python/PyPDF2 1.26.0: Python library to work with pdf files
dev-tex/chklref 2.6.0 2.6.1_alpha20170913: Finds useless references in latex files or unnecessarily numbered environments
dev-util/comp 4.3.1: compare files or directories, including metadata
dev-util/diffhelp 1.12: A frontend, beautifier, and path-fixer for diff -u
+dev-util/flawfinder 2.0.15: Examines C/C++ source code for security flaws
dev-util/mv_perl 4.2: A collection of perl scripts (replacement in files, syncing dirs etc)
dev-util/pyrep 1.5-r1: Search and/or replace regular expressions within many files interactively
dev-util/replacer 3.3: Search and replace python regular expressions within many files interactively
@@ -134,4 +136,5 @@ www-plugins/translate-to-me 1.1: Firefox webextension: translate the selected te
www-plugins/ublock-origin 1.17.2: Firefox webextension: An efficient list-based blocker
x11-libs/gtk+ 2.24.33 3.24.29: Gimp ToolKit +
x11-libs/motif 2.3.8-r1: The Motif user interface component toolkit
-x11-misc/redshift 1.12-r4: A screen color temperature adjusting software
+x11-terms/kitty 0.19.3: A modern, hackable, featureful, OpenGL-based terminal emulator
+x11-themes/fvwm-crystal 3.6.5: Configurable FVWM theme with transparency and freedesktop compatible menu
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index ab241b56..12afa657 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -3,6 +3,7 @@
# * generated automatically using egencache *
app-cdr/cdrtools:schily-tools - Use libschily from app-shells/schily-tools
+app-mobilephone/adb-sync:channel - Install the adb-channel script
app-portage/eix:debug - Build with upstream's CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.
app-portage/eix:dep - Make DEP=true the default which enables support for {,R,P,B}DEPEND but requires roughly double disk and memory.
app-portage/eix:doc - Create description of the eix cache file additionally in html format
@@ -213,4 +214,3 @@ x11-libs/gtk+:broadway - Enable the GDK Broadway backend.
x11-libs/gtk+:cloudprint - Enable printing via Google Cloud Print.
x11-libs/gtk+:colord - Use x11-misc/colord for color management in printing
x11-libs/motif:motif22-compatibility - Compatibility with Open Motif 2.2
-x11-misc/redshift:geoclue - Control dependency on app-misc/geoclue
diff --git a/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-0.5.9.ebuild b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-0.5.9.ebuild
index 1813a692..aae1e037 100644
--- a/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-0.5.9.ebuild
+++ b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-0.5.9.ebuild
@@ -1,9 +1,9 @@
- # Copyright 1999-2020 Gentoo Authors
+ # Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit distutils-r1
diff --git a/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild
index 1813a692..029b37f1 100644
--- a/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild
+++ b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild
@@ -1,9 +1,9 @@
- # Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit distutils-r1
diff --git a/x11-misc/redshift/Manifest b/x11-misc/redshift/Manifest
deleted file mode 100644
index f69f2521..00000000
--- a/x11-misc/redshift/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST redshift-1.12.tar.gz 659019 SHA512 6763f6964b577fc146191af1c67a283a60df5bbdd3a74bfc94f66d5f9f3bef8835a479c6ec8a648b650b83a0e245928884a0f628606ace8c3f58d8319d35036f
diff --git a/x11-misc/redshift/metadata.xml b/x11-misc/redshift/metadata.xml
deleted file mode 100644
index fbfb697d..00000000
--- a/x11-misc/redshift/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>sping@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>desktop-misc@gentoo.org</email>
- <name>Gentoo Desktop Miscellaneous Project</name>
- </maintainer>
- <use>
- <flag name="geoclue">Control dependency on <pkg>app-misc/geoclue</pkg></flag>
- </use>
- <upstream>
- <remote-id type="github">jonls/redshift</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/x11-misc/redshift/redshift-1.12-r4.ebuild b/x11-misc/redshift/redshift-1.12-r4.ebuild
deleted file mode 100644
index 2b33f0e6..00000000
--- a/x11-misc/redshift/redshift-1.12-r4.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit autotools gnome2-utils python-r1 systemd
-
-DESCRIPTION="A screen color temperature adjusting software"
-HOMEPAGE="http://jonls.dk/redshift/"
-SRC_URI="https://github.com/jonls/redshift/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="appindicator geoclue gtk nls"
-
-COMMON_DEPEND=">=x11-libs/libX11-1.4
- x11-libs/libXxf86vm
- x11-libs/libxcb
- x11-libs/libdrm
- appindicator? ( dev-libs/libappindicator:3[introspection] )
- geoclue? ( app-misc/geoclue:2.0 dev-libs/glib:2 )
- gtk? ( ${PYTHON_DEPS} )"
-RDEPEND="${COMMON_DEPEND}
- gtk? ( dev-python/pygobject[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection]
- dev-python/pyxdg[${PYTHON_USEDEP}] )"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.50
- nls? ( sys-devel/gettext )
-"
-BDEPEND=${DEPEND}
-REQUIRED_USE="gtk? ( ${PYTHON_REQUIRED_USE} )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- use gtk && python_setup
-
- econf \
- $(use_enable nls) \
- --enable-drm \
- --enable-randr \
- --enable-vidmode \
- --disable-wingdi \
- \
- --disable-corelocation \
- $(use_enable geoclue geoclue2) \
- \
- $(use_enable gtk gui) \
- --with-systemduserunitdir="$(systemd_get_userunitdir)" \
- --enable-apparmor \
- --disable-quartz \
- --disable-ubuntu
-}
-
-_impl_specific_src_install() {
- emake DESTDIR="${D}" pythondir="$(python_get_sitedir)" \
- -C src/redshift-gtk install
-}
-
-src_install() {
- emake DESTDIR="${D}" UPDATE_ICON_CACHE=/bin/true install
-
- if use gtk; then
- python_foreach_impl _impl_specific_src_install
- python_replicate_script "${D}"/usr/bin/redshift-gtk
- dosym redshift-gtk /usr/bin/gtk-redshift
-
- python_foreach_impl python_optimize
- fi
-}
-
-pkg_preinst() {
- use gtk && gnome2_icon_savelist
-}
-
-pkg_postinst() {
- use gtk && gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- use gtk && gnome2_icon_cache_update
-}
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
new file mode 100644
index 00000000..a8e07181
--- /dev/null
+++ b/x11-terms/kitty/Manifest
@@ -0,0 +1 @@
+DIST kitty-0.19.3.tar.xz 3269628 SHA512 d1eea7f909c9492542650a83a149fd279c44380cf10387759f10caad57cd4dbabeac1ce84e8142bfa47266ec2562dfa3766ce08e2aee4d8e0ebacea165f101e4
diff --git a/x11-terms/kitty/files/kitty-0.14.4-svg-icon.patch b/x11-terms/kitty/files/kitty-0.14.4-svg-icon.patch
new file mode 100644
index 00000000..13f874dd
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.14.4-svg-icon.patch
@@ -0,0 +1,16 @@
+Use SVG icon instead of PNG.
+
+--- kitty-0.14.4/setup.py
++++ kitty-0.14.4/setup.py
+@@ -710,9 +710,9 @@
+ run_tool(['make', 'docs'])
+ copy_man_pages(ddir)
+ copy_html_docs(ddir)
+- icdir = os.path.join(ddir, 'share', 'icons', 'hicolor', '256x256', 'apps')
++ icdir = os.path.join(ddir, 'share', 'icons', 'hicolor', 'scalable', 'apps')
+ safe_makedirs(icdir)
+- shutil.copy2('logo/kitty.png', icdir)
++ shutil.copy2('logo/kitty.svg', icdir)
+ deskdir = os.path.join(ddir, 'share', 'applications')
+ safe_makedirs(deskdir)
+ with open(os.path.join(deskdir, 'kitty.desktop'), 'w') as f:
diff --git a/x11-terms/kitty/files/kitty-0.16.0-remove-terminfo.patch b/x11-terms/kitty/files/kitty-0.16.0-remove-terminfo.patch
new file mode 100644
index 00000000..4b7352aa
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.16.0-remove-terminfo.patch
@@ -0,0 +1,14 @@
+--- a/setup.py
++++ b/setup.py
+@@ -837,11 +837,6 @@
+ safe_makedirs(launcher_dir)
+ build_launcher(args, launcher_dir, bundle_type)
+ os.makedirs(os.path.join(libdir, 'logo'))
+- build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
+- for x in (libdir, os.path.join(ddir, 'share')):
+- odir = os.path.join(x, 'terminfo')
+- safe_makedirs(odir)
+- build_terminfo['compile_terminfo'](odir)
+ shutil.copy2('__main__.py', libdir)
+ shutil.copy2('logo/kitty.rgba', os.path.join(libdir, 'logo'))
+ shutil.copy2('logo/kitty.png', os.path.join(libdir, 'logo'))
diff --git a/x11-terms/kitty/files/kitty-0.17.2-flags.patch b/x11-terms/kitty/files/kitty-0.17.2-flags.patch
new file mode 100644
index 00000000..5a247679
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.17.2-flags.patch
@@ -0,0 +1,50 @@
+Respect user CFLAGS.
+
+--- a/setup.py
++++ b/setup.py
+@@ -236,7 +236,7 @@
+ if ccver >= (5, 0):
+ df += ' -Og'
+ float_conversion = '-Wfloat-conversion'
+ fortify_source = '-D_FORTIFY_SOURCE=2'
+- optimize = df if debug or sanitize else '-O3'
++ optimize = ''
+ sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
+ cppflags_ = os.environ.get(
+ 'OVERRIDE_CPPFLAGS', '-D{}DEBUG'.format('' if debug else 'N'),
+@@ -217,7 +217,7 @@
+ cflags = os.environ.get(
+ 'OVERRIDE_CFLAGS', (
+ '-Wextra {} -Wno-missing-field-initializers -Wall -Wstrict-prototypes -std=c11'
+- ' -pedantic-errors -Werror {} {} -fwrapv {} {} -pipe {} -fvisibility=hidden'
++ ' -pedantic-errors {} {} -fwrapv {} {} {} -fvisibility=hidden'
+ ).format(
+ float_conversion, std,
+ optimize,
+@@ -232,7 +232,7 @@
+ )
+ ldflags = os.environ.get(
+ 'OVERRIDE_LDFLAGS',
+- '-Wall ' + ' '.join(sanitize_args) + ('' if debug else ' -O3')
++ '-Wall ' + ' '.join(sanitize_args)
+ )
+ ldflags = shlex.split(ldflags)
+ ldflags.append('-shared')
+@@ -614,7 +614,7 @@
+
+
+ def build_launcher(args, launcher_dir='.', bundle_type='source'):
+- cflags = '-Wall -Werror -fpie'.split()
++ cflags = '-Wall -fpie'.split()
+ cppflags = []
+ libs = []
+ if args.profile or args.sanitize:
+@@ -626,8 +626,6 @@
+ cflags.append('-g')
+ if args.profile:
+ libs.append('-lprofiler')
+- else:
+- cflags.append('-O3')
+ if bundle_type.endswith('-freeze'):
+ cppflags.append('-DFOR_BUNDLE')
+ cppflags.append('-DPYVER="{}"'.format(sysconfig.get_python_version()))
diff --git a/x11-terms/kitty/files/kitty-0.19.1-tests.patch b/x11-terms/kitty/files/kitty-0.19.1-tests.patch
new file mode 100644
index 00000000..ee489b0d
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.19.1-tests.patch
@@ -0,0 +1,11 @@
+--- a/kitty/constants.py
++++ b/kitty/constants.py
+@@ -64,7 +64,7 @@
+ def kitty_exe() -> str:
+ rpath = sys._xoptions.get('bundle_exe_dir')
+ if not rpath:
+- items = os.environ.get('PATH', '').split(os.pathsep) + [os.path.join(base, 'launcher')]
++ items = os.environ.get('PATH', '').split(os.pathsep) + [os.path.join(base, '../linux-package/bin')]
+ seen: Set[str] = set()
+ for candidate in filter(None, items):
+ if candidate not in seen:
diff --git a/x11-terms/kitty/kitty-0.19.3.ebuild b/x11-terms/kitty/kitty-0.19.3.ebuild
new file mode 100644
index 00000000..0f8ad92b
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.19.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit optfeature python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug wayland"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=media-libs/harfbuzz-1.5.0:=
+ media-libs/lcms
+ media-libs/libcanberra
+ media-libs/libpng:0=
+ sys-apps/dbus
+ sys-libs/zlib
+ x11-libs/libxcb[xkb]
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon[X]
+ x11-libs/libXrandr
+ x11-terms/kitty-terminfo
+ wayland? (
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.17
+ )
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_6)
+"
+
+DEPEND="${RDEPEND}
+ media-libs/mesa[X]
+ sys-libs/ncurses
+"
+
+BDEPEND="virtual/pkgconfig"
+
+[[ ${PV} == *9999 ]] && BDEPEND+=" >=dev-python/sphinx-1.7"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.17.2-flags.patch
+ "${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
+ "${FILESDIR}"/${PN}-0.16.0-remove-terminfo.patch
+ "${FILESDIR}"/${PN}-0.19.1-tests.patch
+)
+
+src_prepare() {
+ default
+
+ # disable wayland as required
+ if ! use wayland; then
+ sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
+ fi
+
+ # respect doc dir
+ sed -i "/htmldir =/s/appname/'${PF}'/" setup.py || die
+
+ tc-export CC
+}
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ --update-check-interval=0 \
+ linux-package || die "Failed to compile kitty."
+}
+
+src_test() {
+ export KITTY_CONFIG_DIRECTORY=${T}
+ "${EPYTHON}" test.py || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+ dobin linux-package/bin/kitty
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ optfeature "Displaying images in the terminal" virtual/imagemagick-tools
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/x11-terms/kitty/metadata.xml b/x11-terms/kitty/metadata.xml
new file mode 100644
index 00000000..c44f7541
--- /dev/null
+++ b/x11-terms/kitty/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>pabloorduna98@gmail.com</email>
+ <name>Pablo Orduna</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kovidgoyal/kitty</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-themes/fvwm-crystal/Manifest b/x11-themes/fvwm-crystal/Manifest
new file mode 100644
index 00000000..22e9dbe5
--- /dev/null
+++ b/x11-themes/fvwm-crystal/Manifest
@@ -0,0 +1 @@
+DIST fvwm-crystal-3.6.5.tar.gz 5899049 BLAKE2B addd82dbbab9b457a94715a969a27ff6ef2be07cddd33a379dc4d5348c9565d3a19943828b068ec5ef5f6d032f51b77a1990316ee7b3e16e5dc98ddf32f98c7d SHA512 45cd99b83342e5e5f0de89edc92dbba3311efc7ef431d509490e3fd5b49420e94d1cef55865f45e731fd4c13172c6e2d26fbd10107cdb4a4f525379e17b94e6d
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.6.5.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.6.5.ebuild
new file mode 100644
index 00000000..4f8d7633
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.6.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+inherit readme.gentoo-r1 python-single-r1
+
+DESCRIPTION="Configurable FVWM theme with transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE=""
+
+case ${PV} in
+*9999)
+ inherit subversion
+ ESVN_REPO_URI="svn://svn.code.sf.net/p/fvwm-crystal/code"
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+ src_unpack() {
+ subversion_src_unpack
+ };;
+esac
+
+RDEPEND="${PYTHON_DEPS}
+ acct-group/fvwm-crystal
+ >=x11-wm/fvwm-2.6.9[png]
+ virtual/imagemagick-tools
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd
+ media-sound/alsa-utils"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="After a first time installation, execute the following commands:
+ $ cp -r "${EROOT}"/usr/share/doc/"${PF}"/addons/Xresources ~/.Xresources
+ $ cp -r "${EROOT}"/usr/share/doc/"${PF}"/addons/Xsession ~/.xinitrc
+You can edit these files at your convenience.
+
+Many applications can extend functionality of fvwm-crystal.
+They are listed in "${EROOT}"/usr/share/doc/"${PF}"/INSTALL.*
+
+To be able to use the exit menu, each user using ${PN}
+must be in the group fvwm-crystal.
+You can do that as root with:
+ $ useradd -G fvwm-crystal <user_name>
+and log out and in again.
+"
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+ # GNU License is globally in the portage tree
+ rm -vf "${ED}/usr/share/doc/${PF}"/LICENSE
+
+ python_doscript "${ED}/usr/bin/${PN}".{apps,wallpaper}
+ python_scriptinto "/usr/share/${PN}"/fvwm/scripts/FvwmMPD
+ python_doscript "${ED}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ elog "Many applications can extend functionality of fvwm-crystal."
+ elog "They are listed in ${EROOT}/usr/share/doc/${PF}/INSTALL.bz2"
+ elog "Popular supported softwares are:"
+ elog "- x11-misc/xdg-user-dirs (the gtk USE is not needed) to"
+ elog " get localized XDG user directories support"
+ elog "- sys-apps/systemd for hibernate/resume support"
+ elog "- media-sound/jack-audio-connection-kit for a professional sound server"
+ elog "- several media players"
+}
diff --git a/x11-themes/fvwm-crystal/metadata.xml b/x11-themes/fvwm-crystal/metadata.xml
new file mode 100644
index 00000000..c77a6de3
--- /dev/null
+++ b/x11-themes/fvwm-crystal/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>dominique.c.michel@gmail.com</email>
+ <name>Dominique Michel</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+FVWM-Crystal is a set of configuration files for FVWM window manager,
+with additional programs and scripts. Some of it's features are:
+ * quick launching of a terminal with just one click on a desktop
+ * a specially configured terminal window, similar to a console from FPP games
+ * builtin control over XMMS player and over aumix mixer from the keyboard and
+ buttons on the screen
+ * very good ability to control the desktop from the keyboard, including window
+ switching, moving, shading/unshading, maximizing, resizing, moving between
+ desktop pages
+ * transparent window titlebars, menus and panels on the desktop
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">fvwm-crystal</remote-id>
+ </upstream>
+</pkgmetadata>