summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/checksec/checksec-1.5.ebuild')
-rw-r--r--app-admin/checksec/checksec-1.5.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-admin/checksec/checksec-1.5.ebuild b/app-admin/checksec/checksec-1.5.ebuild
index ef210637..65abbbf9 100644
--- a/app-admin/checksec/checksec-1.5.ebuild
+++ b/app-admin/checksec/checksec-1.5.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
RESTRICT="mirror"
-inherit base
+inherit eutils
DESCRIPTION="Check for hardened protections like RELRO, NoExec, Stack protection, ASLR, PIE"
HOMEPAGE="http://www.trapkit.de/tools/checksec.html"
@@ -16,6 +16,10 @@ KEYWORDS="~amd64 ~x86"
IUSE="zsh-completion"
S="${WORKDIR}"
+src_prepare() {
+ epatch_user
+}
+
src_install() {
newbin "${DISTDIR}/${P}.sh" "${PN}"
if use zsh-completion