summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sudox/sudox-8.0.1.ebuild')
-rw-r--r--app-admin/sudox/sudox-8.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/sudox/sudox-8.0.1.ebuild b/app-admin/sudox/sudox-8.0.1.ebuild
new file mode 100644
index 00000000..59e02ec2
--- /dev/null
+++ b/app-admin/sudox/sudox-8.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+
+DESCRIPTION="wrapper for sudo which can pass X authority data and deal with screen and tmux"
+HOMEPAGE="https://github.com/vaeth/sudox/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-admin/sudo
+ app-shells/push"
+DEPEND=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}"'/bin/sh"' \
+ -- bin/* || die
+ eapply_user
+}
+
+src_install() {
+ dodoc README ChangeLog
+ newdoc sudoers.d/${PN} sudoers.d
+ dobin bin/${PN}
+ insinto /usr/bin
+ doins bin/${PN}e
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}