summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/lesspipe/lesspipe-1.84_alpha20180414-r1.ebuild')
-rw-r--r--app-text/lesspipe/lesspipe-1.84_alpha20180414-r1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/app-text/lesspipe/lesspipe-1.84_alpha20180414-r1.ebuild b/app-text/lesspipe/lesspipe-1.84_alpha20180414-r1.ebuild
index 07c66cdb..0a6ffc9a 100644
--- a/app-text/lesspipe/lesspipe-1.84_alpha20180414-r1.ebuild
+++ b/app-text/lesspipe/lesspipe-1.84_alpha20180414-r1.ebuild
@@ -25,16 +25,21 @@ case ${PV} in
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
+inherit required-use-warn
+pkg_pretend() {
+ required-use-warn
+}
IUSE="antiword brotli cabextract catdoc +cpio +djvu dpkg +dvi2tty +elinks fastjar +ghostscript gpg +groff hdf5 +html2text id3v2 image isoinfo libplist +links +lynx lz4 lzip mp3info mp3info2 netcdf ooffice p7zip pdf pstotext rar rpm +rpm2targz unrar unrtf +unzip +w3m xlhtml zstd"
htmlmode="( || ( html2text links lynx elinks w3m ) )"
REQUIRED_USE="!rpm2targz? ( rpm? ( cpio ) )
ooffice? ${htmlmode}
- xlhtml? ${htmlmode}
- amd64-fbsd? ( !antiword !catdoc !dpkg !elinks !fastjar !html2text
- !id3v2 !lzip !mp3info !mp3info2 !ooffice !p7zip !pstotext
- !rar !rpm !unrtf !w3m !xlhtml )
+ xlhtml? ${htmlmode}"
+REQUIRED_USE_WARN="
+ amd64-fbsd? ( !antiword !catdoc !dpkg !elinks !fastjar !hdf5 !html2text
+ !id3v2 !lzip !mp3info !mp3info2 !netcdf !ooffice !p7zip !pstotext
+ !rar !rpm !unrtf !w3m !xlhtml !zstd )
alpha? ( !brotli !catdoc !fastjar !id3v2 !libplist !mp3info !mp3info2
!netcdf !ooffice !pstotext !rar !zstd )
arm? ( !antiword !brotli !catdoc !fastjar !html2text !id3v2 !mp3info
@@ -55,7 +60,7 @@ BOTH_DEPEND="sys-apps/file
brotli? ( !alpha? ( !arm? ( !hppa? ( !ia64? ( !ppc? ( !ppc64?
( !sparc? ( >=app-arch/brotli-1 ) ) ) ) ) ) ) )
lz4? ( app-arch/lz4 )
- zstd? ( !alpha? ( !hppa? ( !ia64? ( !sparc? ( app-arch/zstd ) ) ) ) )
+ zstd? ( !amd64-fbsd? ( !alpha? ( !hppa? ( !ia64? ( !sparc? ( app-arch/zstd ) ) ) ) ) )
unzip? ( app-arch/unzip )
fastjar? ( !amd64-fbsd? ( !alpha? ( !arm? ( !hppa? ( !ia64? ( !ppc64?
( !sparc? ( app-arch/fastjar ) ) ) ) ) ) ) )
@@ -119,8 +124,8 @@ BOTH_DEPEND="sys-apps/file
isoinfo? ( || ( app-cdr/cdrtools app-cdr/dvd+rw-tools ) )
libplist? ( !alpha? ( !hppa? ( !ia64? ( !sparc? ( app-pda/libplist ) ) ) ) )
dpkg? ( !amd64-fbsd? ( app-arch/dpkg ) )
- hdf5? ( !hppa? ( sci-libs/hdf5 ) )
- netcdf? ( !alpha? ( !hppa? ( !ia64? ( !sparc? ( sci-libs/netcdf ) ) ) ) )"
+ hdf5? ( !amd64-fbsd? ( !hppa? ( sci-libs/hdf5 ) ) )
+ netcdf? ( !amd64-fbsd? ( !alpha? ( !hppa? ( !ia64? ( !sparc? ( sci-libs/netcdf ) ) ) ) ) )"
DEPEND="${BOTH_DEPEND}"
RDEPEND="${BOTH_DEPEND}
sys-apps/less