summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/chklref/chklref-2.5.2.ebuild')
-rw-r--r--dev-tex/chklref/chklref-2.5.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-tex/chklref/chklref-2.5.2.ebuild b/dev-tex/chklref/chklref-2.5.2.ebuild
new file mode 100644
index 00000000..e1a10183
--- /dev/null
+++ b/dev-tex/chklref/chklref-2.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit eutils latex-package
+RESTRICT="mirror"
+
+DESCRIPTION="Finds out useless references in latex files or numbered environments that should not be"
+HOMEPAGE="http://www-ljk.imag.fr/membres/Jerome.Lelong/soft/chklref/index.html"
+SRC_URI="http://www-ljk.imag.fr/membres/Jerome.Lelong/soft/chklref/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- "${S}"/src/chklref.in || die
+ epatch_user
+}
+
+src_configure() {
+ econf --with-texmf-prefix="${EPREFIX}${TEXMF}"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+ dodoc README
+}