summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/martian/martian-20100123.ebuild')
-rw-r--r--net-dialup/martian/martian-20100123.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-dialup/martian/martian-20100123.ebuild b/net-dialup/martian/martian-20100123.ebuild
index 4e7966f2..a703ad05 100644
--- a/net-dialup/martian/martian-20100123.ebuild
+++ b/net-dialup/martian/martian-20100123.ebuild
@@ -3,7 +3,7 @@
# $Header $
EAPI="4"
-inherit base linux-mod eutils
+inherit linux-mod eutils
ARCHRUMP="${PN}-full-${PV}"
DESCRIPTION="Winmodems with Lucent Apollo (ISA) and Mars (PCI) chipsets"
@@ -25,8 +25,6 @@ MODULE_NAMES="martian_dev(ltmodem::kmodule)"
CONFIG_CHECK="SERIAL_8250"
SERIAL_8250_ERROR="This driver requires you to compile your kernel with serial core (CONFIG_SERIAL_8250) support."
-PATCHES=("${FILESDIR}/grsecurity.patch")
-
pkg_setup() {
linux-mod_pkg_setup
@@ -39,6 +37,11 @@ pkg_setup() {
BUILD_PARAMS="KERNEL_DIR='${KV_DIR}' SUBLEVEL='21'"
}
+src_prepare() {
+ epatch "${FILESDIR}/grsecurity.patch"
+ epatch_user
+}
+
src_install() {
# install kernel module
linux-mod_src_install