summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/kernel/kernel-1.22.ebuild')
-rw-r--r--sys-kernel/kernel/kernel-1.22.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-kernel/kernel/kernel-1.22.ebuild b/sys-kernel/kernel/kernel-1.22.ebuild
new file mode 100644
index 00000000..1671e206
--- /dev/null
+++ b/sys-kernel/kernel/kernel-1.22.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="A POSIX shell script to compile the kernel with user permissions"
+HOMEPAGE="https://github.com/vaeth/kernel/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+eix +title zsh-completion"
+RDEPEND="app-admin/sudo
+ app-admin/sudox
+ app-shells/push
+ eix? ( app-portage/eix )
+ title? ( >=app-shells/runtitle-2.0 )"
+DEPEND=""
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin "${PN}"
+}