summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Kaiser <nikai@nikai.net>2010-07-19 13:03:33 +0200
committerNicolas Kaiser <nikai@nikai.net>2010-07-19 13:03:33 +0200
commit9864e32b810b442c78169d87ae6f0c4f155a3966 (patch)
tree8be8d193ea3d1b2d5e01d51392ed48c72c5af322
downloadnikai-9864e32b810b442c78169d87ae6f0c4f155a3966.tar.gz
nikai-9864e32b810b442c78169d87ae6f0c4f155a3966.tar.bz2
nikai-9864e32b810b442c78169d87ae6f0c4f155a3966.zip
initial commit
-rw-r--r--games-simulation/vegastrike-data/Manifest2
-rw-r--r--games-simulation/vegastrike-data/metadata.xml9
-rw-r--r--games-simulation/vegastrike-data/vegastrike-data-9999.ebuild71
-rw-r--r--games-simulation/vegastrike/Manifest2
-rw-r--r--games-simulation/vegastrike/metadata.xml16
-rw-r--r--games-simulation/vegastrike/vegastrike-9999.ebuild177
-rw-r--r--profiles/package.mask4
-rw-r--r--profiles/repo_name1
8 files changed, 282 insertions, 0 deletions
diff --git a/games-simulation/vegastrike-data/Manifest b/games-simulation/vegastrike-data/Manifest
new file mode 100644
index 0000000..f6a80fb
--- /dev/null
+++ b/games-simulation/vegastrike-data/Manifest
@@ -0,0 +1,2 @@
+EBUILD vegastrike-data-9999.ebuild 1754 RMD160 d6d86ce9cc0430533491ca5dd87277e91b6990a1 SHA1 b01077088de681976f305efd021fec8c8987909d SHA256 0257f145422ca0d9066d7dca4d580be1cab61505ced1189cf094ff448faa6aef
+MISC metadata.xml 599 RMD160 f72a40de6ab575b080e83159f217823c9ae242e8 SHA1 e95e0172986a1fd0c89288d7ce2c9c3d9f2ec0fd SHA256 fc132bb4479504e400941fcf25eb0434468a556386f7f01f06da4009805dddfe
diff --git a/games-simulation/vegastrike-data/metadata.xml b/games-simulation/vegastrike-data/metadata.xml
new file mode 100644
index 0000000..cda9271
--- /dev/null
+++ b/games-simulation/vegastrike-data/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>nikai@nikai.net</email>
+</maintainer>
+<longdescription>Vega Strike is an Open Source 3D Action-Space-Sim that lets you trade, fight, and explore in a vast universe. The data branch of Vega Strike contains 3D models, textures and backgrounds, and also documentation. Parts of this branch are generated from original master files in the master branch. The data branch is required to play the game.</longdescription>
+</pkgmetadata>
diff --git a/games-simulation/vegastrike-data/vegastrike-data-9999.ebuild b/games-simulation/vegastrike-data/vegastrike-data-9999.ebuild
new file mode 100644
index 0000000..d6751bd
--- /dev/null
+++ b/games-simulation/vegastrike-data/vegastrike-data-9999.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Derived from bug 65084
+
+inherit eutils games
+[ "$PV" == "9999" ] && inherit subversion
+
+ESVN_REPO_URI="https://vegastrike.svn.sourceforge.net/svnroot/vegastrike/trunk"
+ESVN_PROJECT="vegastrike"
+ESVN_BOOTSTRAP="vegastrike/bootstrap-sh"
+
+DESCRIPTION="A 3D space simulator that allows you to trade and bounty hunt"
+HOMEPAGE="http://vegastrike.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ games_pkg_setup
+}
+
+src_unpack() {
+ cd "${S}"
+ local svn=${ESVN_TOP_DIR}
+
+ if ([ ! -d "${svn}/data" ] && [ ! -d "${svn}/data" ]); then
+ ESVN_MODULE="data"
+ ESVN_MODULE_DIR="${ESVN_REPO_URI}/${ESVN_MODULE}"
+ subversion_fetch $ESVN_MODULE_DIR $ESVN_MODULE || die "Fetching data failed"
+ fi
+
+ einfo "Copying data to work directory..."
+ cp -a "${svn}"/{data} "${S}" >&/dev/null
+
+ cd "${S}"/data
+ # Clean up data dir
+ esvn_clean "${S}"
+ find "${S}" -name "*.pyc" -type f -exec rm -f '{}' \; >&/dev/null
+
+ # Sort out directory references
+ sed -i \
+ -e "s!/usr/local/share/doc!/usr/share/doc!" \
+ -e "s!/usr/local/share/vegastrike!${GAMES_DATADIR}/vegastrike!" \
+ -e "s!/usr/local/bin!${GAMES_BINDIR}!" \
+ -e "s!/usr/local/lib/man!/usr/share/man!" \
+ "${S}/data/documentation/vegastrike.1" \
+ || die "sed data/documentation/vegastrike.1 failed"
+}
+
+src_install() {
+ doman "${S}"/data/documentation/*.1
+ dodoc "${S}"/data/documentation/*.txt
+
+ doicon "${S}/data/vegastrike.xpm"
+
+ dodir "${GAMES_DATADIR}/vegastrike"
+ cp -r data/ "${D}/${GAMES_DATADIR}/vegastrike/" || die "cp failed (data)"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+}
diff --git a/games-simulation/vegastrike/Manifest b/games-simulation/vegastrike/Manifest
new file mode 100644
index 0000000..a2573ec
--- /dev/null
+++ b/games-simulation/vegastrike/Manifest
@@ -0,0 +1,2 @@
+EBUILD vegastrike-9999.ebuild 5098 RMD160 cffbe95b712ff745134a7680c5910e7d5c27b38b SHA1 9c42e90934211c4b970588ab439d19e16b0c2989 SHA256 8f40ddd773959b7a7f61d37022ae7cd57d76294b0fb25b14037f94f7103f3923
+MISC metadata.xml 821 RMD160 f476e39e14dfdd9ebbc54c9e6042c20aa5b38721 SHA1 99684b8c0984d441011e0773f1df1802cd9e0353 SHA256 15962bbc4c2f2458923461e9d09a7a7c834af4ed73be66a28c814204d2a691a3
diff --git a/games-simulation/vegastrike/metadata.xml b/games-simulation/vegastrike/metadata.xml
new file mode 100644
index 0000000..205947b
--- /dev/null
+++ b/games-simulation/vegastrike/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>nikai@nikai.net</email>
+</maintainer>
+<longdescription>Vega Strike is an Open Source 3D Action-Space-Sim that lets you trade, fight, and explore in a vast universe. The vegastrike branch contains the game source code.</longdescription>
+<use>
+ <flag name='gtk'>FIXME: Description of how USE='gtk' affects this package</flag>
+ <flag name='sdl'>FIXME: Description of how USE='sdl' affects this package</flag>
+ <flag name='debug'>FIXME: Description of how USE='debug' affects this package</flag>
+ <flag name='stencil-buffer'>FIXME: No idea at the moment.</flag>
+ <flag name='no-sound'>FIXME: Check config and dependencies.</flag>
+</use>
+</pkgmetadata>
diff --git a/games-simulation/vegastrike/vegastrike-9999.ebuild b/games-simulation/vegastrike/vegastrike-9999.ebuild
new file mode 100644
index 0000000..e9edff5
--- /dev/null
+++ b/games-simulation/vegastrike/vegastrike-9999.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Derived from bug 65084
+
+inherit flag-o-matic eutils games
+[ "$PV" == "9999" ] && inherit subversion
+
+ESVN_REPO_URI="https://vegastrike.svn.sourceforge.net/svnroot/vegastrike/trunk"
+ESVN_PROJECT="vegastrike"
+ESVN_BOOTSTRAP="vegastrike/bootstrap-sh"
+
+DESCRIPTION="A 3D space simulator that allows you to trade and bounty hunt"
+HOMEPAGE="http://vegastrike.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# FIXME: check configure options
+IUSE="stencil-buffer gtk no-sound sdl debug"
+
+# FIXME: check dependencies
+RDEPEND="
+ dev-lang/python
+ virtual/opengl
+ media-libs/jpeg
+ media-libs/libpng
+ dev-libs/expat
+ media-libs/openal
+ sdl? ( media-libs/libsdl )
+ !no-sound? ( media-libs/libvorbis
+ media-libs/libogg
+ sdl? ( media-libs/sdl-mixer ) )
+ virtual/glut
+ virtual/glu
+ gtk? ( x11-libs/gtk+ )
+ games-simulation/vegastrike-data"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.58"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ games_pkg_setup
+ # FIXME: is this still a problem?
+ einfo "If compiling fails for you on gl_globals.h, try to replace your"
+ einfo "glext.h (usually found in /usr/include/GL/ with this one"
+ einfo "http://oss.sgi.com/projects/ogl-sample/ABI/glext.h"
+ einfo "remember to make backup of the original though"
+}
+
+src_unpack() {
+ cd "${S}"
+ local svn=${ESVN_TOP_DIR}
+
+ if [ ! -d "${svn}/vegastrike" ]; then
+ ESVN_MODULE="vegastrike"
+ ESVN_MODULE_DIR="${ESVN_REPO_URI}/${ESVN_MODULE}"
+ subversion_fetch $ESVN_MODULE_DIR $ESVN_MODULE || die "Fetching vegastrike failed"
+ fi
+
+ einfo "Copying source to work directory..."
+ cp -a "${svn}"/{vegastrike,vssetup} "${S}" >&/dev/null
+
+ # Sort out directory references
+ # FIXME: check whether these are still needed
+ cd "${S}/${PN}"
+ sed -i \
+ -e "s!/usr/games/vegastrike!${GAMES_DATADIR}/${PN}!" \
+ -e "s!/usr/games/bin!${GAMES_BINDIR}!" \
+ launcher/saveinterface.cpp \
+ || die "sed launcher/saveinterface.cpp failed"
+ sed -i \
+ "s!/usr/local/share/vegastrike!${GAMES_DATADIR}/${PN}!" \
+ src/common/common.cpp \
+ || die "sed src/common/common.cpp failed"
+ sed -i \
+ "s!/usr/share/local/vegastrike!${GAMES_DATADIR}/${PN}!" \
+ src/vsfilesystem.cpp \
+ || die "sed src/filesys.cpp failed"
+ sed -i \
+ -e '/^SUBDIRS =/s:tools::' \
+ Makefile.am \
+ || die "sed Makefile.am failed"
+
+ # FIXME: vssetup doesn't find "readme.txt"
+ # from vegastrike/setup/src/include/display_gtk.cpp +69
+ # execlp("less", "less","readme.txt", NULL); //Will this work in Linux?
+
+ # FIXME: is this still a problem?
+ # is not possible here to use built in function subversion_bootstrap: it
+ # won't work as expected: ./bootstrap isn't in main compile dir
+ ./bootstrap-sh
+}
+
+src_compile() {
+ cd "${S}"/vegastrike
+ local conf_opts="${conf_opts} --disable-dependency-tracking"
+
+ # DATA_DIR
+ conf_opts="${conf_opts} --with-data-dir=${GAMES_DATADIR}/${PN}/data"
+
+ if use debug; then
+ conf_opts="${conf_opts} --enable-debug"
+ else
+ # FIXME: This actually enables -O2.
+ # -O3 appears to make problems in some cases.
+ # Might not be a great idea to mix with user -O flags.
+ conf_opts="${conf_opts} --enable-release=2"
+ fi
+
+ if ! use gtk; then
+ conf_opts="${conf_opts} --disable-gtk"
+ fi
+
+ CONFIGURE_OPTIONS="
+ $(use_enable stencil-buffer)
+ $(use_enable sdl)
+ $(use_enable !no-sound sound)
+ ${conf_opts}"
+
+ egamesconf $CONFIGURE_OPTIONS \
+ || die "egamesconf failed"
+
+ # FIXME: Is this still a problem?
+ # FIXME: CXXFLAGS can be supplied in a better way.
+ # it causes corruptions
+ filter-flags -ffast-math
+# # Let's optimize, removing also broken -ffast-math
+ sed -i -e "s:-ffast-math:${CXXFLAGS}:g" Makefile \
+ || die "sed of CXXFLAGS failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ cat << EOF > vsinstall
+#!/bin/sh
+(
+mkdir \${HOME}/.vegastrike 2> /dev/null
+cd \${HOME}/.vegastrike
+cp "${GAMES_DATADIR}"/vegastrike/data/setup.config .
+cp -r "${GAMES_DATADIR}"/vegastrike/data/.vegastrike/* .
+cp "${GAMES_DATADIR}"/vegastrike/data/vegastrike.config .
+vssetup
+)
+echo "If you wish to have your own music edit ~/.vegastrike/*.m3u"
+echo "Each playlist represents a place or situation in Vega Strike"
+exit 0
+EOF
+
+ dogamesbin vegastrike/vegastrike \
+ || die "Creation of vegastrike (the binary) failed"
+ dogamesbin vsinstall \
+ || die "Creation of vsinstall failed"
+ dogamesbin vegastrike/vegaserver \
+ || die "Creation of vegaserver failed"
+ dogamesbin vegastrike/mesher \
+ || die "Creation of mesher failed"
+
+ if use gtk; then
+ newgamesbin vegastrike/vssetup vssetup || die "newgamesbin failed"
+ fi
+
+ make_desktop_entry "vegastrike" "Vegastrike" "${GAMES_DATADIR}/${PN}/data/vegastrike.xpm"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "First run vsinstall to install your account into ~/.vegastrike,"
+ einfo "then run vegastrike to start Vega Strike;"
+ einfo "Run vssetup to configure Vega Strike."
+ einfo "To start Vega Strike Server run vegaserver."
+ einfo "(FIXME: vssetup/vsinstall currently won't find readme.txt."
+ einfo " It's in ${GAMES_DATADIR}/${PN}/data/documentation/.)"
+}
diff --git a/profiles/package.mask b/profiles/package.mask
new file mode 100644
index 0000000..713c51e
--- /dev/null
+++ b/profiles/package.mask
@@ -0,0 +1,4 @@
+# Nicolas Kaiser <nikai@nikai.net (19 Jul 2010)
+# Vega Strike live ebuilds. Use at your own risk.
+~games-simulation/vegastrike-data-9999
+~games-simulation/vegastrike-9999
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100644
index 0000000..625eaa8
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+nikai