summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalmer Dabbelt <palmer@dabbelt.com>2015-07-16 10:18:23 -0700
committerPalmer Dabbelt <palmer@dabbelt.com>2015-07-16 10:18:23 -0700
commit4b945ddaba20c433eca28f620e6496d5540b2281 (patch)
tree4021a7d30f4a5c0b942b05bba6a298b927276ae6 /net-misc/faifa/faifa-0.1.ebuild
parentUpdate flo-llvm to 0.0.22 (diff)
downloadpalmer-4b945ddaba20c433eca28f620e6496d5540b2281.tar.gz
palmer-4b945ddaba20c433eca28f620e6496d5540b2281.tar.bz2
palmer-4b945ddaba20c433eca28f620e6496d5540b2281.zip
Import net-misc/faifa from ZPO
Diffstat (limited to 'net-misc/faifa/faifa-0.1.ebuild')
-rw-r--r--net-misc/faifa/faifa-0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/faifa/faifa-0.1.ebuild b/net-misc/faifa/faifa-0.1.ebuild
new file mode 100644
index 0000000..1875b4d
--- /dev/null
+++ b/net-misc/faifa/faifa-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Power Line Communication device manager"
+HOMEPAGE="https://github.com/ffainelli/faifa"
+SRC_URI="https://github.com/ffainelli/faifa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"_symlink.patch
+ #do no strip
+ sed -i -e "s:installman strip:installman:" Makefile.in
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}