summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/tek/tek-0.7.1.ebuild')
-rw-r--r--app-text/tek/tek-0.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/tek/tek-0.7.1.ebuild b/app-text/tek/tek-0.7.1.ebuild
new file mode 100644
index 0000000..7fbe3fc
--- /dev/null
+++ b/app-text/tek/tek-0.7.1.ebuild
@@ -0,0 +1,39 @@
+EAPI="2"
+
+DESCRIPTION="A simple Makefile generator for LaTeX"
+HOMEPAGE="http://dabbelt.com/~palmer/software/tek/"
+SRC_URI="https://github.com/palmer-dabbelt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 amd64-linux"
+IUSE=""
+
+RDEPEND="sys-devel/pconfigure
+ sys-devel/make
+ dev-tex/tex4ht
+ media-gfx/xfig
+ media-gfx/imagemagick
+ media-gfx/inkscape
+ sci-visualization/gnuplot"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ rm Configfile.local >& /dev/null || true
+ touch Configfile.local
+
+ echo "PREFIX = ${EPREFIX}/usr" >> Configfile.local
+
+ echo "LANGUAGES += c" >> Configfile.local
+ for i in $(echo ${CFLAGS}); do
+ echo "COMPILEOPTS += ${i}" >> Configfile.local
+ done
+ echo "COMPILEOPTS += -DNDEBUG" >> Configfile.local
+
+ pconfigure
+}
+
+src_install() {
+ make D=$D install
+}