summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/faifa/faifa-0.1.ebuild')
-rw-r--r--net-misc/faifa/faifa-0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/faifa/faifa-0.1.ebuild b/net-misc/faifa/faifa-0.1.ebuild
new file mode 100644
index 0000000..1875b4d
--- /dev/null
+++ b/net-misc/faifa/faifa-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Power Line Communication device manager"
+HOMEPAGE="https://github.com/ffainelli/faifa"
+SRC_URI="https://github.com/ffainelli/faifa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"_symlink.patch
+ #do no strip
+ sed -i -e "s:installman strip:installman:" Makefile.in
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}