summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/livestreamer/livestreamer-1.12.1.ebuild')
-rw-r--r--net-misc/livestreamer/livestreamer-1.12.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/livestreamer/livestreamer-1.12.1.ebuild b/net-misc/livestreamer/livestreamer-1.12.1.ebuild
new file mode 100644
index 0000000..f252648
--- /dev/null
+++ b/net-misc/livestreamer/livestreamer-1.12.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/livestreamer/livestreamer-1.10.2.ebuild,v 1.1 2014/11/15 12:40:38 hwoarang Exp $
+
+EAPI="5"
+
+DESCRIPTION="CLI tool that pipes video streams from services like twitch.tv into a video player"
+HOMEPAGE="https://github.com/chrippa/livestreamer"
+SRC_URI="https://github.com/chrippa/livestreamer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+KEYWORDS="~amd64 ~mips ~x86"
+LICENSE="Apache-2.0 BSD-2 MIT-with-advertising"
+SLOT="0"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ >media-video/rtmpdump-2.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"