summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/libpam-google-authenticator/Manifest2
-rw-r--r--sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-auth/libpam-google-authenticator/Manifest b/sys-auth/libpam-google-authenticator/Manifest
new file mode 100644
index 0000000..43fd28a
--- /dev/null
+++ b/sys-auth/libpam-google-authenticator/Manifest
@@ -0,0 +1,2 @@
+DIST libpam-google-authenticator-1.0-source.tar.bz2 32708 RMD160 ce26a2f805f36a82a7ab3d930116a73fb444e037 SHA1 017b7d89989f1624e360abe02d6b27a6298d285d SHA256 80426045d13ce7a2bf56c692ccfb1751cef3c7484752ad40738facf729264d4b
+EBUILD libpam-google-authenticator-1.0.ebuild 659 RMD160 c3a1098716091eced4b934ea17e3bbd2ec35fba0 SHA1 bb36c10797b390e155cc0ca24d2ffd884f5b5f81 SHA256 0b04f1a977a0902ee280fa472c2e0af70a4e17c83effb1c09519123eaa22348d
diff --git a/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
new file mode 100644
index 0000000..fb9b80f
--- /dev/null
+++ b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+inherit eutils pam toolchain-funcs
+
+DESCRIPTION="Example PAM module demonstrating two-factor authentication"
+HOMEPAGE="http://code.google.com/p/google-authenticator/"
+SRC_URI="http://google-authenticator.googlecode.com/files/libpam-google-authenticator-1.0-source.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}
+ media-gfx/qrencode"
+
+src_install() {
+ dopammod pam_google_authenticator.so
+
+ dobin google-authenticator
+
+ dodoc README
+ dohtml totp.html
+}