summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Labedan <plabedan@gmail.com>2017-11-22 12:52:15 +0100
committerPaul Labedan <plabedan@gmail.com>2017-11-22 21:48:57 +0100
commit1611aea17a863f64f390a2cce392eef8ffc2e75e (patch)
tree40899cfda6003c47b578b0f32066fab07e7676c5 /dev-db/pg_activity/pg_activity-1.4.0.ebuild
parentadd pg_activity 1.3.0 (diff)
downloadplab-1611aea17a863f64f390a2cce392eef8ffc2e75e.tar.gz
plab-1611aea17a863f64f390a2cce392eef8ffc2e75e.tar.bz2
plab-1611aea17a863f64f390a2cce392eef8ffc2e75e.zip
upgrade pg_activity to 1.4.0
Diffstat (limited to 'dev-db/pg_activity/pg_activity-1.4.0.ebuild')
-rw-r--r--dev-db/pg_activity/pg_activity-1.4.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-db/pg_activity/pg_activity-1.4.0.ebuild b/dev-db/pg_activity/pg_activity-1.4.0.ebuild
new file mode 100644
index 0000000..ab84a42
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-1.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/julmon/pg_activity/"
+SRC_URI="https://github.com/julmon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+DEPEND=""
+RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}