summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepass-bin/keepass-bin-2.21.ebuild')
-rw-r--r--app-admin/keepass-bin/keepass-bin-2.21.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/app-admin/keepass-bin/keepass-bin-2.21.ebuild b/app-admin/keepass-bin/keepass-bin-2.21.ebuild
deleted file mode 100644
index 671f623..0000000
--- a/app-admin/keepass-bin/keepass-bin-2.21.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils gnome2-utils
-
-MY_PN="KeePass"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="KeePass is a free, open source, light-weight and easy-to-use password manager."
-HOMEPAGE="http://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN/-bin/}/${MY_P}.zip"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-LICENSE="GPL-2"
-
-RDEPEND=">=dev-lang/mono-2.6"
-
-#S="${WORKDIR}"
-
-src_unpack() {
- mkdir "${S}"
- cd "${S}"
- unpack ${A}
-}
-
-src_install() {
- INSTDIR="/opt/${MY_PN}"
-
- dodir ${INSTDIR}
- insinto ${INSTDIR}
- doins *
-
- #insinto /usr/share/pixmaps
- #doins "${FILESDIR}"/${MY_PN}.png
-
- echo "#!/bin/sh" > "${S}/keepass"
- echo "exec mono \"${INSTDIR}/${MY_PN}.exe\" \"\$@\"" >> "${S}/keepass"
- dobin keepass
-
- make_desktop_entry ${PN} ${MY_PN} ${MY_PN} Utility
-}
-
-pkg_preinst() {
- gnome2_icon_savelist;
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update;
- einfo "Documentation has been installed to \"${INSTDIR}/${MY_PN}.chm\"."
- einfo "use app-text/xchm or any other chm viewer to read it."
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update;
-}