summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2022-10-05 20:44:20 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2022-10-05 20:44:20 -0500
commit0cc055db10fdf862db1e51900e0109a4b1c0a1f0 (patch)
treed34142a265f271f060cdf45064853c7b201a1ddc
parentapp-emulation/*: Sync with stefantalpalaru-overlay (diff)
downloadsattvik-0cc055db10fdf862db1e51900e0109a4b1c0a1f0.tar.gz
sattvik-0cc055db10fdf862db1e51900e0109a4b1c0a1f0.tar.bz2
sattvik-0cc055db10fdf862db1e51900e0109a4b1c0a1f0.zip
dev-ruby/*: Add asciidoctor-pdf from guru overlay
Signed-off-by: Daniel Solano Gómez <gentoo@sattvik.com>
-rw-r--r--dev-ruby/asciidoctor-pdf/Manifest3
-rw-r--r--dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.0.ebuild48
-rw-r--r--dev-ruby/asciidoctor-pdf/metadata.xml19
-rw-r--r--dev-ruby/prawn-icon/Manifest3
-rw-r--r--dev-ruby/prawn-icon/metadata.xml11
-rw-r--r--dev-ruby/prawn-icon/prawn-icon-3.1.0.ebuild24
-rw-r--r--dev-ruby/prawn-svg/Manifest3
-rw-r--r--dev-ruby/prawn-svg/metadata.xml11
-rw-r--r--dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild28
-rw-r--r--dev-ruby/prawn-templates/Manifest3
-rw-r--r--dev-ruby/prawn-templates/metadata.xml11
-rw-r--r--dev-ruby/prawn-templates/prawn-templates-0.1.2-r1.ebuild27
12 files changed, 191 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-pdf/Manifest b/dev-ruby/asciidoctor-pdf/Manifest
new file mode 100644
index 0000000..7464747
--- /dev/null
+++ b/dev-ruby/asciidoctor-pdf/Manifest
@@ -0,0 +1,3 @@
+DIST asciidoctor-pdf-2.3.0.tar.gz 6481184 BLAKE2B d304aa7f2833897c525696dad6bf9fdfae3dc135351750cc27707f27e4a3c82c4aebff8ef2fb7241b6d903ff0901bb224c9321cdbbef4c16936fb9484ac56290 SHA512 da55e2ea20d7e076fa9068d9582d1d2a9ed169410f2b1fc3fe5b3b47b7194f9f9552d793c0d9d0c80ff8eb732695c1c2abbee7a325ab507d62761e05c0ea1a14
+EBUILD asciidoctor-pdf-2.3.0.ebuild 1135 BLAKE2B 273f22ae9e6009ec9f8081c14ba50c129bff723f9d1c7e306f2e29185d48e19e07fbf807cfbae544c381725ec300c9f686d4e42703d19612f39496d0fc690996 SHA512 5ad4ace81f8c64c8dc27966d3a2cab83c12fd146f290a1cfb0d6d070ff7c4b4d4958896af51d9c1b72f332e880d3f48e22a1f0286546aad6b134851e011da9ec
+MISC metadata.xml 796 BLAKE2B b27ad40b0ebd92b01ec7fe1c2eeb69d68ce7c9549d4331b10c62d939052f07e395ae16ac4d40fa7237ef6eacba4026ce2636490716ff4aa20ed6adbb831237b1 SHA512 5bc29feb57a3c1e7560a6a7e5045bbc30da1344281ae031a5855c918634ff80f7db7d82b21ee297f315b76a14470eea2b8da6c66e0f36027d2a8168896b4b3fc
diff --git a/dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.0.ebuild b/dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.0.ebuild
new file mode 100644
index 0000000..027a42e
--- /dev/null
+++ b/dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="CUCUMBER_PUBLISH_QUIET=true test features"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="asciidoctor-pdf.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A native PDF converter for AsciiDoc based on Asciidoctor and Prawn"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-pdf"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# rake have no task test, skipping for now
+RESTRICT=test
+
+ruby_add_rdepend "
+ >=dev-ruby/asciidoctor-2.0
+ >=dev-ruby/concurrent-ruby-1.1
+ >=dev-ruby/matrix-0.4
+ >=dev-ruby/prawn-2.4.0
+ >=dev-ruby/prawn-icon-3.0.0
+ >=dev-ruby/prawn-svg-0.32.0
+ >=dev-ruby/prawn-table-0.2.0
+ >=dev-ruby/prawn-templates-0.1.0
+ >=dev-ruby/treetop-1.6.0
+ "
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}
diff --git a/dev-ruby/asciidoctor-pdf/metadata.xml b/dev-ruby/asciidoctor-pdf/metadata.xml
new file mode 100644
index 0000000..d5cd3a9
--- /dev/null
+++ b/dev-ruby/asciidoctor-pdf/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">asciidoctor/asciidoctor-pdf</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Asciidoctor PDF is a native PDF converter for AsciiDoc that serves the
+ pdf backend. It bypasses the step of generating an intermediary format
+ such as DocBook, Apache FO, or LaTeX in order to produce PDF.
+ Instead, you use Asciidoctor PDF to convert your documents directly
+ from AsciiDoc to PDF with Asciidoctor. The aim of this library is to
+ take the pain out of creating PDF documents from AsciiDoc.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/prawn-icon/Manifest b/dev-ruby/prawn-icon/Manifest
new file mode 100644
index 0000000..c4c4885
--- /dev/null
+++ b/dev-ruby/prawn-icon/Manifest
@@ -0,0 +1,3 @@
+DIST prawn-icon-3.1.0.gem 1351680 BLAKE2B e3aae452f16c460e660f0c312b3ddf66dac911dfba55a8a330dd6262b13f6721ee3dcd8132a86af3376810b3c0f15dca0bb6d0b1610975f7ec3e024f968c92dd SHA512 138461a9e4ace3a110877e1492c75c8183f638d71daaa1bb89e2f5b750725527a1ae5c84af7b392a6ce77fd046e6d3f33a57499fe0e2f8d328c93f0acdc8fe68
+EBUILD prawn-icon-3.1.0.ebuild 594 BLAKE2B 2c1870fb0b01752ee68cbe28a794e3631a330c8de60fd5b8877692d6394748d3e940406337c62d547eb6e483a8a14f2b77dfd5fcc23665fa98c04f2ffd303a15 SHA512 1355140dcc6ec268639366632254e34b00f37e494a8993ce43818f38bc4116992168491161c2a6f2cd758187ce24131993936485f110c9c4fd404ab755e7929a
+MISC metadata.xml 329 BLAKE2B d18e7f62841b9bc77ed5f3538bb4ac3920dbb1b636f0210cdee3da460e9ce17ca6848b3b6f05ded651eb5ec094e7364dab6704ae209244dfe4b853d5e8cdac7b SHA512 d7a06eb55ec85127b14b03dd5d0286a354ee5438b1b69acc21c68e36d644a6b691ba521bed689c6b48f6b39e7a682f39168c162e3166307d227ed87f80599f7a
diff --git a/dev-ruby/prawn-icon/metadata.xml b/dev-ruby/prawn-icon/metadata.xml
new file mode 100644
index 0000000..567a2bd
--- /dev/null
+++ b/dev-ruby/prawn-icon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jessedoyle/prawn-icon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/prawn-icon/prawn-icon-3.1.0.ebuild b/dev-ruby/prawn-icon/prawn-icon-3.1.0.ebuild
new file mode 100644
index 0000000..887f987
--- /dev/null
+++ b/dev-ruby/prawn-icon/prawn-icon-3.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for icons in Prawn"
+HOMEPAGE="https://github.com/jessedoyle/prawn-icon"
+LICENSE="|| ( GPL-2+ GPL-3 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# Tests blocks many keywords and new dependencies, skipping for now
+RESTRICT=test
+
+ruby_add_rdepend ">=dev-ruby/prawn-1.1.0"
diff --git a/dev-ruby/prawn-svg/Manifest b/dev-ruby/prawn-svg/Manifest
new file mode 100644
index 0000000..d82755f
--- /dev/null
+++ b/dev-ruby/prawn-svg/Manifest
@@ -0,0 +1,3 @@
+DIST prawn-svg-0.32.0.gem 276992 BLAKE2B 1522dad613079063de1b572ac6c234185637edc8ab129ea438342101f8df059f7f71d3d9647dbd3a43967c4419f0af50df78280a9b630bb78e6ecc6e5815ed6c SHA512 e4bb429106f6d18ad60c64c749ae236d64ebc9a621a20409fcd7c1ec64299d4fcf4d27248af030eb0e65ce74bfb0245b56aad49ed55c693f1a8eb20fc1b5bc49
+EBUILD prawn-svg-0.32.0.ebuild 605 BLAKE2B 2b767311fb4abd2364694737e0cde1a8ca74a1063c8e138d7c28fb718407fbe422ba27b18fd2d9146b73182c8b9c477d31f4f984d03a509be0ffd99431a18b5b SHA512 f57e65c185ad60a40173a5f002326d7a4ee7e7d85389b00df1523c5187c99dacb663d4a778743cc525703529865525c6406ec27047265ac009f5f442d3b3f1a2
+MISC metadata.xml 324 BLAKE2B 0adf4ffb5be0153822f221d768384c54f334a48a7f87297f9a7bce540f0b0d378e0352b99613c88d4b09e6e95003ded731fae5a98ce48358b8e3e01640ffa3bd SHA512 0a5ae282bf3008b76029202411e2644d90b5e1d3abf2fb6199e87aec4e7bb67acfae45cc8a6ee1a56c3e27588a4b010885ffded1ed92856c91af025cd3e71ef3
diff --git a/dev-ruby/prawn-svg/metadata.xml b/dev-ruby/prawn-svg/metadata.xml
new file mode 100644
index 0000000..2a483eb
--- /dev/null
+++ b/dev-ruby/prawn-svg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mogest/prawn-svg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild b/dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild
new file mode 100644
index 0000000..38b4e44
--- /dev/null
+++ b/dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for SVG in Prawn"
+HOMEPAGE="https://github.com/mogest/prawn-svg"
+LICENSE="|| ( MIT Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/css_parser-1.6.0
+ >=dev-ruby/prawn-0.11.1
+ >=dev-ruby/rexml-3.2.0
+ "
+
+ruby_add_bdepend "test? ( dev-ruby/mocha
+ >=dev-ruby/pdf-inspector-1.1.0
+ >=dev-ruby/pdf-reader-1.2
+ )"
diff --git a/dev-ruby/prawn-templates/Manifest b/dev-ruby/prawn-templates/Manifest
new file mode 100644
index 0000000..a7f2600
--- /dev/null
+++ b/dev-ruby/prawn-templates/Manifest
@@ -0,0 +1,3 @@
+DIST prawn-templates-0.1.2.gem 28160 BLAKE2B 128f0f735e91163294b8c027a029f4dc2525cdc01d949ad769bc5421dd72163fbbbc6a83175e4502da67f0bddacaf4e1e55a4d4ed871844fac0c2a4eb4255b51 SHA512 0c64566a9cfdadb075fa31fb7630419f2adc624148f8ff8921c8afea1f2a2ac363439bdef450ad2a84a08cdfbfc9e07a49380e7e6a3e43c16e7413703c029cf0
+EBUILD prawn-templates-0.1.2-r1.ebuild 618 BLAKE2B a6d3f412e37c3af4841e1c0b6eddb4a17b9d43d9ed3b3af1879610dfadba7441ab182f03d337285fc4c1c770f477191a657e30496081571f02b2d8d2136e1258 SHA512 17d3a9d0ac40bb5b571d2174a2147554368313cc0aacf8d526410587c86782adbdf33f845980406e1c0547553fcd8d5ec0df499001983705e9f5ee538581accb
+MISC metadata.xml 332 BLAKE2B 6de2e91aebc7465cb8908cb1f312f90b3361a10862f82295dcfa918712024f8780a55b869ad1322a8a85c2b416b844e208ca20d6a5de3808c6e92b682e39a46c SHA512 fa5817ab16e87ad663bdb453e7c4c7721af3bd87def1341ed651edc41643f38f4f190d4f3e2a8e123aaacd7cd685edec3f5cfbae814abbe63dec25766cf5e09b
diff --git a/dev-ruby/prawn-templates/metadata.xml b/dev-ruby/prawn-templates/metadata.xml
new file mode 100644
index 0000000..2fea477
--- /dev/null
+++ b/dev-ruby/prawn-templates/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">prawnpdf/prawn-templates</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/prawn-templates/prawn-templates-0.1.2-r1.ebuild b/dev-ruby/prawn-templates/prawn-templates-0.1.2-r1.ebuild
new file mode 100644
index 0000000..2129f89
--- /dev/null
+++ b/dev-ruby/prawn-templates/prawn-templates-0.1.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for templates in Prawn"
+HOMEPAGE="https://github.com/prawnpdf/prawn-templates"
+LICENSE="|| ( GPL-2+ GPL-3 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/pdf-reader-1.2
+ >=dev-ruby/prawn-0.11.1
+ "
+
+ruby_add_bdepend "test? ( dev-ruby/mocha
+ >=dev-ruby/pdf-inspector-1.1.0
+ >=dev-ruby/prawn-1.3.0
+ )"