summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2017-06-06 08:35:09 +0200
committerSven Eden <sven.eden@gmx.de>2017-06-06 08:35:09 +0200
commit6b46fb967a58749c7d31d40deb0fcf3847084d50 (patch)
tree64e7db580c469534f6e3be953d2036afb77b6e3e
parentsys-auth/elogind-229.4 : Version bump with moved includes. (diff)
downloadseden-6b46fb967a58749c7d31d40deb0fcf3847084d50.tar.gz
seden-6b46fb967a58749c7d31d40deb0fcf3847084d50.tar.bz2
seden-6b46fb967a58749c7d31d40deb0fcf3847084d50.zip
sys-apps/accountsservice-0.6.43-r4 : Change elogind support patch as requested by upstream.
-rw-r--r--profiles/package.mask/elogind2
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.43-r4.ebuild (renamed from sys-apps/accountsservice/accountsservice-0.6.43-r3.ebuild)0
-rw-r--r--sys-apps/accountsservice/files/accountsservice-enable-elogind.patch109
3 files changed, 61 insertions, 50 deletions
diff --git a/profiles/package.mask/elogind b/profiles/package.mask/elogind
index ff6a1f1..f777a8a 100644
--- a/profiles/package.mask/elogind
+++ b/profiles/package.mask/elogind
@@ -1,7 +1,7 @@
# Sven Eden <yamakuzure@gmx.net> (10 Nov 2016)
# Testing ebuilds for elogind integration
=gnome-base/gvfs-1.30.4-r1
-=sys-apps/accountsservice-0.6.43-r3
+=sys-apps/accountsservice-0.6.43-r4
=sys-auth/elogind-229.4
=sys-auth/elogind-229.9999
=sys-process/procps-3.3.12-r2
diff --git a/sys-apps/accountsservice/accountsservice-0.6.43-r3.ebuild b/sys-apps/accountsservice/accountsservice-0.6.43-r4.ebuild
index f3aeb8d..f3aeb8d 100644
--- a/sys-apps/accountsservice/accountsservice-0.6.43-r3.ebuild
+++ b/sys-apps/accountsservice/accountsservice-0.6.43-r4.ebuild
diff --git a/sys-apps/accountsservice/files/accountsservice-enable-elogind.patch b/sys-apps/accountsservice/files/accountsservice-enable-elogind.patch
index 6aa8f90..f664651 100644
--- a/sys-apps/accountsservice/files/accountsservice-enable-elogind.patch
+++ b/sys-apps/accountsservice/files/accountsservice-enable-elogind.patch
@@ -1,18 +1,6 @@
---- a/config.h.in 2017-06-01 13:38:32.406980179 +0200
-+++ b/config.h.in 2017-06-01 13:38:46.546980454 +0200
-@@ -144,6 +144,9 @@
- /* Version number of package */
- #undef VERSION
-
-+/* Define to enable elogind support */
-+#undef WITH_ELOGIND
-+
- /* Define to enable systemd support */
- #undef WITH_SYSTEMD
-
---- a/configure.ac 2017-06-01 13:06:23.669942591 +0200
-+++ b/configure.ac 2017-06-01 13:20:51.570959505 +0200
-@@ -264,6 +264,39 @@
+--- a/configure.ac 2017-06-06 08:06:51.298368338 +0200
++++ b/configure.ac 2017-06-06 08:24:06.233399409 +0200
+@@ -264,22 +264,55 @@
dnl ---------------------------------------------------------------------------
AC_PATH_PROG([XSLTPROC], [xsltproc])
@@ -24,68 +12,91 @@
+
+AC_ARG_ENABLE([elogind],
+ AS_HELP_STRING([--enable-elogind], [Use elogind]),
-+ [enable_elogind=$enableval])
++ [enable_elogind=$enableval],
++ [enable_elogind=no])
+
+AC_MSG_RESULT($enable_elogind)
+
+if test "x$enable_elogind" != "xno"; then
-+ PKG_CHECK_MODULES(ELOGIND, [libelogind >= 219],
-+ [have_elogind=yes],
-+ [have_elogind=no])
++ PKG_CHECK_MODULES(ELOGIND, [libelogind >= 229.4],
++ [have_elogind=yes])
+fi
+
+if test "x$enable_elogind" != "xno"; then
+ if test "x$have_elogind" != "xyes"; then
-+ AC_MSG_ERROR([elogind support explicitly required, but libelogind not found])
++ AC_MSG_ERROR([elogind support requested, but libelogind not found])
+ else
+ AC_SUBST(ELOGIND_CFLAGS)
+ AC_SUBST(ELOGIND_LIBS)
+
+ LIBACCOUNTSSERVICE_LIBS="$LIBACCOUNTSSERVICE_LIBS $ELOGIND_LIBS"
+ LIBACCOUNTSSERVICE_CFLAGS="$LIBACCOUNTSSERVICE_CFLAGS $ELOGIND_CFLAGS"
-+
-+ AC_DEFINE(WITH_ELOGIND, 1, [Define to enable elogind support])
+ fi
+fi
+
+
# systemd
++have_systemd=no
++
++AC_MSG_CHECKING([whether to use systemd])
++
AC_ARG_ENABLE([systemd],
-@@ -272,8 +305,15 @@
+ AS_HELP_STRING([--enable-systemd], [Use systemd]),
+ [enable_systemd=$enableval],
[enable_systemd=auto])
++AC_MSG_RESULT($enable_systemd)
++
if test x$enable_systemd != xno; then
- PKG_CHECK_MODULES(SYSTEMD, [libsystemd >= 186],
- [have_systemd=yes], [have_systemd=no])
-+ if test "x$enable_elogind" != "xno"; then
-+ AC_MSG_NOTICE([Systemd support requested, but elogind found])
-+ have_systemd=no
-+ enable_systemd=no
-+ else
+-else
+- have_systemd=no
+ PKG_CHECK_MODULES(SYSTEMD, [libsystemd >= 186],
-+ [have_systemd=yes],
-+ [have_systemd=no])
-+ fi
- else
- have_systemd=no
++ [have_systemd=yes])
+ fi
+
+-AC_MSG_CHECKING([whether to use systemd])
+-
+ if test x$enable_systemd = xauto ; then
+ if test x$have_systemd = xno ; then
+ enable_systemd=no
+@@ -288,21 +321,29 @@
+ fi
fi
---- a/src/libaccountsservice/act-user-manager.c 2017-06-01 13:06:17.869942478 +0200
-+++ b/src/libaccountsservice/act-user-manager.c 2017-06-01 13:19:09.037957507 +0200
-@@ -43,8 +43,16 @@
- #ifdef WITH_SYSTEMD
- #include <systemd/sd-login.h>
-+#endif
-+
-+#ifdef WITH_ELOGIND
-+#include <elogind/sd-login.h>
-+/* Re-Use WITH_SYSTEMD as elogind substitutes systemd-login */
-+#define WITH_SYSTEMD 1
-+#endif
+-AC_MSG_RESULT($enable_systemd)
- /* check if logind is running */
-+#ifdef WITH_SYSTEMD
- #define LOGIND_RUNNING() (access("/run/systemd/seats/", F_OK) >= 0)
- #endif
+ if test x$enable_systemd = xyes; then
+ if test x$have_systemd = xno; then
+- AC_MSG_ERROR([Systemd support explicitly required, but systemd not found])
++ AC_MSG_ERROR([Systemd support explicitly requested, but libsystemd not found])
+ fi
++
++ dnl Requesting to use the elogind session tracker makes no sense where
++ dnl systemd-login is (or might be) running.
++ if test x$enable_elogind = xyes; then
++ AC_MSG_WARN([elogind support requested, but systemd was found.])
++ AC_MSG_ERROR([Disable either elogind or systemd support.])
++ fi
++
++ AC_SUBST(SYSTEMD_CFLAGS)
++ AC_SUBST(SYSTEMD_LIBS)
++
++ LIBACCOUNTSSERVICE_LIBS="$LIBACCOUNTSSERVICE_LIBS $SYSTEMD_LIBS"
++ LIBACCOUNTSSERVICE_CFLAGS="$LIBACCOUNTSSERVICE_CFLAGS $SYSTEMD_CFLAGS"
++
+ AC_DEFINE(HAVE_SYSTEMD, 1, [Define if systemd is used])
+ fi
+-AC_SUBST(SYSTEMD_CFLAGS)
+-AC_SUBST(SYSTEMD_LIBS)
+-
+-LIBACCOUNTSSERVICE_LIBS="$LIBACCOUNTSSERVICE_LIBS $SYSTEMD_LIBS"
+-LIBACCOUNTSSERVICE_CFLAGS="$LIBACCOUNTSSERVICE_CFLAGS $SYSTEMD_CFLAGS"
+
+-if test "x$have_systemd" != "xno" ; then
++if test "x$have_systemdx$have_elogind" != "xnoxno" ; then
+ AC_DEFINE(WITH_SYSTEMD, 1, [Define to enable systemd support])
+ fi