summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2016-12-06 09:27:15 +0100
committerSven Eden <sven.eden@gmx.de>2016-12-06 09:27:15 +0100
commit904b7d4b371010ab5462f9073296690152d1581b (patch)
tree2c33e11a1ed6f8155d0929319f5789ffc5b31f48
parentsys-auth/elogind-219.12-r10 : Update init script to create a /run/systemd dir... (diff)
downloadseden-904b7d4b371010ab5462f9073296690152d1581b.tar.gz
seden-904b7d4b371010ab5462f9073296690152d1581b.tar.bz2
seden-904b7d4b371010ab5462f9073296690152d1581b.zip
sys-apps/accountsservice-0.6.43-r1 : Version bump with elogind support
-rw-r--r--profiles/package.mask/elogind1
-rw-r--r--sys-apps/accountsservice/Manifest1
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.43-r1.ebuild70
3 files changed, 72 insertions, 0 deletions
diff --git a/profiles/package.mask/elogind b/profiles/package.mask/elogind
index 7359365..2eaf67c 100644
--- a/profiles/package.mask/elogind
+++ b/profiles/package.mask/elogind
@@ -5,6 +5,7 @@
=kde-plasma/powerdevil-5.8.3-r4
=kde-plasma/powerdevil-5.8.4-r1
=sys-apps/accountsservice-0.6.42-r4
+=sys-apps/accountsservice-0.6.43-r1
=sys-apps/dbus-1.10.12-r1
=sys-apps/dbus-1.10.14-r1
=sys-auth/elogind-219.12-r9
diff --git a/sys-apps/accountsservice/Manifest b/sys-apps/accountsservice/Manifest
index b0cb76c..d328636 100644
--- a/sys-apps/accountsservice/Manifest
+++ b/sys-apps/accountsservice/Manifest
@@ -1 +1,2 @@
DIST accountsservice-0.6.42.tar.xz 380500 SHA256 e56494c2f18627900b57234e5628923cc16a37bf8fd16b06c46118d6ae9c007e SHA512 b31d77b88793a8264d32963a98ad446537292a134a3f80fabb4e2ce30f796e5f3066d02a27515c993133fa493b511a6abba6ff1a7827b5a54ea6a4f62a7b6fc9 WHIRLPOOL 2da1b5037f2306d93471db8ae792145abded9f33e5014f5ad748bb0d988757a4c5e53e5e64ef69752b6e80041af09a87512b95b1b955cfc75b379d7cec40d496
+DIST accountsservice-0.6.43.tar.xz 381008 SHA256 ed3ba94aa38ceb822a0e1a1ac71bf1a8123babf90be049397b3a00900e48d6cc SHA512 0673430b7e5fd726397a9358d60d5c34542afaa786b795d3c8b544dc2bdab151c74f9a3daa4bcd94dc7669400a78cd4cddc453cad78ee8e431bf7c1f417138e2 WHIRLPOOL e704d9dcb5b7c0c6ee7c1ab5ed310ab2428e94d061663367f213c5903f68768680492d651524ef1e7594417335de529463d63b8d8a4d1cc8b6445358f1b97a33
diff --git a/sys-apps/accountsservice/accountsservice-0.6.43-r1.ebuild b/sys-apps/accountsservice/accountsservice-0.6.43-r1.ebuild
new file mode 100644
index 0000000..f3aeb8d
--- /dev/null
+++ b/sys-apps/accountsservice/accountsservice-0.6.43-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools gnome2 systemd
+
+DESCRIPTION="D-Bus interfaces for querying and manipulating user account information"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/AccountsService/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc elogind +introspection selinux systemd"
+
+REQUIRED_USE="elogind? ( !systemd )
+ systemd? ( !elogind )
+"
+
+CDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ sys-auth/polkit
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ elogind? ( >=sys-auth/elogind-219:0= )
+ systemd? ( >=sys-apps/systemd-186:0= )
+ !systemd? ( !elogind? ( sys-auth/consolekit ) )
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto )
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-accountsd )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.35-gentoo-system-users.patch"
+)
+
+src_prepare() {
+ if use elogind; then
+ epatch "${FILESDIR}/${PN}-enable-elogind.patch" || die
+ eautoreconf
+ fi
+
+ default
+}
+
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-more-warnings \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-admin-group="wheel" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ $(use_enable doc docbook-docs) \
+ $(use_enable elogind) \
+ $(use_enable introspection) \
+ $(use_enable systemd)
+}