summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2018-12-22 10:18:45 +0100
committerSven Eden <sven.eden@gmx.de>2018-12-22 10:19:06 +0100
commit4275b3b16f6aa6197db8d4057d957883587d2a0e (patch)
tree63dc8243ad2b728c068b8be9831cec3a3e8b484f /app-text/getRandomName/getRandomName-0.9.1-r1.ebuild
parentmedia-gfx/makeSimplexTexture: fix asan/lsan/tsan use flag selection (diff)
downloadseden-4275b3b16f6aa6197db8d4057d957883587d2a0e.tar.gz
seden-4275b3b16f6aa6197db8d4057d957883587d2a0e.tar.bz2
seden-4275b3b16f6aa6197db8d4057d957883587d2a0e.zip
app-text/getRandomName: Depend on the next pwxLib version to fix crash
This is just an emergency option, as the next pwxLib release will be there in the next couple of days. Signed-Off-By: Sven Eden <sven.eden@gmx.de>
Diffstat (limited to 'app-text/getRandomName/getRandomName-0.9.1-r1.ebuild')
-rw-r--r--app-text/getRandomName/getRandomName-0.9.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-text/getRandomName/getRandomName-0.9.1-r1.ebuild b/app-text/getRandomName/getRandomName-0.9.1-r1.ebuild
new file mode 100644
index 0000000..0918eb7
--- /dev/null
+++ b/app-text/getRandomName/getRandomName-0.9.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Create random names using linguistic rules"
+HOMEPAGE="https://prydeworx.com/getRandomNames"
+SRC_URI="https://github.com/Yamakuzure/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="asan debug lsan tsan"
+
+REQUIRED_USE="
+ ?? ( asan lsan tsan )
+ asan? ( debug )
+ lsan? ( debug )
+ tsan? ( debug )
+"
+
+COMMON_DEPEND="
+ >dev-cpp/pwxlib-0.8.9
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS=()
+
+src_compile() {
+ PREFIX="${EPREFIX}"usr CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CXX="$(tc-getCXX)" LD="$(tc-getCC)" \
+ DEBUG="$(usex debug YES NO)" \
+ SANITIZE_ADDRESS="$(usex asan YES NO)" \
+ SANITIZE_LEAK="$(usex lsan YES NO)" \
+ SANITIZE_THREAD="$(usex tsan YES NO)" \
+ emake || die "emake failed"
+}
+
+src_install() {
+ PREFIX="${EPREFIX}"usr DESTDIR="${D}" \
+ DOCDIR="${EPREFIX}"usr/share/doc/${PF} \
+ emake install || die "install failed"
+}