summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeorion/Manifest3
-rw-r--r--games-strategy/freeorion/freeorion-9999-r5.ebuild106
-rw-r--r--games-strategy/freeorion/metadata.xml8
-rw-r--r--games-strategy/glfrontier/Manifest4
-rw-r--r--games-strategy/glfrontier/glfrontier-20060623-r2.ebuild48
-rw-r--r--games-strategy/seven-kingdoms/Manifest5
-rw-r--r--games-strategy/seven-kingdoms/files/7kaa.pngbin0 -> 2679 bytes
-rw-r--r--games-strategy/seven-kingdoms/seven-kingdoms-2.14.3-r1.ebuild95
8 files changed, 269 insertions, 0 deletions
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
new file mode 100644
index 0000000..288b330
--- /dev/null
+++ b/games-strategy/freeorion/Manifest
@@ -0,0 +1,3 @@
+EBUILD freeorion-9999-r5.ebuild 2829 RMD160 ddbb4bb5ac6b03e36dbcbe8fba9f489d3286cbd8 SHA1 dbdd4eb8e819b9262ae145155e481a3794645a3b SHA256 4a550b9a6a11c38f58e26030c45ae9d6093e65b8d94b13feec321548933fe566
+MISC freeorion-9999-r5.ebuild~ 2828 RMD160 f03d3a3e751a11d982f413db6275e05206dcda81 SHA1 460f18911821a0bd66ff2a489833815f97db85d4 SHA256 0235b077a9290b4f357836e775acbbc9b0b11062de836e557a69081382a1670d
+MISC metadata.xml 289 RMD160 1ddd83f6157c2a67fe8d507cdfaa68f4ca00c634 SHA1 9c3f17b83bfd9097e844e7d5e6102a6179ec6350 SHA256 0a23813a0270aa7139c3c527e15b1b367a1509f2a98903aec2fe2d2496bacf99
diff --git a/games-strategy/freeorion/freeorion-9999-r5.ebuild b/games-strategy/freeorion/freeorion-9999-r5.ebuild
new file mode 100644
index 0000000..477574d
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-9999-r5.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit cmake-utils games subversion
+
+DESCRIPTION="FreeOrion is a free and open source clone of Master Of Orion"
+HOMEPAGE="http://www.freeorion.org"
+ESVN_REPO_URI="https://${PN}.svn.sourceforge.net/svnroot/${PN}/trunk"
+ESVN_PROJECT="${PN}"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cg debug threads xml"
+
+SLOT="0"
+
+RDEPEND="
+ dev-games/gigi[ogre,threads=]
+ || ( threads? ( >=dev-games/ogre-1.7.1[boost,cg=,boost-threads] )
+ !threads? ( >=dev-games/ogre-1.7.1[boost,cg=,-boost-threads] )
+ )
+ <dev-lang/python-3
+ || ( dev-libs/boost:1.44
+ dev-libs/boost:1.45
+ )
+ media-gfx/graphviz
+ media-libs/freealut
+ >=media-libs/libogg-1.1.3
+ >=media-libs/libsdl-1.2
+ >=media-libs/libvorbis-1.1.2
+ media-libs/openal
+ sci-physics/bullet
+ sys-devel/libtool
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+CMAKE_USE_DIR="${S}/FreeOrion"
+
+src_prepare() {
+ # Let's make the autorevision work.
+ subversion_wc_info
+ sed -i -e \
+ "s:svn_revision_number ???:svn_revision_number ${ESVN_WC_REVISION}:" \
+ FreeOrion/CMakeLists.txt || die "sed FreeOrion/CMakeLists.txt failed"
+}
+
+src_configure() {
+ # Due to the testing nature of gigi and freeorion,
+ # and all the ogre+boost stuff, flags should be filtered:
+ strip-flags
+
+ # Type-Pun pointers always break strict aliasing rules,
+ # and this thing is full of those
+ append-flags -fno-strict-aliasing
+
+ # using xml serialization seems to break on linker level with
+ # boost-1.45. For this the new xml USE flag will switch to
+ # binary archives if -xml is used:
+ use xml || sed -i -e \
+ "s:define FREEORION_BINARY_SERIALIZATION 0:define FREEORION_BINARY_SERIALIZATION 1:" \
+ FreeOrion/util/Serialize.h || die "sed FreeOrion/util/Serialize.h failed"
+
+ local mycmakeargs+=(
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_build debug DEBUG)
+ )
+
+ mycmakeargs+=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}/${PN}"
+ "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
+ "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
+ "-DCMAKE_DOC_DIR=/usr/share/doc/${PF}"
+ "-DCMAKE_MAN_DIR=/usr/share/man"
+ "-DCMAKE_DATA_DIR=${GAMES_DATADIR}"
+ "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ ## This is a rather wild thing, but I can't think of a quicker way right now:
+ # Add ogre_plugins config:
+
+ OGRECFG="${D}/${GAMES_PREFIX}/${PN}/ogre_plugins.cfg"
+ cat > ${OGRECFG} <<EOF
+# Plugin folder
+PluginFolder=/usr/lib64/OGRE
+# Plugins
+Plugin=RenderSystem_GL
+Plugin=Plugin_ParticleFX
+Plugin=Plugin_OctreeSceneManager
+EOF
+
+ ## Extra-Plugin with cg enabled:
+ use cg && echo "Plugin=Plugin_CgProgramManager" >> ${OGRECFG}
+
+ prepgamesdirs
+}
diff --git a/games-strategy/freeorion/metadata.xml b/games-strategy/freeorion/metadata.xml
new file mode 100644
index 0000000..a52a84c
--- /dev/null
+++ b/games-strategy/freeorion/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>playboys</herd>
+ <use>
+ <flag name="xml">Do all serialization using xml archives. Otherwise, binary archives will be used.</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-strategy/glfrontier/Manifest b/games-strategy/glfrontier/Manifest
new file mode 100644
index 0000000..7534a95
--- /dev/null
+++ b/games-strategy/glfrontier/Manifest
@@ -0,0 +1,4 @@
+DIST frontvm-audio-20060222.tar.bz2 4623648 RMD160 2261dbcdcff0882d1c1870af41b16bbe967c32ea SHA1 ba7bab4235f0ba09b7d4b801ae55ead04ae61da0 SHA256 e759e587047abd6f041aea4ef339e404b3ca5a6407acf65084a2af79a75ceb87
+DIST frontvm3-20060623.tar.bz2 426463 RMD160 0c6f0c25cb1fa048aa9be240e37386c9d2e1e3d5 SHA1 5f046cf2428444c0316afcb3628f6747c4493bd1 SHA256 9b6c04e8dad75bea11cce459515c7d5983276e23dba4a4764f1084d4810c0afb
+EBUILD glfrontier-20060623-r2.ebuild 1110 RMD160 a6dfbc404d1b788909ae81d977854182c92153a4 SHA1 000263db8f9452ac6fe1d808b90387bad1c72fbd SHA256 98b4006fc735d1cbf3e8044a21691b28d924c8680f9824d81729a31df63ac380
+MISC glfrontier-20060623-r2.ebuild~ 1107 RMD160 f54facbfbddc7a5a8ceec827939bb93c34c46bdd SHA1 b56eadd2f25aafb5e84d413986fdf95d8cc61897 SHA256 ff512b70bdf46c56970909cff15a82a9904d863cf63f6a6d77c212e4e36f164c
diff --git a/games-strategy/glfrontier/glfrontier-20060623-r2.ebuild b/games-strategy/glfrontier/glfrontier-20060623-r2.ebuild
new file mode 100644
index 0000000..92cf230
--- /dev/null
+++ b/games-strategy/glfrontier/glfrontier-20060623-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit games
+
+MY_PN=glfrontier
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Frontier: Elite 2 with OpenGL support"
+HOMEPAGE="http://tom.noflag.org.uk/glfrontier.html"
+
+SRC_URI="http://tom.noflag.org.uk/glfrontier/frontvm3-20060623.tar.bz2
+ http://tom.noflag.org.uk/misc/frontvm-audio-20060222.tar.bz2"
+
+
+LICENSE="GPL"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+SLOT="0"
+
+RDEPEND=">=media-libs/freeglut-2.6
+ media-libs/libsdl
+ media-libs/libogg"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_compile() {
+ cd ${S}/frontvm3-20060623
+ make -f Makefile-C || die "make install failed"
+}
+
+src_install() {
+ mv ${S}/frontvm3-20060623/frontier ${S}/frontvm3-20060623/${MY_PN}
+
+ insinto /opt/${MY_PN}
+ doins ${S}/frontvm3-20060623/${MY_PN}
+ doins ${S}/frontvm3-20060623/fe2.s.bin
+ doins -r ${S}/frontvm-audio-20060222/*
+
+ chgrp -R games ${D}/opt/${MY_PN}
+ chmod g+x ${D}/opt/${MY_PN}/${MY_PN}
+
+ make_desktop_entry /opt/${MY_PN}/${MY_PN} GLFrontier ${MY_PN} Game Path=/opt/${MY_PN}
+ prepgamesdirs
+}
diff --git a/games-strategy/seven-kingdoms/Manifest b/games-strategy/seven-kingdoms/Manifest
new file mode 100644
index 0000000..b90ab1a
--- /dev/null
+++ b/games-strategy/seven-kingdoms/Manifest
@@ -0,0 +1,5 @@
+AUX 7kaa.png 2679 RMD160 31f4cca441e3bfd4b19fd8a735d97891d081dda9 SHA1 236cf22e87577a12806de3f05a82511d80a61247 SHA256 09be1470c5643d8a492755267742397fbe8c80d64839bf686b6c62543353a959
+DIST 7kaa-data-2.13.tar.bz2 37107989 RMD160 a5e3ebbdd2c56269ffff6655fb2d14c4f900b516 SHA1 1283c5fa8545654fc45de39229afb6c7149a39d0 SHA256 b02052502b382dd78fdabaef0b378c0a3e85d91fe21fb067d47d1ebfe02d4294
+DIST 7kaa-source-2.14.3.tar.bz2 1181479 RMD160 84bcc723a63f684047962a4bb03a85e07a9ad946 SHA1 0926383fc32ad0b0af780edf575fb170a00c8d30 SHA256 9d3ba6e4d72495cf83eec922714f818c68974e9ad62e934608676d93a4b48aef
+EBUILD seven-kingdoms-2.14.3-r1.ebuild 2723 RMD160 257895345e6cd38ba70e4bba1ba0520bfca8c563 SHA1 3eca98fedd983ca7c0a0e7ad8e7b8b6dcd2e1a16 SHA256 6911b4850a295693fb641bd2fb91f2e02747e741480707636806db5d05fc8b47
+MISC seven-kingdoms-2.14.3-r1.ebuild~ 2722 RMD160 c27b0cedef8bf906179b555eb4332a6330c80d5d SHA1 12686be8226cb388c72117df284de33e244f78fe SHA256 24425171288da33277e5a8ffcbfce4bff4fb9c3c954dd2af099610898288cac2
diff --git a/games-strategy/seven-kingdoms/files/7kaa.png b/games-strategy/seven-kingdoms/files/7kaa.png
new file mode 100644
index 0000000..b23d95c
--- /dev/null
+++ b/games-strategy/seven-kingdoms/files/7kaa.png
Binary files differ
diff --git a/games-strategy/seven-kingdoms/seven-kingdoms-2.14.3-r1.ebuild b/games-strategy/seven-kingdoms/seven-kingdoms-2.14.3-r1.ebuild
new file mode 100644
index 0000000..0218cab
--- /dev/null
+++ b/games-strategy/seven-kingdoms/seven-kingdoms-2.14.3-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit autotools games
+
+MY_P="7kaa-${PV}"
+MY_DATA_DIR="7kaa"
+MY_DATA="${MY_DATA_DIR}-data-2.13.tar.bz2"
+DESCRIPTION="Seven Kingdoms: Ancient Adversaries game from Enlight, now released with the GPL license."
+HOMEPAGE="http://7kfans.com/"
+SRC_URI="mirror://sourceforge/skfans/7kaa-source-${PV}.tar.bz2
+ mirror://sourceforge/skfans/${MY_DATA}"
+RESTRICT="mirror"
+
+LICENSE="GPL"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+SLOT="0"
+
+DEPEND="
+ >sys-devel/gcc-4.0
+ sys-devel/autoconf
+ media-gfx/icoutils"
+RDEPEND="
+ =media-libs/libsdl-1.2*
+ =media-libs/sdl-net-1.2*
+ media-libs/openal"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( COPYING README )
+
+src_prepare() {
+ eautoreconf
+ # Note: what about game data?
+}
+
+src_configure() {
+ egamesconf
+ egamesconf \
+ --without-directx \
+ --without-wine \
+ --program-suffix=".bin" \
+ --datadir="${GAMES_DATADIR}/${MY_DATA_DIR}"
+}
+
+src_install() {
+ local MY_TGT="${GAMES_DATADIR}/${MY_DATA_DIR}"
+
+ emake DESTDIR="${D}" install || die 'emake install failed.'
+ dodoc ${DOCS[@]} || die 'dodoc failed.'
+
+ # We have to manually install the game data:
+ dodir "${MY_TGT}"
+ for dir in $(find "${WORKDIR}/${MY_DATA_DIR}" -mindepth 1 -maxdepth 1 -type d) ; do
+ echo -n "copying ${dir}"
+ cp -r "${dir}" "${D}${MY_TGT}"/ || die " ... failed"
+ echo " done"
+ done
+
+ icotool -x ${S}/src/client/7k.ico -o ${S}/7kaa.png
+ doicon "${S}/7kaa.png"
+
+ games_make_wrapper 7kaa "${GAMES_BINDIR}/7kaa.bin" "${MY_TGT}"
+ make_desktop_entry 7kaa "Seven Kingdoms" 7kaa "Game;StrategyGame" "Path=${MY_TGT}"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ elog "What you will NOT find in this archive"
+ elog "---------"
+ elog "* The original game music. These files cannot be distributed as Enlight"
+ elog " does not own the copyright. This includes the music directory and the"
+ elog " intro video."
+ elog "* The original translations resource file. This file was created by third"
+ elog " party distributors and Enlight does not have the right to distribute it."
+ elog " This will be replaced by the 7kfans project."
+ elog "* Any other content from original game CDs, including the version 2.12b"
+ elog " game binary or older. This also includes the I*Magic Online service."
+ echo
+ elog "Please do not upload missing content from the original game to the"
+ elog "internet. It is very nice that Enlight has provided the game under the"
+ elog "GPL, but this does not allow you to now violate the rights of other"
+ elog "copyright owners."
+ echo
+ elog "If you really do want to get the music from the original game, you can"
+ elog "still buy Seven Kingdoms for $6 at GoG.com."
+ echo
+ games_pkg_postinst
+}