summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Lallemand <wlallemand@irq6.net>2013-02-28 20:47:03 +0100
committerWilliam Lallemand <wlallemand@irq6.net>2013-02-28 20:47:03 +0100
commit7c60f163b7fa78864e901f86f1148bf2c74a13b3 (patch)
tree6595961383b50d248dbf6604c971a0481e052763
parentAdd repo_name (diff)
downloadsekh-7c60f163b7fa78864e901f86f1148bf2c74a13b3.tar.gz
sekh-7c60f163b7fa78864e901f86f1148bf2c74a13b3.tar.bz2
sekh-7c60f163b7fa78864e901f86f1148bf2c74a13b3.zip
poezio git and dependencies
-rw-r--r--dev-python/dnspython3/Manifest2
-rw-r--r--dev-python/dnspython3/dnspython3-1.10.0.ebuild47
-rw-r--r--dev-python/sleekxmpp/Manifest3
-rw-r--r--dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild40
-rw-r--r--dev-python/sleekxmpp/sleekxmpp-9999.ebuild40
-rw-r--r--net-im/poezio/Manifest1
-rw-r--r--net-im/poezio/poezio-9999.ebuild26
7 files changed, 159 insertions, 0 deletions
diff --git a/dev-python/dnspython3/Manifest b/dev-python/dnspython3/Manifest
new file mode 100644
index 0000000..181af48
--- /dev/null
+++ b/dev-python/dnspython3/Manifest
@@ -0,0 +1,2 @@
+DIST dnspython3-1.10.0.tar.gz 123929 SHA256 1478051ba0ad24aa33ce4cd504190104ede99ca3c8c907163f4cc820ddfe2e95 SHA512 9e5a754fc2dbb50198808eceb4bdf2edd48eb9b943cf8d995681aea3b30aac8b7d50c839302800390a19b35576b4086da487506085c130a096372319642eb98b WHIRLPOOL 509453618e044ab32ec0ff42736c768ca2f4e25a2fc0563620b24ae067d7c75de53e53a27dff9464ce44e034c0d53e7c63814c3ddb6e75431eb87044c28a69a3
+EBUILD dnspython3-1.10.0.ebuild 1105 SHA256 f5669937d0b1801ecba0d5073c32d4b09370489b2c5f04a543d59dd0f9b1356f SHA512 414c58aa96eb46bc9451e76040e8647b32e290b34b0b3c3cf5f0bf00e2fd334fd6b318b16f8f51d5b9247cd25e7bb9767b46e6781126a9bf5c503ba5d449f888 WHIRLPOOL e186ff2790954bd0ffee084240f0cd2ec09ffac9d5a079e266d25aa7687994e4b060342ccf3a4ee6e49be1dbe499e309025e542260b033bb53ff9e20b67fbce6
diff --git a/dev-python/dnspython3/dnspython3-1.10.0.ebuild b/dev-python/dnspython3/dnspython3-1.10.0.ebuild
new file mode 100644
index 0000000..7e51add
--- /dev/null
+++ b/dev-python/dnspython3/dnspython3-1.10.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+PYTHON_DEPEND="3"
+RESTRICT_PYTHON_ABIS="2.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="DNS toolkit for Python 3"
+HOMEPAGE="http://www.dnspython.org/ http://pypi.python.org/pypi/dnspython3"
+SRC_URI="http://www.dnspython.org/kits3/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples"
+
+DEPEND="dev-python/pycrypto"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog README"
+PYTHON_MODNAME="dns"
+
+src_test() {
+ cd tests
+
+ testing() {
+ local exit_status="0" test
+ for test in *.py; do
+ echo "Running ${test}..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}" || exit_status="1"
+ done
+ return "${exit_status}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die "Installation of examples failed"
+ fi
+}
diff --git a/dev-python/sleekxmpp/Manifest b/dev-python/sleekxmpp/Manifest
new file mode 100644
index 0000000..1a60ba9
--- /dev/null
+++ b/dev-python/sleekxmpp/Manifest
@@ -0,0 +1,3 @@
+DIST sleekxmpp-1.1.11.tar.gz 971732 SHA256 c6f4a466881dcef0c4d054e690b6fbc24639c24bf366a2e4e45ea781403a20b0 SHA512 0757965a9f1779b2341b412e8383c51161d9f2e97af565127d878c5c61cf40ce660adb20dfa4c509e3e49d142df0a04a74067565b18db168286caeea486bf209 WHIRLPOOL f1541ee6d8d57c575fc831048093505a748120f5eb7280e50ce27cdb47f9de89fe9dc4f99ed3cc7bb354da35d78ce992261bb12489cef24355c781a335766347
+EBUILD sleekxmpp-1.1.11.ebuild 759 SHA256 75b91ca90a97ad7612408751ceffad0212a853bcf5b580509faf102bf1e90197 SHA512 1af0f83687501618c0ced8aad019af7ab9b53d25fd041fdb122654c76e29f4a27b000c9009bbfe0e7eb1aff3671f38f9bcb2b25010a263520af8e35d44f89ac4 WHIRLPOOL 9fb24622b09ab0e8c0f0388327b6f787336c3972299ca6fa569abacbf167d56fa028d475e48e7358c505cbdb99f0ed85457a5639c7e5bb7103ec24e6e05648bd
+EBUILD sleekxmpp-9999.ebuild 750 SHA256 1930abd9df2301a5b30a1f6d6b456c123b1769bbbcb80c5133a895d78c81dbbc SHA512 c38f92660d4a36ef9c23351d6cf654606811855049b8f2604714c403f14e941d265c7ac414f0d5e84da0db1fd92cd94426741b447c0a2f1b6112c3c4916ad248 WHIRLPOOL 876375b55b85179897817127618ac40b3d0e13361b6df841b508a41f490dd5b306210d8e39d7faf0c60aad17bfedb359adf896631dee9a9b57cb70df75db2f6e
diff --git a/dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild b/dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild
new file mode 100644
index 0000000..c01a265
--- /dev/null
+++ b/dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit vcs-snapshot distutils
+
+DESCRIPTION="MIT licensed XMPP library for Python"
+HOMEPAGE="http://sleekxmpp.com/"
+SRC_URI="https://github.com/fritzy/SleekXMPP/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND="
+ dev-python/dnspython
+ dev-python/python-gnupg
+"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ make -C docs html
+ dohtml -r docs/_build/html/
+ fi
+ if use examples; then
+ dodoc -r examples
+ fi
+}
diff --git a/dev-python/sleekxmpp/sleekxmpp-9999.ebuild b/dev-python/sleekxmpp/sleekxmpp-9999.ebuild
new file mode 100644
index 0000000..6a9f518
--- /dev/null
+++ b/dev-python/sleekxmpp/sleekxmpp-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit vcs-snapshot distutils git-2
+
+DESCRIPTION="MIT licensed XMPP library for Python"
+HOMEPAGE="http://sleekxmpp.com/"
+EGIT_REPO_URI="git://github.com/fritzy/SleekXMPP.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND="
+ dev-python/dnspython3
+ dev-python/python-gnupg
+"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ make -C docs html
+ dohtml -r docs/_build/html/
+ fi
+ if use examples; then
+ dodoc -r examples
+ fi
+}
diff --git a/net-im/poezio/Manifest b/net-im/poezio/Manifest
new file mode 100644
index 0000000..b87cf46
--- /dev/null
+++ b/net-im/poezio/Manifest
@@ -0,0 +1 @@
+EBUILD poezio-9999.ebuild 562 SHA256 2de1281835f5e103b9ba723375285e8b35cb83ef19ce08e4ce742b3bc896b814 SHA512 ee7def2a221641f51c15e60610d67291f3cf8e6fe87c8b74e1a7af496bd02a7758422930235b8a78a63f2f9cebe616f0ccb8361119f0a2193f6be4a9b1e67293 WHIRLPOOL b9e3beddcbab6dae13b41d6066e1fe7841c4c10d2236c2adab772ae5a91f430f2d906fd5fbd812c9b2dea31afe8710f930870d5f5eb932684825ec16ffa14f37
diff --git a/net-im/poezio/poezio-9999.ebuild b/net-im/poezio/poezio-9999.ebuild
new file mode 100644
index 0000000..c1e6ae8
--- /dev/null
+++ b/net-im/poezio/poezio-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_DEPEND="3"
+
+EGIT_REPO_URI="git://github.com/sekh/poezio.git"
+
+inherit python git-2
+
+DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
+HOMEPAGE="http://poezio.eu/"
+
+LICENSE="custom"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=dev-python/sleekxmpp-9999 >=dev-python/dnspython3-1.10.0"
+RDEPEND="${DEPEND}"
+
+src_install()
+{
+ emake DESTDIR="${D}" prefix="/usr/" install || die "make install failed"
+}