summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild')
-rw-r--r--dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild b/dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild
new file mode 100644
index 0000000..c01a265
--- /dev/null
+++ b/dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit vcs-snapshot distutils
+
+DESCRIPTION="MIT licensed XMPP library for Python"
+HOMEPAGE="http://sleekxmpp.com/"
+SRC_URI="https://github.com/fritzy/SleekXMPP/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND="
+ dev-python/dnspython
+ dev-python/python-gnupg
+"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ make -C docs html
+ dohtml -r docs/_build/html/
+ fi
+ if use examples; then
+ dodoc -r examples
+ fi
+}