summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-05 21:42:20 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-05 21:42:20 +0200
commit2011fc297226ad7d6fca233237a18d3d81211b23 (patch)
tree488fafd55e091ad042f43f572f657c9344598bae
parentsys-fs/udev: reintroduce systemd IUSE (diff)
downloadsystemd-2011fc297226ad7d6fca233237a18d3d81211b23.tar.gz
systemd-2011fc297226ad7d6fca233237a18d3d81211b23.tar.bz2
systemd-2011fc297226ad7d6fca233237a18d3d81211b23.zip
remove sys-apps/dbus
systemd unit files are now always installed by the ebuild in the main tree. Hooray!
-rw-r--r--sys-apps/dbus/Manifest6
-rw-r--r--sys-apps/dbus/dbus-1.4.8.ebuild189
-rw-r--r--sys-apps/dbus/files/80-dbus13
-rw-r--r--sys-apps/dbus/files/dbus-1.4.0-asneeded.patch94
-rw-r--r--sys-apps/dbus/files/dbus.init-1.051
-rw-r--r--sys-apps/dbus/metadata.xml11
-rw-r--r--sys-apps/systemd/Manifest2
-rw-r--r--sys-apps/systemd/systemd-26.ebuild4
8 files changed, 2 insertions, 368 deletions
diff --git a/sys-apps/dbus/Manifest b/sys-apps/dbus/Manifest
deleted file mode 100644
index 0572fac..0000000
--- a/sys-apps/dbus/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-AUX 80-dbus 341 RMD160 3b7f55906289d91a1f0ed87edec7902ddac076c5 SHA1 df1f96934fbe164dc4f4e2e4d4b4cdeaf8cef2b5 SHA256 76ce25ce8769cdfcb0d7b7e52e5a7e6474448fc34e8ad9393afac1eca1e07fd2
-AUX dbus-1.4.0-asneeded.patch 3696 RMD160 360f21c06d268116884ed441e7b91478829f1be5 SHA1 a15445bcc5d811276c681b543d0bcd14df9db32f SHA256 f785afd7943b3220ebcf2603b1c059a2dec46bdbfba376e60d8373ba3f933562
-AUX dbus.init-1.0 1152 RMD160 f0f409b59167beef2e2b8c14f701fbeaa54c3bc9 SHA1 b00e23868046c67eaec87220e92ffcea5d9dd911 SHA256 a2e13a025faa488ff35521188c0d44909bc82c55e8676a24a5a5179545303d98
-DIST dbus-1.4.8.tar.gz 1841864 RMD160 3f0f7ff7e952b93c33fe27862d2b4191394e0032 SHA1 68076715cc600964967715fff927face01313b6e SHA256 48bf73a35be0f0e2d9a5071d8f2d9c7c40b4254d9b405dee57f0fb07c9c3cf58
-EBUILD dbus-1.4.8.ebuild 4747 RMD160 2d4466ac575cf4dc6704ee06553c206adb5f0ea0 SHA1 31e54adc31182fc07e6735d2bd4f97dfa9f517d7 SHA256 3b287399d7a0b3d6e10e650f15c586dc05d7e3415b733c5831deb76d27043c95
-MISC metadata.xml 285 RMD160 a557848c4782030e9eeb3dc1f06d98840ad7f73a SHA1 e0ba318a0e1a819cc360ea98cc3477dcf52a1526 SHA256 f0df8a3ebe8d22c87645cf66ed8c50c4e64ded6ad1e279e9912cb5074feb5a82
diff --git a/sys-apps/dbus/dbus-1.4.8.ebuild b/sys-apps/dbus/dbus-1.4.8.ebuild
deleted file mode 100644
index e700f84..0000000
--- a/sys-apps/dbus/dbus-1.4.8.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.4.8.ebuild,v 1.2 2011/04/26 16:13:24 ssuominen Exp $
-
-EAPI=2
-inherit autotools eutils multilib flag-o-matic python virtualx systemd-local
-
-DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
-HOMEPAGE="http://dbus.freedesktop.org/"
-SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc selinux static-libs test X"
-
-RDEPEND="
- X? (
- x11-libs/libX11
- x11-libs/libXt
- )
- selinux? (
- sys-libs/libselinux
- sec-policy/selinux-dbus
- )
- >=dev-libs/expat-1.95.8
- systemd? ( !sys-apps/systemd-dbus )
-"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? (
- app-doc/doxygen
- app-text/docbook-xml-dtd:4.1.2
- app-text/xmlto
- )
- test? ( =dev-lang/python-2* )
-"
-
-# out of sources build directory
-BD=${WORKDIR}/${P}-build
-# out of sources build dir for make check
-TBD=${WORKDIR}/${P}-tests-build
-
-pkg_setup() {
- enewgroup messagebus
- enewuser messagebus -1 "-1" -1 messagebus
-
- if use test; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # Tests were restricted because of this
- sed -i \
- -e 's/.*bus_dispatch_test.*/printf ("Disabled due to excess noise\\n");/' \
- -e '/"dispatch"/d' \
- bus/test-main.c || die
-
- epatch "${FILESDIR}"/${PN}-1.4.0-asneeded.patch
-
- # required for asneeded patch but also for bug 263909, cross-compile so
- # don't remove eautoreconf
- eautoreconf
-}
-
-src_configure() {
- local my_conf
-
- # so we can get backtraces from apps
- append-flags -rdynamic
-
- # libaudit is *only* used in DBus wrt SELinux support, so disable it, if
- # not on an SELinux profile.
- my_conf="$(use_with X x)
- $(use_enable debug verbose-mode)
- $(use_enable debug asserts)
- $(use_enable kernel_linux inotify)
- $(use_enable kernel_FreeBSD kqueue)
- $(use_enable selinux)
- $(use_enable selinux libaudit)
- $(use_enable static-libs static)
- $(use_with_systemdsystemunitdir)
- --enable-shared
- --with-xml=expat
- --with-system-pid-file=/var/run/dbus.pid
- --with-system-socket=/var/run/dbus/system_bus_socket
- --with-session-socket-dir=/tmp
- --with-dbus-user=messagebus
- --localstatedir=/var"
-
- mkdir "${BD}"
- cd "${BD}"
- einfo "Running configure in ${BD}"
- ECONF_SOURCE="${S}" econf ${my_conf} \
- $(use_enable doc doxygen-docs) \
- $(use_enable doc xml-docs)
-
- if use test; then
- mkdir "${TBD}"
- cd "${TBD}"
- einfo "Running configure in ${TBD}"
- ECONF_SOURCE="${S}" econf \
- ${my_conf} \
- $(use_enable test checks) \
- $(use_enable test tests) \
- $(use_enable test asserts)
- fi
-}
-
-src_compile() {
- # after the compile, it uses a selinuxfs interface to
- # check if the SELinux policy has the right support
- use selinux && addwrite /selinux/access
-
- cd "${BD}"
- einfo "Running make in ${BD}"
- emake || die
-
- if use doc; then
- doxygen || die
- fi
-
- if use test; then
- cd "${TBD}"
- einfo "Running make in ${TBD}"
- emake || die
- fi
-}
-
-src_test() {
- cd "${TBD}"
- DBUS_VERBOSE=1 Xemake -j1 check || die
-}
-
-src_install() {
- # initscript
- newinitd "${FILESDIR}"/dbus.init-1.0 dbus || die
-
- if use X ; then
- # dbus X session script (#77504)
- # turns out to only work for GDM (and startx). has been merged into
- # other desktop (kdm and such scripts)
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}"/80-dbus || die
- fi
-
- # needs to exist for the system socket
- keepdir /var/run/dbus
- # needs to exist for machine id
- keepdir /var/lib/dbus
- # needs to exist for dbus sessions to launch
-
- keepdir /usr/lib/dbus-1.0/services
- keepdir /usr/share/dbus-1/services
- keepdir /etc/dbus-1/system.d/
- keepdir /etc/dbus-1/session.d/
-
- dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO || die
-
- cd "${BD}"
- # FIXME: split dtd's in dbus-dtd ebuild
- emake DESTDIR="${D}" install || die
- if use doc; then
- dohtml -p api/ doc/api/html/* || die
- cd "${S}"
- dohtml doc/*.html || die
- fi
-
- # Remove .la files
- find "${D}" -type f -name '*.la' -exec rm -f {} +
-}
-
-pkg_postinst() {
- elog "To start the D-Bus system-wide messagebus by default"
- elog "you should add it to the default runlevel :"
- elog "\`rc-update add dbus default\`"
- elog
- elog "Some applications require a session bus in addition to the system"
- elog "bus. Please see \`man dbus-launch\` for more information."
- elog
- ewarn "You must restart D-Bus \`/etc/init.d/dbus restart\` to run"
- ewarn "the new version of the daemon."
- ewarn "Don't do this while X is running because it will restart your X as well."
-
- # Ensure unique id is generated
- dbus-uuidgen --ensure="${ROOT}"/var/lib/dbus/machine-id
-}
diff --git a/sys-apps/dbus/files/80-dbus b/sys-apps/dbus/files/80-dbus
deleted file mode 100644
index 5593e2c..0000000
--- a/sys-apps/dbus/files/80-dbus
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/bash
-
-# launches a session dbus instance
-
-dbuslaunch="`which dbus-launch 2>/dev/null`"
-if [ -n "$dbuslaunch" ] && [ -x "$dbuslaunch" ] && [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
- if [ -n "$command" ]; then
- command="$dbuslaunch --exit-with-session $command"
- else
- eval `$dbuslaunch --sh-syntax --exit-with-session`
- fi
-fi
-
diff --git a/sys-apps/dbus/files/dbus-1.4.0-asneeded.patch b/sys-apps/dbus/files/dbus-1.4.0-asneeded.patch
deleted file mode 100644
index baa7129..0000000
--- a/sys-apps/dbus/files/dbus-1.4.0-asneeded.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-http://bugs.freedesktop.org/show_bug.cgi?id=23162
-
---- dbus/Makefile.am
-+++ dbus/Makefile.am
-@@ -277,7 +277,7 @@
- dbus_test_SOURCES= \
- dbus-test-main.c
-
--dbus_test_LDADD=libdbus-internal.la $(DBUS_TEST_LIBS)
-+dbus_test_LDADD=$(DBUS_TEST_LIBS) libdbus-internal.la
- dbus_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
-
- ## mop up the gcov files
---- test/Makefile.am
-+++ test/Makefile.am
-@@ -63,17 +63,17 @@
-
- # When any programs are not linked to libdbus-internal, fix this.
- AM_CPPFLAGS=-DDBUS_STATIC_BUILD
--TEST_LIBS=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
-+TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
-
--test_service_LDADD=libdbus-testutils.la $(TEST_LIBS)
-+test_service_LDADD=$(TEST_LIBS) libdbus-testutils.la
- test_service_LDFLAGS=@R_DYNAMIC_LDFLAG@
--test_names_LDADD=libdbus-testutils.la $(TEST_LIBS)
-+test_names_LDADD=$(TEST_LIBS) libdbus-testutils.la
- test_names_LDFLAGS=@R_DYNAMIC_LDFLAG@
- ## break_loader_LDADD= $(TEST_LIBS)
- ## break_loader_LDFLAGS=@R_DYNAMIC_LDFLAG@
--test_shell_service_LDADD=libdbus-testutils.la $(TEST_LIBS)
-+test_shell_service_LDADD=$(TEST_LIBS) libdbus-testutils.la
- test_shell_service_LDFLAGS=@R_DYNAMIC_LDFLAG@
--shell_test_LDADD=libdbus-testutils.la $(TEST_LIBS)
-+shell_test_LDADD=$(TEST_LIBS) libdbus-testutils.la
- shell_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
- spawn_test_LDADD=$(TEST_LIBS)
- spawn_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
---- test/name-test/Makefile.am
-+++ test/name-test/Makefile.am
-@@ -22,46 +22,46 @@
- test_pending_call_dispatch_SOURCES = \
- test-pending-call-dispatch.c
-
--test_pending_call_dispatch_LDADD=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
-+test_pending_call_dispatch_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
- test_pending_call_dispatch_LDFLAGS=@R_DYNAMIC_LDFLAG@
-
- test_pending_call_timeout_SOURCES = \
- test-pending-call-timeout.c
-
--test_pending_call_timeout_LDADD=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
-+test_pending_call_timeout_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
- test_pending_call_timeout_LDFLAGS=@R_DYNAMIC_LDFLAG@
-
- test_threads_init_SOURCES = \
- test-threads-init.c
-
--test_threads_init_LDADD=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
-+test_threads_init_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
- test_threads_init_LDFLAGS=@R_DYNAMIC_LDFLAG@
-
- test_ids_SOURCES = \
- test-ids.c
-
--test_ids_LDADD=$(top_builddir)/dbus/libdbus-internal.la $(DBUS_TEST_LIBS)
-+test_ids_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la
- test_ids_LDFLAGS=@R_DYNAMIC_LDFLAG@
-
- test_shutdown_SOURCES = \
- test-shutdown.c
-
- test_shutdown_CFLAGS=
--test_shutdown_LDADD=$(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la $(DBUS_TEST_LIBS)
-+test_shutdown_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la
- test_shutdown_LDFLAGS=@R_DYNAMIC_LDFLAG@
-
- test_privserver_SOURCES = \
- test-privserver.c
-
- test_privserver_CFLAGS=
--test_privserver_LDADD=$(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la $(DBUS_TEST_LIBS)
-+test_privserver_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la
- test_privserver_LDFLAGS=@R_DYNAMIC_LDFLAG@
-
- test_privserver_client_SOURCES = \
- test-privserver-client.c
-
- test_privserver_client_CFLAGS=
--test_privserver_client_LDADD=$(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la $(DBUS_TEST_LIBS)
-+test_privserver_client_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-internal.la ../libdbus-testutils.la
- test_privserver_client_LDFLAGS=@R_DYNAMIC_LDFLAG@
-
- endif
diff --git a/sys-apps/dbus/files/dbus.init-1.0 b/sys-apps/dbus/files/dbus.init-1.0
deleted file mode 100644
index e96ea05..0000000
--- a/sys-apps/dbus/files/dbus.init-1.0
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/files/dbus.init-1.0,v 1.4 2007/04/04 13:35:25 cardoe Exp $
-
-opts="reload"
-
-depend() {
- need localmount
- after bootmisc
-}
-
-start() {
- ebegin "Starting D-BUS system messagebus"
-
- /usr/bin/dbus-uuidgen --ensure
-
- # We need to test if /var/run/dbus exists, since script will fail if it does not
- [ ! -e /var/run/dbus ] && mkdir /var/run/dbus
-
- start-stop-daemon --start --pidfile /var/run/dbus.pid --exec /usr/bin/dbus-daemon -- --system
- eend $?
-}
-
-stop() {
- local retval
-
- ebegin "Stopping D-BUS system messagebus"
-
- start-stop-daemon --stop --pidfile /var/run/dbus.pid
- retval=$?
-
- eend ${retval}
-
- [ -S /var/run/dbus/system_bus_socket ] && rm -f /var/run/dbus/system_bus_socket
-
- return ${retval}
-}
-
-reload() {
- local retval
-
- ebegin "Reloading D-BUS messagebus config"
-
- /usr/bin/dbus-send --print-reply --system --type=method_call \
- --dest=org.freedesktop.DBus \
- / org.freedesktop.DBus.ReloadConfig > /dev/null
- retval=$?
- eend ${retval}
- return ${retval}
-}
diff --git a/sys-apps/dbus/metadata.xml b/sys-apps/dbus/metadata.xml
deleted file mode 100644
index f65c1a3..0000000
--- a/sys-apps/dbus/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>freedesktop</herd>
-<maintainer>
- <email>cardoe@gentoo.org</email>
-</maintainer>
-<maintainer>
- <email>steev@gentoo.org</email>
-</maintainer>
-</pkgmetadata>
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
index e0a8328..3eed924 100644
--- a/sys-apps/systemd/Manifest
+++ b/sys-apps/systemd/Manifest
@@ -1,4 +1,4 @@
DIST systemd-26.tar.bz2 791117 RMD160 06836ca8daf0c5ebc113940357289348561dac56 SHA1 901486904aeb1d8a3ae20e5971afd9b42b847450 SHA256 d7a222c09cdb0a9eebe97c7c499c458cc29ef8b3b2d0ca79bb949b2fd3d077d3
-EBUILD systemd-26.ebuild 3726 RMD160 97d458ce779b47ec7168393c78f3ce2f3602acb3 SHA1 f36c806c2181174f85f23c2d1570744a566dd9ab SHA256 fb0fb7403df6d46dadd97cd4a2c52e4f13fd2062277e8a5cfa1d5796b4c5637c
+EBUILD systemd-26.ebuild 3678 RMD160 d4a4d97a68929b2402e7ae569e41e18c6dc3298c SHA1 726cf6a1a03dcc8787cb8198e1f25618e98c9490 SHA256 d447ca087e0ea70c2fdcf36704b297c2f84b1f075090509ae9cc376c1048cdb9
EBUILD systemd-9999.ebuild 3077 RMD160 7d8f07f2aa567f4461c3b61eda0730c80e95e444 SHA1 93b84d98fac70f16b0f5d268426cc99c1705b5e6 SHA256 3841ecaa0200ff83d46a76e2ffb44ec8b2a4ea2e57638ebe53a720fe4d6f5d6c
MISC metadata.xml 737 RMD160 cdd440f38c039bfa7967fd713ef238588c2e1fb4 SHA1 1dea5e1d1e388bf43131297667bb4dbba10e65dd SHA256 042b1b68c02c274920954280705e21c2ca2ef5eece3229aab03d8dd43e06422d
diff --git a/sys-apps/systemd/systemd-26.ebuild b/sys-apps/systemd/systemd-26.ebuild
index 2eab674..3ad6477 100644
--- a/sys-apps/systemd/systemd-26.ebuild
+++ b/sys-apps/systemd/systemd-26.ebuild
@@ -17,9 +17,7 @@ IUSE="audit gtk pam +tcpwrap sysv selinux"
-COMMON_DEPEND="
- || ( >=sys-apps/dbus-1.4.0[systemd]
- >=sys-apps/systemd-dbus-1.4.0 )
+COMMON_DEPEND=">=sys-apps/dbus-1.4.8-r1
sys-libs/libcap
>=sys-fs/udev-163[systemd]
audit? ( sys-process/audit )