summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd-units/systemd-units-9999.ebuild')
-rw-r--r--sys-apps/systemd-units/systemd-units-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-apps/systemd-units/systemd-units-9999.ebuild b/sys-apps/systemd-units/systemd-units-9999.ebuild
index e1651c8..9f4d0e5 100644
--- a/sys-apps/systemd-units/systemd-units-9999.ebuild
+++ b/sys-apps/systemd-units/systemd-units-9999.ebuild
@@ -34,4 +34,8 @@ src_install() {
rm -f "${D}/$(systemd_get_unitdir)"/gdm@.service
fi
fi
+
+ # Files in portage cannot contain a literal '@' character. Therfore,
+ # convert the code string "_at" into an '@' before installing.
+ rename '_at' '@' "${D}/$(systemd_get_unitdir)"/*
}