summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNoel Darlow <mail@mcgruff.plus.com>2012-11-12 13:29:46 +0000
committerNoel Darlow <mail@mcgruff.plus.com>2012-11-12 13:29:46 +0000
commit15a413395528e888c3b4a1f8745cd18d02e09905 (patch)
tree2807292bd2d9b5657f0bffc12cbcbca7f2924022 /app-admin/gentool/gentool-0.2.9.ebuild
parentbashfun remote file exists (diff)
downloadunderlay-15a413395528e888c3b4a1f8745cd18d02e09905.tar.gz
underlay-15a413395528e888c3b4a1f8745cd18d02e09905.tar.bz2
underlay-15a413395528e888c3b4a1f8745cd18d02e09905.zip
minor edit backup list display
Diffstat (limited to 'app-admin/gentool/gentool-0.2.9.ebuild')
-rw-r--r--app-admin/gentool/gentool-0.2.9.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/gentool/gentool-0.2.9.ebuild b/app-admin/gentool/gentool-0.2.9.ebuild
new file mode 100644
index 0000000..9d07298
--- /dev/null
+++ b/app-admin/gentool/gentool-0.2.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="gentoo system management"
+HOMEPAGE=""
+SRC_URI="http://www.aperiplus.co.uk/downloads/src/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-misc/bashfun-0.1.4
+ net-misc/htpdate
+ net-misc/rsync
+ sys-boot/grub"
+
+#DEPEND=""
+
+src_install() {
+ dodir /opt/bin
+
+ insinto '/opt/gentool'
+ insopts -m0755
+ doins -r "${S}/opt/gentool/bin"
+ dosym /opt/gentool/bin/gentool.sh /opt/bin/gentool
+
+ insinto '/opt/gentool'
+ insopts -m0644
+ doins -r "${S}/opt/gentool/docs"
+
+ insinto '/opt/gentool'
+ insopts -m0644
+ doins -r "${S}/opt/gentool/lib"
+
+ dodir '/etc/gentool'
+ insinto '/etc/gentool'
+ insopts -m0644
+ doins "${S}/etc/gentool/config.sh"
+
+ doenvd "${S}/etc/env.d/99gentool-env"
+}
+
+pkg_postinst() {
+ elog
+ elog 'you may want to edit /etc/gentool/config.sh now - just follow instructions in the file'
+ elog
+}