summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Kuhn <Wuodan0@gmail.com>2015-01-18 13:06:10 +0100
committerStefan Kuhn <Wuodan0@gmail.com>2015-01-18 13:06:10 +0100
commit2ff209fab21bc831301ff8cf227de265c8fe5a4f (patch)
tree7978ce99a2d9286effadcb19132b1bcc990d72ed /pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild
parentsys-boot/gummiboot-45: Depend on 2 versions of sys-bot/gnu-efi: 3.0s or 3.0u.... (diff)
downloadwuodan-2ff209fab21bc831301ff8cf227de265c8fe5a4f.tar.gz
wuodan-2ff209fab21bc831301ff8cf227de265c8fe5a4f.tar.bz2
wuodan-2ff209fab21bc831301ff8cf227de265c8fe5a4f.zip
pentoo/pentoo-installer: added version, 99999 now points to branches/developmentHEADmaster
Diffstat (limited to 'pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild')
-rw-r--r--pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild b/pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild
new file mode 100644
index 0000000..dbe64cb
--- /dev/null
+++ b/pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit subversion
+
+DESCRIPTION="Installer for pentoo"
+HOMEPAGE="https://code.google.com/p/pentoo/"
+ESVN_REPO_URI="https://${PN}.googlecode.com/svn/tags/v${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="dev-util/dialog
+ X? ( x11-misc/xdialog )
+ || ( sys-boot/grub:0
+ sys-boot/grub-static:0 )
+ sys-boot/grub:2
+ sys-fs/squashfs-tools
+ net-misc/rsync"
+
+src_install() {
+ dodir /usr/
+ cp -R "${S}"/* "${ED}"/usr/ || die "Copy files failed"
+ exeinto /root/Desktop/
+ doexe share/applications/pentoo-installer.desktop
+}