summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/mozilla-addon.eclass188
-rw-r--r--www-plugins/downthemall/Manifest4
-rw-r--r--www-plugins/downthemall/downthemall-2.0.17.ebuild31
-rw-r--r--www-plugins/downthemall/downthemall-9999.ebuild36
-rw-r--r--www-plugins/enigmail/Manifest3
-rw-r--r--www-plugins/enigmail/enigmail-1.7.2.ebuild79
-rw-r--r--www-plugins/lightning/Manifest4
-rw-r--r--www-plugins/lightning/lightning-3.3.1.ebuild32
-rw-r--r--www-plugins/lightning/lightning-9999.ebuild37
-rw-r--r--www-plugins/multi_links/Manifest4
-rw-r--r--www-plugins/multi_links/multi_links-3.0.0.19-r2.ebuild31
-rw-r--r--www-plugins/multi_links/multi_links-9999.ebuild36
-rw-r--r--www-plugins/provider_for_google_calendar/Manifest4
-rw-r--r--www-plugins/provider_for_google_calendar/provider_for_google_calendar-1.0.2.ebuild32
-rw-r--r--www-plugins/provider_for_google_calendar/provider_for_google_calendar-9999.ebuild37
-rw-r--r--www-plugins/status_4_evar/Manifest4
-rw-r--r--www-plugins/status_4_evar/status_4_evar-2014.07.06.05.ebuild31
-rw-r--r--www-plugins/status_4_evar/status_4_evar-9999.ebuild36
18 files changed, 629 insertions, 0 deletions
diff --git a/eclass/mozilla-addon.eclass b/eclass/mozilla-addon.eclass
new file mode 100644
index 0000000..33ad3a7
--- /dev/null
+++ b/eclass/mozilla-addon.eclass
@@ -0,0 +1,188 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# @ECLASS: mozilla-addon.eclass
+# @MAINTAINER:
+# Stefan Kuhn <wuodan@pentoo.ch>
+# @BLURB: Eclass for installing firefox addons.
+# @DESCRIPTION:
+# Install addons for firefox
+
+inherit mozextension multilib
+
+# @ECLASS-VARIABLE: MZA_TARGETS
+# @REQUIRED
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# Space separated list of target packages. Allowed items:
+# firefox, thunderbird, seamonkey, firefox-bin, thunderbird-bin, seamonkey-bin
+#
+# MZA_TARGETS=firefox firefox-bin
+
+# @ECLASS-VARIABLE: MZA_XPI_PATH
+# @DESCRIPTION:
+# PAth to unpacked xpi content for installation. Default is ${WORKDIR/${P}.
+: ${MZA_XPI_PATH:=${WORKDIR}/${P}}
+
+# This eclass supports all EAPIs
+EXPORT_FUNCTIONS src_unpack src_install
+
+# @FUNCTION: mozilla-addon_dosym
+# @DESCRIPTION:
+# creates a symlink to the global installation target
+mozilla-addon_dosym() {
+ # 2 required arguments
+ [[ ${#} -ne 2 ]] && die "$FUNCNAME takes exactly two arguments. Please specify the global-installation-path plus the full symlink to it."
+ local installpath="${1}"
+ local symlinkpath="${2}"
+ # conversion from previous installations without symlink
+ # portage does prevent replacing dir with a symlink
+ if [[ -e "${symlinkpath}" ]] \
+ && ! [[ -h "${symlinkpath}" ]]; then
+ addwrite "${symlinkpath}" || die 'addwrite failed'
+ rm -rf "${symlinkpath}" || die 'rm failed'
+ fi
+ dosym "${installpath}" \
+ "${symlinkpath}"
+}
+
+# @FUNCTION: mozilla-addon_getemid
+# @DESCRIPTION:
+# Parses em:id from install.rdf file
+# Avoid using awk with this dummy parser function
+mozilla-addon_getemid() {
+ # no arguments allowed
+ [[ ${#} -ne 0 ]] && die "$FUNCNAME takes no arguments."
+ [[ ! -r "${MZA_XPI_PATH}/install.rdf" ]] && die "$FUNCNAME cannot read file ${MZA_XPI_PATH}/install.rdf"
+ local line
+ local targetapp=0
+ local emid
+ while read line; do
+ # comment lines
+ echo -n "${line}" | grep -q '^[[:space:]]*#' \
+ && continue
+ echo -n "${line}" | grep -q '<em:targetApplication>' \
+ && targetapp=1
+ if [[ "${targetapp}" -eq 0 ]] \
+ && echo -n "${line}" | grep -Eq '<em:id>[^<]+</em:id>'; then
+ emid="$(echo -n "${line}" | sed -r 's#^.*<em:id>([^<]+)</em:id>.*$#\1#')"
+ break
+ # other format, see install.rdf of www-client/exif_viewer
+ elif [[ "${targetapp}" -eq 0 ]] \
+ && echo -n "${line}" | grep -Eq 'em:id="[^"]+"'; then
+ emid="$(echo -n "${line}" | sed -r 's#^.*em:id="([^"]+)".*$#\1#')"
+ break
+ fi
+ echo -n "${line}" | grep -q '</em:targetApplication>' \
+ && targetapp=0
+ done < "${MZA_XPI_PATH}/install.rdf"
+ [[ -n "${emid}" ]] || die "$FUNCNAME could not find em:id!"
+ echo -n "${emid}"
+}
+
+# @FUNCTION: mozilla-addon_verifytarget
+# @DESCRIPTION:
+# Search for target package id in install.rdf. Warn if it's not found.
+mozilla-addon_verifytarget() {
+ [[ ${#} -ne 1 ]] && die "$FUNCNAME takes exactly one argument. Please specify the target package"
+ [[ ! -r "${MZA_XPI_PATH}/install.rdf" ]] && die "$FUNCNAME cannot read file ${MZA_XPI_PATH}/install.rdf"
+ # check target in install.rdf
+ case ${1} in
+ firefox|firefox-bin)
+ grep -q '<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>' \
+ "${MZA_XPI_PATH}/install.rdf" \
+ || ewarn 'Firefox not found as target in install.rdf' ;;
+ thunderbird|thunderbird-bin)
+ grep -q '<em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>' \
+ "${MZA_XPI_PATH}/install.rdf" \
+ || ewarn 'Thunderbird not found as target in install.rdf' ;;
+ seamonkey|seamonkey-bin)
+ grep -q '<em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>' \
+ "${MZA_XPI_PATH}/install.rdf" \
+ || ewarn 'Seamonkey not found as target in install.rdf' ;;
+ *) die "$FUNCNAME received unexptected target package ${1}" ;;
+ esac
+ return 0
+}
+
+# @FUNCTION: mozilla-addon_src_unpack
+# @DESCRIPTION:
+# Default src_unpack function for firefox addons
+mozilla-addon_src_unpack() {
+ xpi_unpack ${A}
+}
+
+# @FUNCTION: mozilla-addon_src_install
+# @DESCRIPTION:
+# Default install function for firefox addons
+mozilla-addon_src_install() {
+ local emid
+ local installpath
+ local count=0
+ # sanity check, at least one of these targets must be set
+ if ! has 'firefox' $MZA_TARGETS \
+ && ! has 'thunderbird' $MZA_TARGETS \
+ && ! has 'seamonkey' $MZA_TARGETS \
+ && ! has 'firefox-bin' $MZA_TARGETS \
+ && ! has 'thunderbird-bin' $MZA_TARGETS \
+ && ! has 'seamonkey-bin' $MZA_TARGETS; then
+ die "At least one of these targets (firefox thunderbird seamonkey firefox-bin thunderbird-bin seamonkey-bin) must be set to use this eclass."
+ fi
+ emid="$(mozilla-addon_getemid)" \
+ || die "failed to determine extension id"
+ installpath="/usr/$(get_libdir)/mozilla/extensions/${emid}"
+ # install to global installation folder
+ insinto "${installpath}" || die "insinto failed"
+ doins -r "${MZA_XPI_PATH}"/* || die "failed to copy extension"
+ # symlink each target
+ # target: firefox
+ if has 'firefox' $MZA_TARGETS; then
+ mozilla-addon_verifytarget firefox
+ mozilla-addon_dosym "${installpath}" \
+ "/usr/$(get_libdir)/firefox/browser/extensions/${emid}"
+ count=$((count+1))
+ mozilla-addon_dosym "${installpath}" \
+ "/usr/$(get_libdir)/firefox/extensions/${emid}"
+ count=$((count+1))
+ fi
+ # target: firefox-bin
+ if has 'firefox-bin' $MZA_TARGETS; then
+ mozilla-addon_dosym "${installpath}" \
+ "/opt/firefox/browser/extensions/${emid}"
+ count=$((count+1))
+ mozilla-addon_dosym "${installpath}" \
+ "/opt/firefox/extensions/${emid}"
+ count=$((count+1))
+ fi
+ # target: thunderbird
+ if has 'thunderbird' $MZA_TARGETS; then
+ mozilla-addon_verifytarget thunderbird
+ mozilla-addon_dosym "${installpath}" \
+ "/usr/$(get_libdir)/thunderbird/extensions/${emid}"
+ count=$((count+1))
+ fi
+ # target: thunderbird-bin
+ if has 'thunderbird-bin' $MZA_TARGETS; then
+ mozilla-addon_verifytarget thunderbird
+ mozilla-addon_dosym "${installpath}" \
+ "/opt/thunderbird/extensions/${emid}"
+ count=$((count+1))
+ fi
+ # target: seamonkey
+ if has 'seamonkey' $MZA_TARGETS; then
+ mozilla-addon_verifytarget seamonkey
+ mozilla-addon_dosym "${installpath}" \
+ "/usr/$(get_libdir)/seamonkey/extensions/${emid}"
+ count=$((count+1))
+ fi
+ # target: seamonkey-bin
+ if has 'seamonkey-bin' $MZA_TARGETS; then
+ mozilla-addon_verifytarget seamonkey
+ mozilla-addon_dosym "${installpath}" \
+ "/opt/seamonkey/extensions/${emid}"
+ count=$((count+1))
+ fi
+ # sanity check
+ [[ "${count}" -gt 0 ]] || die "Error in $FUNCNAME: No target was installed, this seems wrong!"
+}
diff --git a/www-plugins/downthemall/Manifest b/www-plugins/downthemall/Manifest
new file mode 100644
index 0000000..cbc866f
--- /dev/null
+++ b/www-plugins/downthemall/Manifest
@@ -0,0 +1,4 @@
+DIST downthemall-2.0.17.xpi 731942 SHA256 b306fb1c596bc2c8112139c0c6dc43cbb53df06869679c766ac66321ebacedb9 SHA512 1f52437f71829430d8f3028ab61738f4d1338268374fefba5d6ce478c7be813445ee19302fc76e090abc42ede1babdfecfbdb1e4fc592de4c7a265fa86feba90 WHIRLPOOL 3b0d27575808f67a0f40da2fd42529250af955b40cc26f498823f43d766f003023257466bc4e51ab8474575f730087bf67f855763784518e6dc652713aeff082
+DIST downthemall-9999.xpi 731942 SHA256 b306fb1c596bc2c8112139c0c6dc43cbb53df06869679c766ac66321ebacedb9 SHA512 1f52437f71829430d8f3028ab61738f4d1338268374fefba5d6ce478c7be813445ee19302fc76e090abc42ede1babdfecfbdb1e4fc592de4c7a265fa86feba90 WHIRLPOOL 3b0d27575808f67a0f40da2fd42529250af955b40cc26f498823f43d766f003023257466bc4e51ab8474575f730087bf67f855763784518e6dc652713aeff082
+EBUILD downthemall-2.0.17.ebuild 840 SHA256 f623cc1fbc386b002d47fd46a3c094e028f4278a7fe7e822dd19d54cfc173600 SHA512 dba3bbbfb4c0b21ad2edc8d4ff9fcf6a36fd285ff296f36a1ac19fa14970a20b36fb83ca59deb218165da64ffaf3f80f9b866cb90fecb84b3aebc0d38aedc1a5 WHIRLPOOL 961f00466fc921ec74647390172ed5dd6354b5b0434b1c208ef6914aa11c7682cfa11e6b85918a4e3eec9b88227bacf8749b929d38e3263a4b9fef05b8c49c78
+EBUILD downthemall-9999.ebuild 989 SHA256 4cb8cc2c7eb7f204025a624e68f16b179cdb39176d25f55136fb52bc110742e3 SHA512 f90190c39b8f6ca84e1c07f7498c48243fcbdc230e0d5f408ce671e9796dd231985b1791d3e06a6ac159257c17d91d244458eee930c16b3ec5673444af692b68 WHIRLPOOL 208ebcaa47f37f921f58be1ae0e5c116de19b53a4f26f507b70d5dd8cb5a4c3ac8f1d1a39bb6fb3f4ce81fa527e17dde1ed67a87930964398da4f24f7b4a8622
diff --git a/www-plugins/downthemall/downthemall-2.0.17.ebuild b/www-plugins/downthemall/downthemall-2.0.17.ebuild
new file mode 100644
index 0000000..b0df41b
--- /dev/null
+++ b/www-plugins/downthemall/downthemall-2.0.17.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_FILEID="256360"
+DESCRIPTION="The first and only download manager/accelerator built inside Firefox!"
+HOMEPAGE="http://www.downthemall.net"
+SRC_URI="http://addons.mozilla.org/downloads/file/${MOZ_FILEID} -> ${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+symlink_all_targets target_firefox target_firefox-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="firefox firefox-bin"
+else
+ use target_firefox && MZA_TARGETS+=" firefox"
+ use target_firefox-bin && MZA_TARGETS+=" firefox-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_firefox? ( www-client/firefox )
+ target_firefox-bin? ( www-client/firefox-bin )
+ )"
diff --git a/www-plugins/downthemall/downthemall-9999.ebuild b/www-plugins/downthemall/downthemall-9999.ebuild
new file mode 100644
index 0000000..3d6fc9f
--- /dev/null
+++ b/www-plugins/downthemall/downthemall-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_ADDON_ID=201
+DESCRIPTION="The first and only download manager/accelerator built inside Firefox!"
+HOMEPAGE="http://www.downthemall.net"
+SRC_URI="http://addons.mozilla.org/downloads/latest/${MOZ_ADDON_ID} -> ${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+symlink_all_targets target_firefox target_firefox-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="firefox firefox-bin"
+else
+ use target_firefox && MZA_TARGETS+=" firefox"
+ use target_firefox-bin && MZA_TARGETS+=" firefox-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_firefox? ( www-client/firefox )
+ target_firefox-bin? ( www-client/firefox-bin )
+ )"
+
+pkg_postinst() {
+ ewarn "This ebuild installs the latest STABLE version !"
+ ewarn "It is used by the maintainer to check for new versions ..."
+}
diff --git a/www-plugins/enigmail/Manifest b/www-plugins/enigmail/Manifest
new file mode 100644
index 0000000..4dee64f
--- /dev/null
+++ b/www-plugins/enigmail/Manifest
@@ -0,0 +1,3 @@
+DIST enigmail-1.7.2.tar.gz 1420346 SHA256 7b3a62e83961bafec1cdac60075aa6c317c8f655a837e31a7d1f3ce6a49fc7d6 SHA512 e121308127d25d658db804bcd49e37b609fe7a52c2b2f4b0e5cd5c90106157642e164b7f9e31ef419e89a60326af93ce007e6d04ecea714e4b933b01007fee10 WHIRLPOOL 8e226445556cbf31dc55c924f8d2367d4a497eff385fb31128be03dd0650d32251e37a99aba9806b1a019cc124b717f2e97a8341bd4e01dcc39be6580fe27a24
+DIST enigmail-1.7.2.xpi 1292322 SHA256 1e113740da3c2186a91504b8107bcec38b9c13f58de52f9e60de2f8ad8a26277 SHA512 f05d090f071b5bb22e25371cfb05c161dadd82197c2280a5f72b7c47da3a8bed3a9c280b405d8723618b5142ddcb5b9270abe3241ad986c5ae9ba1acf0899c3b WHIRLPOOL 3c875bc48ce917a5554e0b4a0fb09d92e5bf6224d8097c5d013ff7bee1e21d793339269940ba0141ac3763ae489135e64863e97f0f194da70e4d13a2dc44a770
+EBUILD enigmail-1.7.2.ebuild 2257 SHA256 5de6b697463f8e320c60fe2c1c701bd2b7702fd69fcee7b1d38dec8cdc358543 SHA512 ce6ec69b2e4191ced26e57e712ac31d3169697745d5507b2ae896047e66bfca304799f01d265fb766cb08280c1acce3d08b15f1398ae103fb192a0e8558ee6de WHIRLPOOL e672f5aa19b078501e25716a155a15f854120a98b23bd5d573fb784968f39bc2538cfa9dc4d2a8e93cf213325e37a4042a8e5d19542a7e837fad86c095cde92f
diff --git a/www-plugins/enigmail/enigmail-1.7.2.ebuild b/www-plugins/enigmail/enigmail-1.7.2.ebuild
new file mode 100644
index 0000000..b9ecfe4
--- /dev/null
+++ b/www-plugins/enigmail/enigmail-1.7.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_FILEID="283972"
+DESCRIPTION="OpenPGP message encryption and authentication for Thunderbird and SeaMonkey."
+HOMEPAGE="http://www.enigmail.net"
+# SRC_URI="http://www.enigmail.net/download/release/1.7/enigmail-1.7.2-tb+sm.xpi -> ${P}.xpi"
+SRC_URI="
+ binary? ( http://www.enigmail.net/download/release/1.7/enigmail-1.7.2-tb+sm.xpi -> ${P}.xpi )
+ !binary? ( http://www.enigmail.net/download/source/${P}.tar.gz )"
+
+LICENSE="MPL-2.0 GPL-2.0+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+symlink_all_targets target_thunderbird target_seamonkey target_thunderbird-bin target_seamonkey-bin +binary"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="thunderbird seamonkey thunderbird-bin seamonkey-bin"
+else
+ use target_thunderbird && MZA_TARGETS+=" thunderbird"
+ use target_thunderbird-bin && MZA_TARGETS+=" thunderbird-bin"
+ use target_seamonkey && MZA_TARGETS+=" seamonkey"
+ use target_seamonkey-bin && MZA_TARGETS+=" seamonkey-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_seamonkey? ( www-client/seamonkey[-crypt] )
+ target_seamonkey-bin? ( www-client/seamonkey-bin )
+ target_thunderbird? ( mail-client/thunderbird[-crypt] )
+ target_thunderbird-bin? ( mail-client/thunderbird-bin )
+ )
+ !www-client/seamonkey[crypt]
+ !mail-client/thunderbird[crypt]
+ || (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk]
+ app-crypt/pinentry[qt4]
+ )
+ )
+ =app-crypt/gnupg-1.4* )"
+
+if use !binary; then
+ S="${WORKDIR}/${PN}"
+ MZA_XPI_PATH="${WORKDIR}/${PN}/build/dist"
+fi
+
+src_unpack() {
+ if use binary; then
+ mozilla-addon_src_unpack
+ else
+ unpack ${A} || die 'unpack failed'
+ fi
+}
+
+src_compile() {
+ if use !binary; then
+ # fails without -j1
+ emake -j1
+ emake -j1 xpi
+ fi
+}
+
+pkg_postinst() {
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gtk*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
+ ewarn "You may be prompted for your password in an inaccessible shell!!"
+ ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end" ;;
+ esac
+}
diff --git a/www-plugins/lightning/Manifest b/www-plugins/lightning/Manifest
new file mode 100644
index 0000000..0e679a5
--- /dev/null
+++ b/www-plugins/lightning/Manifest
@@ -0,0 +1,4 @@
+DIST lightning-3.3.1.xpi 4226304 SHA256 8fce348c32376071373a0a76a325c35eb77a6e4318bda37a367cde4546748a90 SHA512 3c175b6a7398e37bb533dce09116e133aabd5386d669fbbafae4e0142026ad16ded3f78d68cab81161eeb1146111b1c80b5e019b9e5b0eed880514bb5597b33b WHIRLPOOL eda08452da77015642de049086f610d40da183e6bc5976c2e171281add5e0976dbb7c12be27f556a3396dce724947890c2286bb04b2a1c424ccd6e90f7dbe3ab
+DIST lightning-9999.xpi 4226304 SHA256 8fce348c32376071373a0a76a325c35eb77a6e4318bda37a367cde4546748a90 SHA512 3c175b6a7398e37bb533dce09116e133aabd5386d669fbbafae4e0142026ad16ded3f78d68cab81161eeb1146111b1c80b5e019b9e5b0eed880514bb5597b33b WHIRLPOOL eda08452da77015642de049086f610d40da183e6bc5976c2e171281add5e0976dbb7c12be27f556a3396dce724947890c2286bb04b2a1c424ccd6e90f7dbe3ab
+EBUILD lightning-3.3.1.ebuild 927 SHA256 0a63d159f8e2c7385490938f718fbab5a2430863b7844d86952f3b0cba779bdf SHA512 7d5cbb4bcc1bed2313f3d94eb135d4c9d1faf85b23e6415c02f0526dc39358ed65bf1d9bd95ec92fa8e1255e03f40c942fce9bad2927e1f1f86518b2ad843183 WHIRLPOOL 06daa956977846fd1a69a5dabff49aa3c50ee3dd23ce4e6db608a59bcfcff305f3924f6a7161bfd2e70c4609fe76972dbe81404b2f79f68f1cf2a1eea92a1313
+EBUILD lightning-9999.ebuild 1089 SHA256 ffefc10dfcffcbcb9e1a99dd8fcbe6807aaf11388ca1e6cf247f01b40a64381d SHA512 d0cf2e9ece483b71f3827a9c3fee7e2985e9e9fc6aeb2ffb9900556fdcb5d0b5f060c2f703a89112e56af20ede617c83ae80e6f3ca330477343557b8160d61f2 WHIRLPOOL 18834c9af19b87d6c8cd2e6463742002ce78abc601ba70fa468eae71f90b7d3714122d935aa0cf15fa1054d0181450cf976ee4c1e8c4296ad4f64fd5fbabac72
diff --git a/www-plugins/lightning/lightning-3.3.1.ebuild b/www-plugins/lightning/lightning-3.3.1.ebuild
new file mode 100644
index 0000000..73c520e
--- /dev/null
+++ b/www-plugins/lightning/lightning-3.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_FILEID="277302"
+DESCRIPTION="Lightning calendar for Thunderbird"
+HOMEPAGE="http://www.mozilla.org/en-US/projects/calendar/"
+SRC_URI="http://addons.mozilla.org/downloads/file/${MOZ_FILEID} -> ${P}.xpi"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+symlink_all_targets target_thunderbird target_thunderbird-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="thunderbird thunderbird-bin"
+else
+ use target_thunderbird && MZA_TARGETS+=" thunderbird"
+ use target_thunderbird-bin && MZA_TARGETS+=" thunderbird-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_thunderbird? ( mail-client/thunderbird[-lightning] )
+ target_thunderbird-bin? ( mail-client/thunderbird-bin )
+ )
+ !mail-client/thunderbird[lightning]"
diff --git a/www-plugins/lightning/lightning-9999.ebuild b/www-plugins/lightning/lightning-9999.ebuild
new file mode 100644
index 0000000..2dfa59d
--- /dev/null
+++ b/www-plugins/lightning/lightning-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_ADDON_ID=2313
+DESCRIPTION="Lightning calendar for Thunderbird"
+HOMEPAGE="http://www.mozilla.org/en-US/projects/calendar/"
+SRC_URI="http://addons.mozilla.org/downloads/latest/${MOZ_ADDON_ID}/platform:2/ -> ${P}.xpi"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+symlink_all_targets target_thunderbird target_thunderbird-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="thunderbird thunderbird-bin"
+else
+ use target_thunderbird && MZA_TARGETS+=" thunderbird"
+ use target_thunderbird-bin && MZA_TARGETS+=" thunderbird-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_thunderbird? ( mail-client/thunderbird[-lightning] )
+ target_thunderbird-bin? ( mail-client/thunderbird-bin )
+ )
+ !mail-client/thunderbird[lightning]"
+
+pkg_postinst() {
+ ewarn "This ebuild installs the latest STABLE version !"
+ ewarn "It is used by the maintainer to check for new versions ..."
+}
diff --git a/www-plugins/multi_links/Manifest b/www-plugins/multi_links/Manifest
new file mode 100644
index 0000000..7331886
--- /dev/null
+++ b/www-plugins/multi_links/Manifest
@@ -0,0 +1,4 @@
+DIST multi_links-3.0.0.19.xpi 38090 SHA256 2712fb1c9f11306f95c3398e02aeaee4a134b09aac83ac48d563e61d2a7847f2 SHA512 a80395bf8236b0ed398dbe0f7eac414f6b7e38f2a3a294b634b1d698e04713f65451dd2faae79075ce4eef01d134b21e2ea75ddde6f4cfdc2428436dab984295 WHIRLPOOL daac2cd57aaa98d855ace58cac0bfb03464e4e9f83700cd9f7a1e0dc6394fa0d2150df5fd88486123480f2b0bcd67f3045d41cf62fe950cdc8c8951e5d5d1bee
+DIST multi_links-9999.xpi 38090 SHA256 2712fb1c9f11306f95c3398e02aeaee4a134b09aac83ac48d563e61d2a7847f2 SHA512 a80395bf8236b0ed398dbe0f7eac414f6b7e38f2a3a294b634b1d698e04713f65451dd2faae79075ce4eef01d134b21e2ea75ddde6f4cfdc2428436dab984295 WHIRLPOOL daac2cd57aaa98d855ace58cac0bfb03464e4e9f83700cd9f7a1e0dc6394fa0d2150df5fd88486123480f2b0bcd67f3045d41cf62fe950cdc8c8951e5d5d1bee
+EBUILD multi_links-3.0.0.19-r2.ebuild 863 SHA256 277db4d0d6efd69acbc42cfd55e819ceeff0f060409e13416954c43a40c0602b SHA512 85a0dae4566111645c3c976f05f1cd2a095431d7fc757b8f91af4d7f13acf386013348f7705583061aa3c9807011623f7518041065d48bd7669ba0957040c384 WHIRLPOOL 7754cce0ae121e40c2f61e0453cdd5257050fbff2ab9907c2af56599943bae1af76ce9580584fef047b5d6330b1f2838c936468e0f282928f2e9014221429a26
+EBUILD multi_links-9999.ebuild 1014 SHA256 3474df8c10ff96251df0427f47d7d9e0d9eea09a01c2cbc10cfa761c1e49a22c SHA512 e9f1bc3898ae49baba076091c922f5a3c181268f4f1f673c985955df9e044162f229e8f2f0e2a2b92e2af526744af93af460836e88c7924c9c38a7b5c86efed2 WHIRLPOOL e6844535599b2e06349c5e69e3dafaf5bda92326f8549a80b4953366995583418e4f9c14072f1af26e11cf9e6e4eb64e0143a408915b2086d8be36f703ea08bc
diff --git a/www-plugins/multi_links/multi_links-3.0.0.19-r2.ebuild b/www-plugins/multi_links/multi_links-3.0.0.19-r2.ebuild
new file mode 100644
index 0000000..8e2330b
--- /dev/null
+++ b/www-plugins/multi_links/multi_links-3.0.0.19-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_FILEID="139561"
+DESCRIPTION="Firefox extension open, copy or bookmark multiple links at the same time"
+HOMEPAGE="http://www.grizzlyape.com/addons/multi-links/"
+SRC_URI="http://addons.mozilla.org/downloads/file/${MOZ_FILEID} -> ${P}.xpi"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+symlink_all_targets target_firefox target_firefox-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="firefox firefox-bin"
+else
+ use target_firefox && MZA_TARGETS+=" firefox"
+ use target_firefox-bin && MZA_TARGETS+=" firefox-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_firefox? ( www-client/firefox )
+ target_firefox-bin? ( www-client/firefox-bin )
+ )"
diff --git a/www-plugins/multi_links/multi_links-9999.ebuild b/www-plugins/multi_links/multi_links-9999.ebuild
new file mode 100644
index 0000000..794462f
--- /dev/null
+++ b/www-plugins/multi_links/multi_links-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_ADDON_ID=13494
+DESCRIPTION="Firefox extension open, copy or bookmark multiple links at the same time"
+HOMEPAGE="http://www.grizzlyape.com/addons/multi-links/"
+SRC_URI="http://addons.mozilla.org/downloads/latest/${MOZ_ADDON_ID} -> ${P}.xpi"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+symlink_all_targets target_firefox target_firefox-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="firefox firefox-bin"
+else
+ use target_firefox && MZA_TARGETS+=" firefox"
+ use target_firefox-bin && MZA_TARGETS+=" firefox-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_firefox? ( www-client/firefox )
+ target_firefox-bin? ( www-client/firefox-bin )
+ )"
+
+pkg_postinst() {
+ ewarn "This ebuild installs the latest STABLE version !"
+ ewarn "It is used by the maintainer to check for new versions ..."
+}
diff --git a/www-plugins/provider_for_google_calendar/Manifest b/www-plugins/provider_for_google_calendar/Manifest
new file mode 100644
index 0000000..14b930b
--- /dev/null
+++ b/www-plugins/provider_for_google_calendar/Manifest
@@ -0,0 +1,4 @@
+DIST provider_for_google_calendar-1.0.2.xpi 70117 SHA256 a16fb5112983d42970ec57682b843b0cc3b53083c2dee7a38713a5df887c8122 SHA512 d096c7da23a1ccee2f616ee2ac2a99d7f3647560a0abd109af78ebac204e4eba67513a725cee7457d6370d61e8dea4c2e3a6296a5d1844e0b68d88a5c41c8b3e WHIRLPOOL b5d3932df1628a68eedb6f1424dcddeef2c7a02a8635266fdb2d41b264ed2fbef25cf60fa1261842a0ce3059991fe5640f04e3b9df4e38d5bb3c66a2842c9631
+DIST provider_for_google_calendar-9999.xpi 52362 SHA256 dff2b055f844c6ca58a64c4d5e49160af63d1a1c3c8ffd533b95a60ee50d1c95 SHA512 b77b9b9c21b3ff459e83b187a247ce15d87c3550cc99aceda800270e60773c1f1e60a29133a46258f9b6d821050c24ce9dd68637e93f16730c259d0acda3a7aa WHIRLPOOL 4268288ded1f8c986f2d2944fad8709dc2e9f30db6effb6a258c16e1ac82c350247a9db06fe7209cb16bd01391f76fba9531e0dcfedd1f8f3b861e25ec4f53cb
+EBUILD provider_for_google_calendar-1.0.2.ebuild 997 SHA256 79047fb872184fa5d94b83abc099d0fcf8c8199a08ad61a540d5cd2154c9b102 SHA512 73ad7be25794c9b92786fdda2d7d25f40219b1871b7c5831111c501a99be5fa13dac47ae7a00a49d296dcfce91a0a5e056744b175e0484771b9d7ebd24083c90 WHIRLPOOL f373d02035b593bb59c6e2cfd9992461c0f4ad6353bed72e94576bc7bbc9e20423b320202d4f8e3230011992fd24f5135d5e0b5d2398dec37f2216cd85466ba7
+EBUILD provider_for_google_calendar-9999.ebuild 1145 SHA256 07439d2cfecbdda059994b658b5b6118c33f0825de2c9efa4e5e44a77b9c0907 SHA512 809ecc86521cd24745453ef0d68463993ef1371259fdaf428f27c0d3c0722a645866188f19a4ddc5cc1a81bead6a76e14356a43d2959290bf0a896188eff465c WHIRLPOOL ae46483f14bed92802aad0a6da77b30d61957076d6ac31b06df7379c19a9a8d1685995940f0296e5cb0a7735186dbebc94afda9d655dd5716c005bb0cc6808cb
diff --git a/www-plugins/provider_for_google_calendar/provider_for_google_calendar-1.0.2.ebuild b/www-plugins/provider_for_google_calendar/provider_for_google_calendar-1.0.2.ebuild
new file mode 100644
index 0000000..15c7ada
--- /dev/null
+++ b/www-plugins/provider_for_google_calendar/provider_for_google_calendar-1.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_FILEID="281202"
+DESCRIPTION="Allows Lightning to read and write events and tasks to a Google Calendar"
+HOMEPAGE="http://addons.mozilla.org/en-us/thunderbird/addon/provider-for-google-calendar/"
+SRC_URI="http://addons.mozilla.org/downloads/file/${MOZ_FILEID} -> ${P}.xpi"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+symlink_all_targets target_thunderbird target_thunderbird-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="thunderbird thunderbird-bin"
+else
+ use target_thunderbird && MZA_TARGETS+=" thunderbird"
+ use target_thunderbird-bin && MZA_TARGETS+=" thunderbird-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_thunderbird? ( mail-client/thunderbird[-lightning] )
+ target_thunderbird-bin? ( mail-client/thunderbird-bin )
+ )
+ !mail-client/thunderbird[lightning]"
diff --git a/www-plugins/provider_for_google_calendar/provider_for_google_calendar-9999.ebuild b/www-plugins/provider_for_google_calendar/provider_for_google_calendar-9999.ebuild
new file mode 100644
index 0000000..1802faa
--- /dev/null
+++ b/www-plugins/provider_for_google_calendar/provider_for_google_calendar-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_ADDON_ID=4631
+DESCRIPTION="Allows Lightning to read and write events and tasks to a Google Calendar"
+HOMEPAGE="http://addons.mozilla.org/en-us/thunderbird/addon/provider-for-google-calendar/"
+SRC_URI="http://addons.mozilla.org/downloads/file/${MOZ_ADDON_ID} -> ${P}.xpi"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+symlink_all_targets target_thunderbird target_thunderbird-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="thunderbird thunderbird-bin"
+else
+ use target_thunderbird && MZA_TARGETS+=" thunderbird"
+ use target_thunderbird-bin && MZA_TARGETS+=" thunderbird-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_thunderbird? ( mail-client/thunderbird[-lightning] )
+ target_thunderbird-bin? ( mail-client/thunderbird-bin )
+ )
+ !mail-client/thunderbird[lightning]"
+
+pkg_postinst() {
+ ewarn "This ebuild installs the latest STABLE version !"
+ ewarn "It is used by the maintainer to check for new versions ..."
+}
diff --git a/www-plugins/status_4_evar/Manifest b/www-plugins/status_4_evar/Manifest
new file mode 100644
index 0000000..c932d84
--- /dev/null
+++ b/www-plugins/status_4_evar/Manifest
@@ -0,0 +1,4 @@
+DIST status_4_evar-2014.07.06.05.xpi 179297 SHA256 c10025d8a662a48f18903a2c411b29bc79905069acff7cc666b6765fe34198cc SHA512 21736deeecbe2a2fb33ecc94874063441ba0eab5b1184bf8db094e7a86a09e45bd3ed28f258b742de7404abc30120028bbeaa8819d4f3dda3eb135d4418eaa73 WHIRLPOOL 7b2842cc537c2c6545ccfd780d0c47e942da93796d5add96cd13eb7fd07b817371155951fda5be8754841fc42334568ec6148f878c1209b0061a1cc784974b6f
+DIST status_4_evar-9999.xpi 179297 SHA256 c10025d8a662a48f18903a2c411b29bc79905069acff7cc666b6765fe34198cc SHA512 21736deeecbe2a2fb33ecc94874063441ba0eab5b1184bf8db094e7a86a09e45bd3ed28f258b742de7404abc30120028bbeaa8819d4f3dda3eb135d4418eaa73 WHIRLPOOL 7b2842cc537c2c6545ccfd780d0c47e942da93796d5add96cd13eb7fd07b817371155951fda5be8754841fc42334568ec6148f878c1209b0061a1cc784974b6f
+EBUILD status_4_evar-2014.07.06.05.ebuild 886 SHA256 9704d0987f02a409d044b4313b069979ac63c195463c331be05958c6ff81960a SHA512 ba14fc3f3c0462a69e884c9ba5d08e4243d1d30d0156fc5416d9145090966b756c1f0b6032762f8e1907081d1490b680ce428698c21a572ed46f56d16ab4b5c4 WHIRLPOOL 6444f087e29c03ff8227c7428d8ad1ad9761a9163119ffa88ce68a083e782ab9df63b0c34906d1284df7c403e98dea5ad79a39bac2ff7fbd4f147239aff8c3ba
+EBUILD status_4_evar-9999.ebuild 1038 SHA256 97d251e5301be8f5ba17826a170b86d1ed412d31dd8741f034e1700b68be4d61 SHA512 2a6933e7b8705b64764d2cfb4f5cde0048fcd5d79310032c72487c97bc610675f06db27d298e3521667acf1daa148fe738969a7624ff840db3d80eafd1950073 WHIRLPOOL 73ee18786e791065c53b41a3f86028a58e5665944be7ebbdff2c7a6728c360f3c4e54b155f2a2a8dbaf99b93dc60a4a7dd960d5af39a6bf2d2f25f01f280646a
diff --git a/www-plugins/status_4_evar/status_4_evar-2014.07.06.05.ebuild b/www-plugins/status_4_evar/status_4_evar-2014.07.06.05.ebuild
new file mode 100644
index 0000000..c585571
--- /dev/null
+++ b/www-plugins/status_4_evar/status_4_evar-2014.07.06.05.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_FILEID="265690"
+DESCRIPTION="Status bar widgets and progress indicators for Firefox 4+"
+HOMEPAGE="http://addons.mozilla.org/en-US/firefox/addon/status-4-evar/"
+SRC_URI="http://addons.mozilla.org/downloads/file/${MOZ_FILEID} -> ${P}.xpi"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+symlink_all_targets target_firefox target_firefox-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="firefox firefox-bin"
+else
+ use target_firefox && MZA_TARGETS+=" firefox"
+ use target_firefox-bin && MZA_TARGETS+=" firefox-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_firefox? ( www-client/firefox )
+ target_firefox-bin? ( www-client/firefox-bin )
+ )"
diff --git a/www-plugins/status_4_evar/status_4_evar-9999.ebuild b/www-plugins/status_4_evar/status_4_evar-9999.ebuild
new file mode 100644
index 0000000..e98a04f
--- /dev/null
+++ b/www-plugins/status_4_evar/status_4_evar-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_ADDON_ID=235283
+DESCRIPTION="Status bar widgets and progress indicators for Firefox 4+"
+HOMEPAGE="http://addons.mozilla.org/en-US/firefox/addon/status-4-evar/"
+SRC_URI="http://addons.mozilla.org/downloads/latest/${MOZ_ADDON_ID} -> ${P}.xpi"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+symlink_all_targets target_firefox target_firefox-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="firefox firefox-bin"
+else
+ use target_firefox && MZA_TARGETS+=" firefox"
+ use target_firefox-bin && MZA_TARGETS+=" firefox-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_firefox? ( www-client/firefox )
+ target_firefox-bin? ( www-client/firefox-bin )
+ )"
+
+pkg_postinst() {
+ ewarn "This ebuild installs the latest STABLE version !"
+ ewarn "It is used by the maintainer to check for new versions ..."
+}