summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/starpu/Manifest1
-rw-r--r--dev-libs/starpu/metadata.xml22
-rw-r--r--dev-libs/starpu/starpu-1.1.5.ebuild84
3 files changed, 0 insertions, 107 deletions
diff --git a/dev-libs/starpu/Manifest b/dev-libs/starpu/Manifest
deleted file mode 100644
index e0dda49..0000000
--- a/dev-libs/starpu/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST starpu-1.1.5.tar.gz 5209660 SHA256 3b93d3d54b2bd4c96d49ca4a46f6d4ed077c7d7602baa2044152ef55ad5d9b15 SHA512 e22a51c601c1997f6a9279e87b22a96f2b25a9c8bb4b715ee3a048ed8af638997610ba72c7b42f61d9401464464c57402feebc76368f9df6ca84fa1305baeedd WHIRLPOOL dc2e17be76b58e5c2c902f653d2e2cf4961cf2618347d2f7ebe7b7597c0c5abfb93690e117ded809ae9f84586b380e8355fd8767a09974a479b06c76addd48b7
diff --git a/dev-libs/starpu/metadata.xml b/dev-libs/starpu/metadata.xml
deleted file mode 100644
index 362d944..0000000
--- a/dev-libs/starpu/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer>
- <email>bicatali@gentoo.org</email>
- <description>Feel free to update and/or fix</description>
-</maintainer>
-<longdescription lang='en'>
- StarPU is a runtime system that offers support for heterogeneous
- multicore machines. While many efforts are devoted to design efficient
- computation kernels for those architectures (e.g. to implement BLAS
- kernels on GPUs or on Cell's SPUs), StarPU not only takes care of
- offloading such kernels (and implementing data coherency across
- the machine), but it also makes sure the kernels are executed as
- efficiently as possible.
-</longdescription>
-<use>
- <flag name="cuda">Enable NVIDIA CUDA toolkit support</flag>
- <flag name="gcc-plugin">Enable GCC extension plugin (experimental)</flag>
- <flag name="opencl">Enable OpenCL support</flag>
-</use>
-</pkgmetadata>
diff --git a/dev-libs/starpu/starpu-1.1.5.ebuild b/dev-libs/starpu/starpu-1.1.5.ebuild
deleted file mode 100644
index 73f5a66..0000000
--- a/dev-libs/starpu/starpu-1.1.5.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils toolchain-funcs cuda
-
-DESCRIPTION="Unified runtime system for heterogeneous multicore architectures"
-HOMEPAGE="http://runtime.bordeaux.inria.fr/StarPU/"
-SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-IUSE="blas cuda debug doc examples fftw gcc-plugin mpi opencl opengl qt4
- static-libs test"
-
-RDEPEND="
- sys-apps/hwloc:0=
- sci-mathematics/glpk:0=
- blas? ( virtual/blas )
- cuda? ( dev-util/nvidia-cuda-toolkit
- x11-drivers/nvidia-drivers
- blas? ( sci-libs/magma ) )
- fftw? ( sci-libs/fftw:3.0= )
- mpi? ( virtual/mpi )
- opencl? ( virtual/opencl )
- opengl? ( media-libs/freeglut:0= )
- qt4? ( >=dev-qt/qtgui-4.7:4
- >=dev-qt/qtopengl-4.7:4
- >=dev-qt/qtsql-4.7:4
- x11-libs/qwt:5 )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen virtual/latex-base )
- test? ( gcc-plugin? ( dev-scheme/guile ) )"
-
-src_prepare() {
- # upstream did not want the patches so apply sed's
- sed -i -e 's/-O3 $CFLAGS/$CFLAGS/' configure.ac || die
- sed -i -e '/Libs.private/s/@LDFLAGS@//g' *.pc.in */*.pc.in || die
- autotools-utils_src_prepare
- use cuda && cuda_src_prepare
-}
-
-src_configure() {
- use blas && export BLAS_LIBS="$($(tc-getPKG_CONFIG) --libs blas)"
-
- local myeconfargs=(
- --disable-build-examples
- $(use_enable cuda)
- $(use_enable debug)
- $(use_enable doc build-doc)
- $(use_enable fftw starpufft)
- $(use_enable gcc-plugin gcc-extensions)
- $(use_enable opencl)
- $(use_enable opengl opengl-render)
- $(use_enable qt4 starpu-top)
- $(use_with mpi mpicc "$(type -P mpicc)")
- $(use cuda && use_enable blas magma)
- $(use mpi && use_enable test mpi-check)
- )
- autotools-utils_src_configure
-}
-
-src_test() {
- autotools-utils_src_test -j1 showcheck
-}
-
-src_install() {
- autotools-utils_src_install
- if use doc; then
- dodoc "${BUILD_DIR}"/doc/doxygen/*.pdf
- dohtml -r "${BUILD_DIR}"/doc/doxygen/html/*
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}